gnu: Remove unneeded uses of 'libiconv'.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages rsync)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages acl)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages digest)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages popt)
32 #:use-module ((guix licenses) #:prefix license:)
33 #:use-module (guix packages)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module (guix build-system cmake)
37 #:use-module (guix build-system gnu))
38
39 (define-public rsync
40 (package
41 (name "rsync")
42 (version "3.2.3")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
46 version ".tar.gz"))
47 (sha256
48 (base32
49 "03p5dha9g9krq61mdbcrjkpz5nglri0009ks2vs9k97f9i83rk5y"))))
50 (build-system gnu-build-system)
51 (arguments
52 `(#:configure-flags
53 ;; The bundled copies are preferred by default.
54 (list "--without-included-zlib"
55 "--without-included-popt"
56 ;; Avoid these dependencies for now.
57 "--disable-openssl")))
58 (native-inputs
59 (list perl))
60 (inputs
61 (list acl
62 lz4
63 popt
64 xxhash
65 zlib
66 `(,zstd "lib")))
67 (synopsis "Remote (and local) file copying tool")
68 (description
69 "Rsync is a fast and versatile file copying tool. It can copy locally,
70 to/from another host over any remote shell, or to/from a remote rsync daemon.
71 Its delta-transfer algorithm reduces the amount of data sent over the network
72 by sending only the differences between the source files and the existing
73 files in the destination.")
74 (license license:gpl3+)
75 (home-page "https://rsync.samba.org/")))
76
77 (define-public librsync
78 (package
79 (name "librsync")
80 (version "2.3.2")
81 (source (origin
82 (method git-fetch)
83 (uri (git-reference
84 (url "https://github.com/librsync/librsync")
85 (commit (string-append "v" version))))
86 (file-name (git-file-name name version))
87 (sha256
88 (base32
89 "0bn29npmbw26akc6y54661irpdh6qcivcs6q48cgp3llklhhxp0q"))))
90 (build-system cmake-build-system)
91 (inputs
92 (list popt))
93 (native-inputs
94 (list which perl))
95 (home-page "http://librsync.sourceforge.net/")
96 (synopsis "Implementation of the rsync remote-delta algorithm")
97 (description
98 "Librsync is a free software library that implements the rsync
99 remote-delta algorithm. This algorithm allows efficient remote updates of a
100 file, without requiring the old and new versions to both be present at the
101 sending end. The library uses a \"streaming\" design similar to that of zlib
102 with the aim of allowing it to be embedded into many different applications.")
103 (license license:lgpl2.1+)))
104
105 (define-public librsync-0.9
106 (package
107 (inherit librsync)
108 (version "0.9.7")
109 (source (origin
110 (method url-fetch)
111 (uri (string-append "mirror://sourceforge/librsync/librsync/"
112 version "/librsync-" version ".tar.gz"))
113 (sha256
114 (base32
115 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
116 (build-system gnu-build-system)
117 (arguments '(#:configure-flags '("--enable-shared")))
118 (inputs '())))