gnu: Remove unneeded uses of 'libiconv'.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
7 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages libidn)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages libunistring)
29 #:use-module (guix licenses)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public libidn
35 (package
36 (name "libidn")
37 (version "1.37")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/libidn/libidn-" version
41 ".tar.gz"))
42 (sha256
43 (base32
44 "1hljls9rkilh04dwiwg388wk8djkac8idijrdysqq2nqbh6rg3iw"))))
45 (build-system gnu-build-system)
46 ;; FIXME: No Java and C# libraries are currently built.
47 (arguments
48 `(#:configure-flags '("--disable-static")))
49 (synopsis "Internationalized string processing library")
50 (description
51 "libidn is a library implementing of the Stringprep, Punycode and IDNA
52 specifications. These are used to encode and decode internationalized domain
53 names according to the IDNA2003 specifications. It includes native C, C# and
54 Java libraries.")
55 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
56 ;; the command line tool is gpl3+.
57 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
58 (home-page "https://www.gnu.org/software/libidn/")))
59
60 (define-public libidn2
61 (package
62 (name "libidn2")
63 (version "2.3.1")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "mirror://gnu/libidn/" name "-" version
67 ".tar.gz"))
68 (sha256
69 (base32
70 "0b8gsksj2g9f4iywwdma3v4jcg7i9rqvdxfmclwvbf1n72a89xla"))))
71 (inputs
72 (list libunistring))
73 (build-system gnu-build-system)
74 (arguments
75 `(#:configure-flags '("--disable-static")))
76 (synopsis "Internationalized domain name library for IDNA2008")
77 (description "Libidn2 is an internationalized domain library implementing
78 the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
79 implementation, but has yet to be as extensively used as the original Libidn
80 library.")
81 (home-page "https://www.gnu.org/software/libidn/#libidn2")
82 (properties '((ftp-directory . "/gnu/libidn")))
83 ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
84 ;; GPL2+ or LGPL3+.
85 (license (list gpl2+ gpl3+ lgpl3+))))