gnu: Remove unneeded uses of 'libiconv'.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Nikita <nikita@n0.is>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
10 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
11 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
12 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
13 ;;; Copyright © 2021 WinterHound <winterhound@yandex.com>
14 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages irc)
32 #:use-module (guix gexp)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module (guix utils)
37 #:use-module (guix packages)
38 #:use-module (guix utils)
39 #:use-module (guix build-system cmake)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system meson)
42 #:use-module (guix build-system python)
43 #:use-module (guix build-system qt)
44 #:use-module (gnu packages)
45 #:use-module (gnu packages admin)
46 #:use-module (gnu packages aspell)
47 #:use-module (gnu packages autogen)
48 #:use-module (gnu packages autotools)
49 #:use-module (gnu packages base)
50 #:use-module (gnu packages backup)
51 #:use-module (gnu packages boost)
52 #:use-module (gnu packages check)
53 #:use-module (gnu packages code)
54 #:use-module (gnu packages compression)
55 #:use-module (gnu packages curl)
56 #:use-module (gnu packages cyrus-sasl)
57 #:use-module (gnu packages databases)
58 #:use-module (gnu packages file)
59 #:use-module (gnu packages gettext)
60 #:use-module (gnu packages geo)
61 #:use-module (gnu packages glib)
62 #:use-module (gnu packages gnome)
63 #:use-module (gnu packages gnupg)
64 #:use-module (gnu packages gtk)
65 #:use-module (gnu packages guile)
66 #:use-module (gnu packages lua)
67 #:use-module (gnu packages lxqt)
68 #:use-module (gnu packages ncurses)
69 #:use-module (gnu packages openldap)
70 #:use-module (gnu packages kde)
71 #:use-module (gnu packages kde-frameworks)
72 #:use-module (gnu packages password-utils)
73 #:use-module (gnu packages pcre)
74 #:use-module (gnu packages perl)
75 #:use-module (gnu packages pkg-config)
76 #:use-module (gnu packages python)
77 #:use-module (gnu packages python-crypto)
78 #:use-module (gnu packages python-xyz)
79 #:use-module (gnu packages regex)
80 #:use-module (gnu packages ruby)
81 #:use-module (gnu packages sphinx)
82 #:use-module (gnu packages sqlite)
83 #:use-module (gnu packages qt)
84 #:use-module (gnu packages tcl)
85 #:use-module (gnu packages textutils)
86 #:use-module (gnu packages time)
87 #:use-module (gnu packages tls)
88 #:use-module (gnu packages web)
89 #:use-module (srfi srfi-1)
90 #:use-module (srfi srfi-26))
91
92 (define-public quassel
93 (package
94 (name "quassel")
95 (version "0.14.0")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (string-append "https://quassel-irc.org/pub/quassel-"
100 version ".tar.xz"))
101 (sha256
102 (base32
103 "042fzssydvv35jjknziph8iyyjsyrsb2hp3d0ix0bqbagbrpf1q9"))
104 (modules '((guix build utils)))
105 ;; We don't want to install the bundled inxi script.
106 (snippet
107 '(begin
108 (delete-file "data/scripts/inxi")))))
109 (build-system qt-build-system)
110 (arguments
111 ;; The three binaries are not mutually exlusive, and are all built
112 ;; by default.
113 '(#:configure-flags '("-DBUILD_TESTING=ON"
114 ;;"-DWANT_QTCLIENT=OFF"
115 ;;"-DWANT_CORE=OFF"
116 ;;"-DWANT_MONO=OFF"
117 "-DWITH_KDE=OFF"
118 "-DWITH_BUNDLED_ICONS=ON"
119 "-DWITH_OXYGEN_ICONS=ON"
120 ;; This disables link previews.
121 "-DWITH_WEBENGINE=OFF")
122 #:phases
123 (modify-phases %standard-phases
124 (add-after 'unpack 'patch-inxi-reference
125 (lambda* (#:key inputs #:allow-other-keys)
126 (let ((inxi (search-input-file inputs "/bin/inxi")))
127 (symlink inxi "data/scripts/inxi")))))))
128 (native-inputs
129 (list extra-cmake-modules pkg-config qttools))
130 (inputs
131 (list boost
132 inxi-minimal
133 libdbusmenu-qt
134 perl
135 qca
136 qtbase-5
137 qtmultimedia
138 qtscript
139 qtsvg
140 snorenotify
141 sonnet
142 zlib))
143 (home-page "https://quassel-irc.org/")
144 (synopsis "Distributed IRC client")
145 (description "Quassel is a distributed IRC client, meaning that one or more
146 clients can attach to and detach from the central core. It resembles the
147 popular combination of screen and a text-based IRC client such as WeeChat or
148 irssi, but graphical.")
149 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
150
151 (define-public irssi
152 (package
153 (name "irssi")
154 (version "1.2.3")
155 (source (origin
156 (method url-fetch)
157 (uri (string-append "https://github.com/irssi/irssi/"
158 "releases/download/" version "/irssi-"
159 version ".tar.xz"))
160 (sha256
161 (base32
162 "17vninwcdfxw39xl2q55qircckckjk2xlvkvlwgj5lhlxppvyix6"))))
163 (build-system gnu-build-system)
164 (arguments
165 `(#:phases
166 (modify-phases %standard-phases
167 (replace 'configure
168 (lambda* (#:key inputs outputs #:allow-other-keys)
169 (let ((out (assoc-ref outputs "out")))
170 (setenv "CONFIG_SHELL" (which "bash"))
171 (invoke "./configure"
172 (string-append "--prefix=" out)
173 (string-append "--enable-true-color")
174 (string-append "--with-proxy")
175 (string-append "--with-socks")
176 (string-append "--with-bot")))))
177 (add-before 'check 'set-home
178 (lambda _
179 (setenv "HOME" (getcwd)))))))
180 (inputs
181 (list glib ncurses openssl perl utf8proc))
182 (native-inputs
183 (list pkg-config))
184 (home-page "https://irssi.org/")
185 (synopsis "Terminal-based IRC client")
186 (description
187 "Irssi is a terminal based IRC client for UNIX systems. It also supports
188 SILC and ICB protocols via plugins.")
189 (license license:gpl2+)))
190
191 (define-public weechat
192 (package
193 (name "weechat")
194 (version "3.4")
195 (source (origin
196 (method url-fetch)
197 (uri (string-append "https://weechat.org/files/src/weechat-"
198 version ".tar.xz"))
199 (sha256
200 (base32
201 "0k5rgdy0c4dnxvsqjzyrr5czz1lmfk1vrsqkkvj8v24y0b3xrlvw"))))
202 (build-system cmake-build-system)
203 (outputs '("out" "doc"))
204 (native-inputs
205 `(("gettext-minimal" ,gettext-minimal)
206 ("pkg-config" ,pkg-config)
207 ,@(if (or (target-x86-64?)
208 (target-x86-32?))
209 `(("ruby-asciidoctor" ,ruby-asciidoctor))
210 '())
211 ;; For tests.
212 ("cpputest" ,cpputest)))
213 (inputs
214 (list aspell
215 curl
216 gnutls
217 libgcrypt
218 ncurses
219 zlib
220 ;; Scripting language plug-ins.
221 guile-3.0
222 lua-5.1
223 perl
224 python
225 ruby
226 tcl))
227 (arguments
228 `(#:configure-flags
229 (list "-DENABLE_PHP=OFF"
230 ,@(if (or (target-x86-64?)
231 (target-x86-32?))
232 '("-DENABLE_MAN=ON"
233 "-DENABLE_DOC=ON")
234 '())
235 "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
236 #:phases
237 (modify-phases %standard-phases
238 ,@(if (or (target-x86-64?)
239 (target-x86-32?))
240 '((add-after 'install 'move-doc
241 (lambda* (#:key outputs #:allow-other-keys)
242 (let* ((out (assoc-ref outputs "out"))
243 (doc (assoc-ref outputs "doc"))
244 (from (string-append out "/share/doc/weechat"))
245 (to (string-append doc "/share/doc/weechat")))
246 (mkdir-p (string-append doc "/share/doc"))
247 (rename-file from to)))))
248 '()))))
249 (synopsis "Extensible chat client")
250 (description "WeeChat (Wee Enhanced Environment for Chat) is an
251 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
252 The client uses a curses frontend, and there are remote interfaces for Web,
253 Qt, Android, and Emacs.
254
255 Everything in WeeChat can be done with the keyboard, though it also supports
256 using a mouse. It is customizable and extensible with plugins and scripts.")
257 (home-page "https://weechat.org/")
258 (license license:gpl3)))
259
260 (define-public srain
261 (package
262 (name "srain")
263 (version "1.3.2")
264 (source
265 (origin
266 (method git-fetch)
267 (uri (git-reference
268 (url "https://github.com/SrainApp/srain")
269 (commit version)))
270 (file-name (git-file-name name version))
271 (sha256
272 (base32 "16nsxicixp7194bkiiyj7zrg05lhcp0xblqsbv6dq1lxd5wd3i96"))))
273 (build-system meson-build-system)
274 (arguments
275 `(#:tests? #f ;there are no tests
276 #:glib-or-gtk? #t))
277 (native-inputs
278 `(("gettext" ,gettext-minimal)
279 ("glib:bin" ,glib "bin")
280 ("pkg-config" ,pkg-config)
281 ("python" ,python-wrapper)
282 ("python-sphinx" ,python-sphinx)))
283 (inputs
284 (list glib-networking
285 gsettings-desktop-schemas
286 gtk+
287 libconfig
288 libsecret
289 libsoup-minimal-2
290 openssl))
291 (home-page "https://srain.im")
292 (synopsis "Modern IRC client written in GTK")
293 (description
294 "Srain is an IRC client written in GTK. It aims to be modern and easy to
295 use while still remaining useful to power users. It also has partial support
296 for the IRCv3 protocol.")
297 (license license:gpl3+)))
298
299 (define-public ircii
300 (package
301 (name "ircii")
302 (version "20210314")
303 (source (origin
304 (method url-fetch)
305 (uri (string-append "https://ircii.warped.com/"
306 name "-" version ".tar.gz"))
307 (sha256
308 (base32
309 "04jczayv1vdn21fcf5zkfaa98sy7d6ydrv2sns2i67gvya2z28j3"))))
310 (build-system gnu-build-system)
311 ;; TODO: We should package a small socks4/5 library/server to configure
312 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
313 ;; is too big.
314 (arguments
315 `(#:tests? #f
316 #:configure-flags (list
317 "--enable-ipv6"
318 "--with-emacs-meta-keys"
319 (string-append "--with-openssl="
320 (assoc-ref %build-inputs "openssl")))
321 #:phases
322 (modify-phases %standard-phases
323 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
324 (lambda* (#:key inputs #:allow-other-keys)
325 (substitute* "bsdinstall"
326 (("/bin/strip") "strip")
327 (("/bin/cp") "cp")
328 (("/bin/chmod") "chmod")
329 (("/etc/chown") "chown")
330 (("/bin/chgrp") "chgrp")
331 (("/bin/mkdir") "mkdir")
332 (("/bin/rm") "rm")
333 (("/bin/mv") "mv")))))))
334 (inputs
335 (list ncurses openssl))
336 (native-inputs
337 (list pkg-config perl))
338 (home-page "http://www.eterna.com.au/ircii/")
339 (synopsis "Terminal-based IRC and ICB client")
340 (description
341 "ircII is a terminal based IRC and ICB client for UNIX systems.")
342 (license license:bsd-3)))
343
344 (define-public catgirl
345 (package
346 (name "catgirl")
347 (version "1.9a")
348 (source (origin
349 (method url-fetch)
350 (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
351 name "-" version ".tar.gz"))
352 (sha256
353 (base32
354 "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
355 (build-system gnu-build-system)
356 (arguments
357 `(#:tests? #f ; no tests
358 #:make-flags (list (string-append "PREFIX=" %output)
359 ,(string-append "CC=" (cc-for-target)))))
360 (native-inputs
361 (list universal-ctags pkg-config))
362 (inputs
363 (list libressl ncurses))
364 (home-page "https://git.causal.agency/catgirl")
365 (synopsis "TLS-only terminal IRC client")
366 (description
367 "@command{catgirl} is a TLS-only terminal IRC client.
368
369 Notable features include:
370 @itemize
371 @item Tab complete: most recently seen or mentioned nicks are completed first.
372 Commas are inserted between multiple nicks.
373 @item Prompt: the prompt clearly shows whether input will be interpreted as a
374 command or sent as a message.
375 @item Split scroll: keeps the latest messages in view while scrolling.
376 @item URL detection: recent URLs from a particular user or matching a
377 substring can be opened or copied.
378 @item Nick coloring: color generation based on usernames remains stable across
379 nick changes. Mentions of users in messages are colored.
380 @item Topic diffing: the modified portion of a channel topic change is
381 highlighted.
382 @end itemize")
383 (license license:gpl3+)))
384
385 (define-public ii
386 (package
387 (name "ii")
388 (version "1.9")
389 (source (origin
390 (method url-fetch)
391 (uri (string-append "http://dl.suckless.org/tools/"
392 name "-" version ".tar.gz"))
393 (sha256
394 (base32
395 "05wcaszm9hap5gqf58bciqm3ad1kfgp976fs3fsn3ll3nliv6345"))))
396 (build-system gnu-build-system)
397 (arguments
398 `(#:tests? #f ; no tests
399 #:make-flags (list (string-append "PREFIX=" %output)
400 ,(string-append "CC=" (cc-for-target)))
401 #:phases
402 (modify-phases %standard-phases
403 (delete 'configure)))) ; no configure
404 (home-page "https://tools.suckless.org/ii/")
405 (synopsis "FIFO and file system based IRC client")
406 (description
407 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
408 (license license:expat)))
409
410 (define-public sic
411 (package
412 (name "sic")
413 (version "1.2")
414 (source (origin
415 (method url-fetch)
416 (uri (string-append "http://dl.suckless.org/tools/"
417 name "-" version ".tar.gz"))
418 (sha256
419 (base32
420 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
421 (build-system gnu-build-system)
422 (arguments
423 `(#:tests? #f ; no tests
424 #:make-flags (list ,(string-append "CC=" (cc-for-target))
425 (string-append "PREFIX=" %output))
426 #:phases
427 (modify-phases %standard-phases
428 (delete 'configure)))) ; no configure
429 (home-page "https://tools.suckless.org/sic/")
430 (synopsis "Simple IRC client")
431 (description
432 "sic is a simple IRC client, even more minimalistic than ii.")
433 (license license:expat)))
434
435 (define-public kirc
436 (package
437 (name "kirc")
438 (version "0.2.9")
439 (source (origin
440 (method git-fetch)
441 (uri (git-reference
442 (url "https://github.com/mcpcpc/kirc")
443 (commit version)))
444 (file-name (git-file-name name version))
445 (sha256
446 (base32 "0ahmfxhgcvnlgmxxbv9vga5x6krab1n7qq55ygj7hj3x7s7ra419"))))
447 (build-system gnu-build-system)
448 (arguments
449 `(#:tests? #f ; no tests
450 #:make-flags
451 (list (string-append "CC=" ,(cc-for-target))
452 (string-append "PREFIX=" %output))
453 #:phases
454 (modify-phases %standard-phases
455 (delete 'configure)))) ; No ./configure script
456 (synopsis "IRC client written in POSIX C99")
457 (description "Kirc is an Internet Relay Chat (IRC) client. It includes
458 support for Simple Authentication and Security Layer (SASL), the
459 client-to-client (CTCP) protocol, simple chat history logging, synchronous
460 message handling, multi-channel joining at server connection, full support for
461 all RFC 2812 commands, and customized color scheme definitions.")
462 (home-page "http://kirc.io/index.html")
463 (license license:expat)))
464
465 (define-public limnoria
466 (package
467 (name "limnoria")
468 (version "2019.11.22")
469 (source
470 (origin
471 (method url-fetch)
472 (uri (pypi-uri "limnoria" version))
473 (sha256
474 (base32 "0853xk1ps3v6lkmfx50wv56vynnzpl84v66hxnhl8i34zl36kk3c"))))
475 (build-system python-build-system)
476 (inputs
477 (list python-pytz
478 python-chardet
479 python-dateutil
480 python-gnupg
481 python-feedparser
482 python-sqlalchemy
483 python-socksipy-branch
484 python-ecdsa))
485 (native-inputs
486 (list python-mock))
487 ;; Despite the existence of a test folder there is no test phase.
488 ;; We need to package https://github.com/ProgVal/irctest and write
489 ;; our own testphase.
490 (arguments
491 `(#:tests? #f))
492 (home-page "https://github.com/ProgVal/Limnoria")
493 (synopsis "Modified version of Supybot (an IRC bot and framework)")
494 (description
495 "Modified version of Supybot with Python 3 and IRCv3 support,
496 embedded web server, translations (fr, fi, it, hu, de), and many
497 other enhancements and bug fixes.")
498 (license license:bsd-3)))
499
500 (define-public epic5
501 (package
502 (name "epic5")
503 (version "2.0.1")
504 (source (origin
505 (method url-fetch)
506 (uri (string-append "http://ftp.epicsol.org/pub/"
507 "epic/EPIC5-PRODUCTION/"
508 name "-" version ".tar.xz"))
509 (sha256
510 (base32
511 "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
512 (build-system gnu-build-system)
513 (arguments
514 `(#:test-target "test"
515 #:phases
516 (modify-phases %standard-phases
517 (add-after 'unpack 'patch-perl
518 (lambda _
519 (substitute* "regress/crash-irc"
520 (("perl5") (which "perl")))
521 #t))
522 (add-after 'unpack 'patch-bsdinstall
523 ;; If we just remove /bin/ some part of the bsdinstall breaks.
524 ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
525 ;; means if we leave /etc/ in, install fails.
526 (lambda _
527 (substitute* "bsdinstall"
528 (("/bin/strip") "strip")
529 (("/bin/cp") "cp")
530 (("/bin/chmod") "chmod")
531 (("/bin/chgrp") "chgrp")
532 (("/bin/mkdir") "mkdir")
533 (("/bin/rm") "rm")
534 (("/bin/mv") "mv")
535 (("/etc/") ""))
536 #t))
537 (replace 'configure
538 (lambda* (#:key outputs #:allow-other-keys)
539 ;; The tarball uses a very old version of autconf. It does not
540 ;; understand extra flags like `--enable-fast-install', so
541 ;; we need to invoke it with just what it understands.
542 (let ((out (assoc-ref outputs "out")))
543 ;; 'configure' doesn't understand '--host'.
544 ,@(if (%current-target-system)
545 `((setenv "CHOST" ,(%current-target-system)))
546 '())
547 (setenv "CONFIG_SHELL" (which "bash"))
548 (setenv "SHELL" (which "bash"))
549 (invoke "./configure"
550 (string-append "--prefix=" out)
551 "--with-ipv6" "--with-libarchive"
552 ;; We use libressl because openssl does not come
553 ;; with the lib/libssl.a which is needed for epic5.
554 ;; XXX: No matter which implementation is chosen,
555 ;; epic5 fails to connect to tls ports of roundrobin
556 ;; irc networks. This however is believed to be an
557 ;; protocol issue at epic5 related to ircd.
558 (string-append "--with-ssl="
559 (assoc-ref %build-inputs "libressl"))
560 (string-append "--with-tcl="
561 (assoc-ref %build-inputs "tcl")
562 "/lib/tclConfig.sh"))))))))
563 (inputs
564 (list libressl
565 ncurses
566 libarchive ; CHANGELOG: "Support for loading zip files"
567 perl
568 tcl
569 ruby))
570 (native-inputs
571 (list pkg-config))
572 (home-page "http://epicsol.org")
573 (synopsis "Epic5 IRC Client")
574 (description
575 "EPIC is a IRC client that has been under active development for
576 over 20 years. It is stable and mature, and offers an excellent ircII
577 interface for those who are accustomed to the ircII way of doing things.")
578 (license (list license:bsd-3
579 license:isc
580 license:bsd-4
581 ;; The epic license is equal to the standard three-clause
582 ;; BSD license except that you are not permitted to remove the
583 ;; "Redistribution is permitted" clause of the license if you
584 ;; distribute binaries.
585 (license:non-copyleft "http://epicsol.org/copyright")))))
586
587 (define-public litterbox
588 (package
589 (name "litterbox")
590 (version "1.8")
591 (source
592 (origin
593 (method url-fetch)
594 (uri (string-append "https://git.causal.agency/litterbox/snapshot/litterbox-"
595 version ".tar.gz"))
596 (sha256
597 (base32 "0ll5d18slngdg2qhaxkvrcq2p1admh0h7sr06wx8347ka0vvrgjl"))))
598 (build-system gnu-build-system)
599 (arguments
600 `(#:tests? #f ; There are no tests.
601 #:make-flags
602 (list
603 (string-append "CC=" ,(cc-for-target))
604 (string-append "PREFIX=" %output))))
605 (native-inputs
606 (list pkg-config universal-ctags))
607 (inputs
608 (list libressl sqlite))
609 (home-page "https://code.causal.agency/june/litterbox")
610 (synopsis "TLS-only IRC logger")
611 (description
612 "@command{litterbox} is a TLS-only IRC logger. It logs
613 events from IRC in a SQLite database, indexing messages for full-text
614 search. It is intended for use with the IRC bouncer @command{pounce},
615 but can also be used independently as a logging bot.")
616 (license license:gpl3+)))
617
618 (define-public inspircd
619 (package
620 (name "inspircd")
621 (version "3.12.0")
622 (source
623 (origin
624 (method git-fetch)
625 (uri (git-reference
626 (url "https://github.com/inspircd/inspircd")
627 (commit (string-append "v" version))))
628 (file-name (git-file-name name version))
629 (sha256
630 (base32 "0xlfs269iaw7dfryzl6vjzqsn2g4nqh6kpf5xfgk3zbjhqaczknx"))))
631 (build-system gnu-build-system)
632 (arguments
633 (list #:configure-flags
634 #~(map (lambda (module)
635 (string-append "--enable-extras=" module))
636 '("m_argon2.cpp"
637 "m_geo_maxmind.cpp"
638 "m_ldap.cpp"
639 "m_mysql.cpp"
640 "m_pgsql.cpp"
641 "m_regex_pcre.cpp"
642 "m_regex_posix.cpp"
643 "m_regex_stdlib.cpp"
644 "m_regex_re2.cpp"
645 "m_regex_tre.cpp"
646 "m_sqlite3.cpp"
647 "m_ssl_gnutls.cpp"
648 "m_ssl_openssl.cpp"
649 "m_ssl_mbedtls.cpp"
650 "m_sslrehashsignal.cpp"))
651 #:tests? #f ; XXX figure out later
652 #:phases
653 #~(modify-phases %standard-phases
654 (add-before 'configure 'module-configure
655 (lambda* (#:key configure-flags #:allow-other-keys)
656 (apply invoke "./configure"
657 configure-flags)))
658 (replace 'configure
659 (lambda _
660 (let ((lib (string-append #$output "/lib/"))
661 (bin (string-append #$output "/bin/"))
662 (etc (string-append #$output "/etc/"))
663 (name "inspircd"))
664 (invoke "./configure"
665 (string-append "--prefix=" lib name)
666 (string-append "--binary-dir=" bin)
667 (string-append "--module-dir=" lib name "/modules/")
668 (string-append "--config-dir=" etc name))))))))
669 (native-inputs
670 (list pkg-config))
671 (inputs
672 (list argon2
673 gnutls
674 libmaxminddb
675 mbedtls-apache
676 mysql
677 openldap
678 openssl
679 `(,pcre "bin")
680 perl
681 postgresql
682 re2
683 sqlite
684 tre))
685 (synopsis "Modular IRC server written in C++")
686 (description "InspIRCd is a modular Internet Relay Chat
687 server written in C++ for Unix-like operating systems.")
688 (home-page "https://www.inspircd.org/")
689 (license license:gpl2)))