gnu: r-opencyto: Update to 2.8.4.
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages onc-rpc)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages gettext)
33 #:use-module (gnu packages kerberos)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix utils))
37
38 (define-public libtirpc
39 (package
40 (name "libtirpc")
41 (version "1.3.1")
42 (replacement libtirpc/fixed)
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
46 version "/libtirpc-"
47 version ".tar.bz2"))
48 (sha256
49 (base32
50 "05zf16ilwwkzv4cccaac32nssrj3rg444n9pskiwbgk6y359an14"))))
51 (build-system gnu-build-system)
52 (arguments
53 `(#:configure-flags '("--disable-static")
54 #:phases
55 (modify-phases %standard-phases
56 (add-after 'unpack 'adjust-netconfig-reference
57 (lambda* (#:key outputs #:allow-other-keys)
58 (substitute* '("man/netconfig.5"
59 "man/getnetconfig.3t"
60 "man/getnetpath.3t"
61 "man/rpc.3t"
62 "src/getnetconfig.c"
63 "tirpc/netconfig.h")
64 (("/etc/netconfig") (string-append (assoc-ref outputs "out")
65 "/etc/netconfig"))))))))
66 (inputs (list mit-krb5))
67 (home-page "https://sourceforge.net/projects/libtirpc/")
68 (synopsis "Transport-independent Sun/ONC RPC implementation")
69 (description
70 "This package provides a library that implements the Sun/ONC RPC (remote
71 procedure calls) protocol in a transport-independent manner. It supports both
72 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
73 (license bsd-3)))
74
75 (define-public libtirpc/hurd
76 (package/inherit libtirpc
77 (name "libtirpc-hurd")
78 (source (origin (inherit (package-source libtirpc))
79 (patches (search-patches "libtirpc-hurd.patch"
80 "libtirpc-CVE-2021-46828.patch"))))
81 (arguments
82 (substitute-keyword-arguments (package-arguments libtirpc)
83 ((#:configure-flags flags ''())
84 ;; When cross-building the target system's krb5-config should be used.
85 `(list (string-append "ac_cv_prog_KRB5_CONFIG="
86 (assoc-ref %build-inputs "mit-krb5")
87 "/bin/krb5-config")))))))
88
89 (define libtirpc/fixed
90 (package
91 (inherit libtirpc)
92 (source (origin
93 (inherit (package-source libtirpc))
94 (patches (search-patches "libtirpc-CVE-2021-46828.patch"))))))
95
96 (define-public rpcbind
97 (package
98 (name "rpcbind")
99 (version "1.2.6")
100 (source
101 (origin
102 (method url-fetch)
103 (uri (string-append "mirror://sourceforge/" name "/" name "/"
104 version "/"
105 name "-" version ".tar.bz2"))
106 (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
107 (sha256
108 (base32 "1pp8xvprsfz8nlmmvxf829gilx0ibb08bfs3lhisxrfai5j784sn"))))
109 (build-system gnu-build-system)
110 (arguments
111 `(#:configure-flags
112 `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
113 (inputs
114 (list libnsl libtirpc))
115 (native-inputs
116 (list pkg-config))
117 (home-page "http://rpcbind.sourceforge.net/")
118 (synopsis "Server to convert RPC program numbers into universal addresses")
119 (description
120 "@command{Rpcbind} is a server that converts RPC program numbers into
121 universal addresses.")
122 (license bsd-3)))
123
124 (define-public rpcsvc-proto
125 (package
126 (name "rpcsvc-proto")
127 (version "1.4")
128 (home-page "https://github.com/thkukuk/rpcsvc-proto")
129 (source (origin
130 (method url-fetch)
131 (uri (string-append home-page "/releases/download/v" version
132 "/rpcsvc-proto-" version ".tar.xz"))
133 (sha256
134 (base32
135 "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
136 (build-system gnu-build-system)
137 (synopsis "RPCSVC protocol definitions")
138 (description
139 "This package provides @code{rpcsvc} @file{protocol.x} files and headers
140 that are not included with the @code{libtirpc} package. Additionally it
141 contains @command{rpcgen}, which is used to produce header files and sources
142 from the protocol files.")
143 (license bsd-3)))
144
145 (define-public libnsl
146 (package
147 (name "libnsl")
148 (version "1.3.0")
149 (source (origin
150 (method git-fetch)
151 (uri (git-reference
152 (url "https://github.com/thkukuk/libnsl")
153 (commit (string-append "v" version))))
154 (file-name (git-file-name name version))
155 (sha256
156 (base32
157 "1dayj5i4bh65gn7zkciacnwv2a0ghm6nn58d78rsi4zby4lyj5w5"))))
158 (build-system gnu-build-system)
159 (arguments
160 `(#:configure-flags '("--disable-static")))
161 (native-inputs
162 `(("autoconf" ,autoconf)
163 ("automake" ,automake)
164 ("gettext" ,gettext-minimal)
165 ("libtool" ,libtool)
166 ("pkg-config" ,pkg-config)))
167 (inputs
168 (list libtirpc))
169 (synopsis "Public client interface for NIS(YP) and NIS+")
170 (description "Libnsl is the public client interface for the Network
171 Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
172 This library was part of glibc < 2.26, but is now distributed separately.")
173 (home-page "https://github.com/thkukuk/libnsl")
174 ;; The package is distributed under the LGPL 2.1. Some files in
175 ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
176 (license lgpl2.1)))