build-system/r: Update to Bioconductor 3.7.
[jackhill/guix/guix.git] / gnu / packages / patches / fontconfig-remove-debug-printf.patch
1 Fontconfig 2.12.5 and 2.12.6 was released with a stray debugging statement.
2 See <https://lists.freedesktop.org/archives/fontconfig/2017-October/006079.html>.
3
4 Patch copied from upstream source repository:
5 https://cgit.freedesktop.org/fontconfig/commit/?id=b56207a069be2574df455ede0a6ab61f44d5ca2b
6
7 diff --git a/fc-query/fc-query.c b/fc-query/fc-query.c
8 index 842a8b6..6cd5abd 100644
9 --- a/fc-query/fc-query.c
10 +++ b/fc-query/fc-query.c
11 @@ -170,7 +170,6 @@ main (int argc, char **argv)
12 FcPattern *pat;
13
14 id = ((instance_num << 16) + face_num);
15 - printf("id %d\n", id);
16 if (FT_New_Face (ftLibrary, argv[i], id, &face))
17 break;
18 num_faces = face->num_faces;