gnu: xorg-server: Update to 21.1.2 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / assembly.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
8 ;;; Copyright © 2019 Andy Tai <atai@atai.org>
9 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
10 ;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
11 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
12 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
13 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages assembly)
31 #:use-module (guix build-system meson)
32 #:use-module (guix build-system cmake)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (guix packages)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages admin)
40 #:use-module (gnu packages autotools)
41 #:use-module (gnu packages base)
42 #:use-module (gnu packages bison)
43 #:use-module (gnu packages compression)
44 #:use-module (gnu packages flex)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages image)
47 #:use-module (gnu packages linux)
48 #:use-module (gnu packages man)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages texinfo)
52 #:use-module (gnu packages python)
53 #:use-module (gnu packages sphinx)
54 #:use-module (gnu packages shells)
55 #:use-module (gnu packages xml)
56 #:use-module ((guix utils)
57 #:select (%current-system cc-for-target)))
58
59 (define-public nasm
60 (package
61 (name "nasm")
62 (version "2.15.05")
63 (source (origin
64 (method url-fetch)
65 (uri (string-append "http://www.nasm.us/pub/nasm/releasebuilds/"
66 version "/nasm-" version ".tar.xz"))
67 (sha256
68 (base32
69 "0gqand86b0r86k3h46dh560lykxmxqqywz5m55kgjfq7q4lngbrw"))))
70 (build-system gnu-build-system)
71 (native-inputs (list perl ;for doc and test target
72 texinfo))
73 (arguments
74 `(#:test-target "test"
75 #:phases
76 (modify-phases %standard-phases
77 (add-after 'unpack 'dont-build-ps-pdf-outputs
78 (lambda _
79 (substitute* "doc/Makefile.in"
80 (("html nasmdoc.txt nasmdoc.pdf \\$\\(XZFILES\\)")
81 "html nasmdoc.txt")
82 (("\\$\\(INSTALL_DATA\\) nasmdoc.pdf")
83 "$(INSTALL_DATA)"))))
84 (add-after 'install 'install-info
85 (lambda _
86 (invoke "make" "install_doc"))))))
87 (home-page "https://www.nasm.us/")
88 (synopsis "80x86 and x86-64 assembler")
89 (description
90 "NASM, the Netwide Assembler, is an 80x86 and x86-64 assembler designed
91 for portability and modularity. It supports a range of object file formats,
92 including Linux and *BSD a.out, ELF, COFF, Mach-O, Microsoft 16-bit OBJ,
93 Windows32 and Windows64. It will also output plain binary files. Its syntax
94 is designed to be simple and easy to understand, similar to Intel's but less
95 complex. It supports all currently known x86 architectural extensions, and
96 has strong support for macros.")
97 (license license:bsd-2)))
98
99 (define-public yasm
100 (package
101 (name "yasm")
102 (version "1.3.0")
103 (source (origin
104 (method url-fetch)
105 (uri (string-append
106 "http://www.tortall.net/projects/yasm/releases/yasm-"
107 version ".tar.gz"))
108 (sha256
109 (base32
110 "0gv0slmm0qpq91za3v2v9glff3il594x5xsrbgab7xcmnh0ndkix"))))
111 (build-system gnu-build-system)
112 (arguments
113 '(#:parallel-tests? #f)) ; Some tests fail
114 ; non-deterministically when run in
115 ; parallel
116 (inputs
117 `(("python" ,python-wrapper)
118 ("xmlto" ,xmlto)))
119 (home-page "https://yasm.tortall.net/")
120 (synopsis "Rewrite of the NASM assembler")
121 (description
122 "Yasm is a complete rewrite of the NASM assembler.
123
124 Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM
125 and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit
126 Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
127 debugging information in STABS, DWARF 2, and CodeView 8 formats.")
128 (license (license:non-copyleft "file://COPYING"
129 "See COPYING in the distribution."))))
130
131 (define-public lightning
132 (package
133 (name "lightning")
134 (version "2.1.3")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://gnu/lightning/lightning-"
138 version ".tar.gz"))
139 (sha256
140 (base32
141 "1jgxbq2cm51dzi3zhz38mmgwdcgs328mfl8iviw8dxn6dn36p1gd"))))
142 (build-system gnu-build-system)
143 (native-inputs (list zlib))
144 (arguments
145 ;; Some tests fail when run in parallel.
146 `(#:parallel-tests? #f))
147 (synopsis "Library for generating assembly code at runtime")
148 (description
149 "GNU Lightning is a library that generates assembly language code at
150 run-time. Thus, it is useful in creating Just-In-Time compilers. It
151 abstracts over the target CPU by exposing a standardized RISC instruction set
152 to the clients.")
153 (home-page "https://www.gnu.org/software/lightning/")
154 (license license:gpl3+)))
155
156 (define-public simde
157 (package
158 (name "simde")
159 (version "0.7.2")
160 (source
161 (origin
162 (method git-fetch)
163 (uri (git-reference
164 (url "https://github.com/simd-everywhere/simde")
165 (commit (string-append "v" version))))
166 (file-name (git-file-name name version))
167 (sha256
168 (base32 "0xkf21gbkgz6zlxabkmgwvy7py6cdnfqx9aplj90gz25gzrr1mkb"))))
169 (build-system meson-build-system)
170 ;; We really want this for the headers, and the tests require a bundled library.
171 (arguments '(#:configure-flags '("-Dtests=false")))
172 (synopsis "Implementations of SIMD instruction sets for foreign systems")
173 (description "The SIMDe header-only library provides fast, portable
174 implementations of SIMD intrinsics on hardware which doesn't natively support
175 them, such as calling SSE functions on ARM. There is no performance penalty if
176 the hardware supports the native implementation (e.g., SSE/AVX runs at full
177 speed on x86, NEON on ARM, etc.).")
178 (home-page "https://simd-everywhere.github.io/blog/")
179 (license license:expat)))
180
181 (define-public fasm
182 (package
183 (name "fasm")
184 (version "1.73.28")
185 (source
186 (origin
187 (method url-fetch)
188 (uri (string-append "https://flatassembler.net/fasm-"
189 version ".tgz"))
190 (sha256
191 (base32 "14ljh0ngdaqlwzsr0l70k09r2d520lqpgswl388p84gxhnsfplcy"))))
192 (build-system gnu-build-system)
193 (arguments
194 `(#:tests? #f ; no tests exist
195 #:strip-binaries? #f ; fasm has no sections
196 #:phases
197 (modify-phases %standard-phases
198 (delete 'configure) ; no "configure" script
199 (replace 'build
200 (lambda _
201 (chdir "source/Linux/")
202 (if (string=? ,(%current-system) "x86_64-linux")
203 ;; Use pre-compiled binaries in top-level directory to build
204 ;; fasm.
205 (invoke "../../fasm.x64" "fasm.asm")
206 (invoke "../../fasm" "fasm.asm"))))
207 (replace 'install
208 (lambda _
209 (let ((out (assoc-ref %outputs "out")))
210 (install-file "fasm" (string-append out "/bin"))))))))
211 (supported-systems '("x86_64-linux" "i686-linux"))
212 (synopsis "Assembler for x86 processors")
213 (description
214 "@acronym{FASM, the Flat ASseMbler} is an assembler that supports x86 and
215 IA-64 Intel architectures. It does multiple passes to optimize machine code.
216 It has macro abilities and focuses on operating system portability.")
217 (home-page "https://flatassembler.net/")
218 (license license:bsd-2)))
219
220 (define-public dev86
221 (package
222 (name "dev86")
223 (version "0.16.21")
224 (source (origin
225 (method url-fetch)
226 (uri (string-append "http://v3.sk/~lkundrak/dev86/Dev86src-"
227 version ".tar.gz"))
228 (sha256
229 (base32
230 "154dyr2ph4n0kwi8yx0n78j128kw29rk9r9f7s2gddzrdl712jr3"))))
231 (build-system gnu-build-system)
232 (arguments
233 `(#:parallel-build? #f ; They use submakes wrong
234 #:make-flags (list ,(string-append "CC=" (cc-for-target))
235 (string-append "PREFIX="
236 (assoc-ref %outputs "out")))
237 #:system "i686-linux" ; Standalone ld86 had problems otherwise
238 #:tests? #f ; No tests exist
239 #:phases
240 (modify-phases %standard-phases
241 (delete 'configure)
242 (add-before 'install 'mkdir
243 (lambda* (#:key outputs #:allow-other-keys)
244 (let ((out (assoc-ref outputs "out")))
245 (mkdir-p (string-append out "/bin"))
246 (mkdir-p (string-append out "/man/man1"))
247 #t))))))
248 (synopsis "Intel 8086 (primarily 16-bit) assembler, C compiler and
249 linker")
250 (description "This package provides a Intel 8086 (primarily 16-bit)
251 assembler, a C compiler and a linker. The assembler uses Intel syntax
252 (also Intel order of operands).")
253 (home-page "https://github.com/jbruchon/dev86")
254 (supported-systems '("i686-linux" "x86_64-linux"))
255 (license license:gpl2+)))
256
257 (define-public libjit
258 (let ((commit "554c9f5c750daa6e13a6a5cd416873c81c7b8226"))
259 (package
260 (name "libjit")
261 (version "0.1.4")
262 (source (origin
263 (method git-fetch)
264 (uri (git-reference
265 (url "https://git.savannah.gnu.org/r/libjit.git")
266 (commit commit)))
267 (file-name (git-file-name name version))
268 (sha256
269 (base32
270 "0p6wklslkkp3s4aisj3w5a53bagqn5fy4m6088ppd4fcfxgqkrcd"))))
271 (build-system gnu-build-system)
272 (native-inputs
273 (list autoconf
274 automake
275 bison
276 flex
277 help2man
278 gettext-minimal
279 libtool
280 texinfo
281 pkg-config))
282 (home-page "https://www.gnu.org/software/libjit/")
283 (synopsis "Just-In-Time compilation library")
284 (description
285 "GNU libjit is a library that provides generic Just-In-Time compiler
286 functionality independent of any particular bytecode, language, or
287 runtime")
288 (license license:lgpl2.1+))))
289
290 (define-public rgbds
291 (package
292 (name "rgbds")
293 (version "0.4.2")
294 (source (origin
295 (method git-fetch)
296 (uri (git-reference
297 (url "https://github.com/gbdev/rgbds")
298 (commit (string-append "v" version))))
299 (file-name (git-file-name name version))
300 (sha256
301 (base32
302 "0lygj7jzjlq4w0mkiir7ycysrd1p1akyvzrppjcchja05mi8wy9p"))))
303 (build-system gnu-build-system)
304 (arguments
305 `(#:phases
306 (modify-phases %standard-phases
307 (delete 'configure)
308 (add-after 'unpack 'patch-pkg-config
309 (lambda _
310 (substitute* "Makefile"
311 (("pkg-config")
312 (or (which "pkg-config")
313 (string-append ,(%current-target-system)
314 "-pkg-config"))))
315 #t))
316 (replace 'check
317 (lambda _
318 (with-directory-excursion "test/asm"
319 (invoke "./test.sh"))
320 (with-directory-excursion "test/link"
321 (invoke "./test.sh")))))
322 #:make-flags `(,(string-append "CC=" ,(cc-for-target))
323 ,(string-append "PREFIX="
324 (assoc-ref %outputs "out")))))
325 (native-inputs
326 (list bison flex pkg-config util-linux))
327 (inputs
328 (list libpng))
329 (home-page "https://github.com/gbdev/rgbds")
330 (synopsis "Rednex Game Boy Development System")
331 (description
332 "RGBDS (Rednex Game Boy Development System) is an assembler/linker
333 package for the Game Boy and Game Boy Color. It consists of:
334 @itemize @bullet
335 @item rgbasm (assembler)
336 @item rgblink (linker)
337 @item rgbfix (checksum/header fixer)
338 @item rgbgfx (PNG-to-Game Boy graphics converter)
339 @end itemize")
340 (license license:expat)))
341
342 (define-public wla-dx
343 (package
344 (name "wla-dx")
345 (version "9.12")
346 (source (origin
347 (method git-fetch)
348 (uri (git-reference
349 (url "https://github.com/vhelin/wla-dx")
350 (commit (string-append "v" version))))
351 (file-name (git-file-name name version))
352 (sha256
353 (base32
354 "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
355 (build-system cmake-build-system)
356 (native-inputs
357 `(("sphinx" ,python-sphinx))) ; to generate man pages
358 (arguments
359 `(#:tests? #f)) ; no tests
360 (home-page "https://github.com/vhelin/wla-dx")
361 (synopsis "Assemblers for various processors")
362 (description "WLA DX is a set of tools to assemble assembly files to
363 object or library files (@code{wla-ARCH}) and link them together (@code{wlalink}).
364 Supported architectures are:
365
366 @itemize @bullet
367 @item z80
368 @item gb (z80-gb)
369 @item 6502
370 @item 65c02
371 @item 6510
372 @item 65816
373 @item 6800
374 @item 6801
375 @item 6809
376 @item 8008
377 @item 8080
378 @item huc6280
379 @item spc700
380 @end itemize")
381 (license license:gpl2)))
382
383 (define-public xa
384 (package
385 (name "xa")
386 (version "2.3.12")
387 (source (origin
388 (method url-fetch)
389 (uri (string-append "https://www.floodgap.com/retrotech/xa"
390 "/dists/xa-" version ".tar.gz"))
391 (sha256
392 (base32
393 "0107zdwc2rzlp26pyx7gns4lqmiyg68nmpgwrg36yrrd04v1bzgq"))))
394 (build-system gnu-build-system)
395 (arguments
396 `(#:tests? #f ; TODO: custom test harness, not sure how it works
397 #:phases
398 (modify-phases %standard-phases
399 (delete 'configure)) ; no "configure" script
400 #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
401 (native-inputs (list perl))
402 (home-page "https://www.floodgap.com/retrotech/xa/")
403 (synopsis "Two-pass portable cross-assembler")
404 (description
405 "xa is a high-speed, two-pass portable cross-assembler.
406 It understands mnemonics and generates code for NMOS 6502s (such
407 as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...),
408 CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.")
409 (license license:gpl2)))
410
411 (define-public armips
412 (package
413 (name "armips")
414 (version "0.11.0")
415 (source
416 (origin
417 (method git-fetch)
418 (uri (git-reference
419 (url "https://github.com/Kingcom/armips")
420 (commit (string-append "v" version))))
421 (file-name (git-file-name name version))
422 (sha256
423 (base32 "1c4dhjkvynqn9xm2vcvwzymk7yg8h25alnawkz4z1dnn1z1k3r9g"))))
424 (build-system cmake-build-system)
425 (arguments
426 `(#:phases
427 (modify-phases %standard-phases
428 (replace 'check
429 (lambda* (#:key inputs #:allow-other-keys)
430 (invoke "./armipstests" "../source/Tests")))
431 (replace 'install
432 (lambda* (#:key outputs #:allow-other-keys)
433 (install-file "armips" (string-append (assoc-ref outputs "out")
434 "/bin"))
435 #t)))))
436 (home-page "https://github.com/Kingcom/armips")
437 (synopsis "Assembler for various ARM and MIPS platforms")
438 (description
439 "armips is an assembler with full support for the MIPS R3000, MIPS R4000,
440 Allegrex and RSP instruction sets, partial support for the EmotionEngine
441 instruction set, as well as complete support for the ARM7 and ARM9 instruction
442 sets, both THUMB and ARM mode.")
443 (license license:expat)))
444
445 (define-public intel-xed
446 (package
447 (name "intel-xed")
448 (version "12.0.1")
449 (source
450 (origin
451 (method git-fetch)
452 (uri (git-reference
453 (url "https://github.com/intelxed/xed")
454 (commit version)))
455 (sha256 (base32 "07zfff8zf29c2n0wal87hiqfq3cwcjn80zz78mz0nyjfj09nd39f"))
456 (file-name (git-file-name name version))
457 (patches (search-patches "intel-xed-fix-nondeterminism.patch"))))
458 (build-system gnu-build-system)
459 (native-inputs
460 `(("python" ,python-wrapper)
461 ("tcsh" ,tcsh)
462 ;; As of the time of writing this comment, mbuild does not exist in the
463 ;; Python Package Index and seems to only be used by intel-xed, so we
464 ;; opt to include it here instead of packaging separately. Note also
465 ;; that the git repository contains no version tags, so we directly
466 ;; reference the "version" variable from setup.py instead.
467 ("mbuild"
468 ,(let ((name "mbuild")
469 (version "0.2496"))
470 (origin
471 (method git-fetch)
472 (uri (git-reference
473 (url "https://github.com/intelxed/mbuild")
474 (commit "3de3f0d753c11dbe634bec611d4cc13f74768e4f")))
475 (sha256
476 (base32
477 "0z8hdhpmk8y5c9429p2yns9daswnffbprni9czkq3vij8f58lkg4"))
478 (file-name (git-file-name name version)))))))
479 (outputs '("out" "lib"))
480 (arguments
481 `(#:phases
482 ;; Upstream uses the custom Python build tool `mbuild', so we munge
483 ;; gnu-build-system to fit. The build process for this package is
484 ;; documented at https://intelxed.github.io/build-manual/.
485 (let* ((build-dir "build")
486 (kit-dir "kit"))
487 (modify-phases %standard-phases
488 (delete 'configure)
489 (replace 'build
490 (lambda* (#:key inputs #:allow-other-keys)
491 (let ((mbuild (assoc-ref inputs "mbuild")))
492 (setenv "PYTHONPATH" mbuild)
493 (invoke "./mfile.py"
494 (string-append "--build-dir=" build-dir)
495 (string-append "--install-dir=" kit-dir)
496 "examples"
497 "doc"
498 "install"))))
499 (replace 'check
500 (lambda _
501 ;; Skip broken test group `tests/tests-avx512pf'.
502 (invoke "tests/run-cmd.py"
503 (string-append "--build-dir=" kit-dir "/bin")
504 "--tests" "tests/tests-base"
505 "--tests" "tests/tests-avx512"
506 "--tests" "tests/tests-cet"
507 "--tests" "tests/tests-via"
508 "--tests" "tests/tests-syntax"
509 "--tests" "tests/tests-xop")))
510 (replace 'install
511 (lambda* (#:key outputs #:allow-other-keys)
512 (let* ((out (assoc-ref outputs "out"))
513 (lib (assoc-ref outputs "lib")))
514 (copy-recursively (string-append kit-dir "/bin")
515 (string-append out "/bin"))
516 (copy-recursively (string-append kit-dir "/include")
517 (string-append lib "/include"))
518 (copy-recursively (string-append kit-dir "/lib")
519 (string-append lib "/lib")))))))))
520 (home-page "https://intelxed.github.io/")
521 (synopsis "Encoder and decoder for x86 (IA32 and Intel64) instructions")
522 (description "The Intel X86 Encoder Decoder (XED) is a software library and
523 for encoding and decoding X86 (IA32 and Intel64) instructions. The decoder
524 takes sequences of 1-15 bytes along with machine mode information and produces
525 a data structure describing the opcode, operands, and flags. The encoder takes
526 a similar data structure and produces a sequence of 1 to 15 bytes. Disassembly
527 is essentially a printing pass on the data structure.
528
529 The library and development files are under the @code{lib} output, with a
530 family of command line utility wrappers in the default output. Each of the cli
531 tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
532 this is a case where ``the code is the documentation.''")
533 (license license:asl2.0)))