gnu: Add kuserfeedback.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
12 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
13 ;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages kde)
31 #:use-module (guix build-system cmake)
32 #:use-module (guix build-system qt)
33 #:use-module (guix deprecation)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (guix packages)
38 #:use-module (guix utils)
39 #:use-module (gnu packages)
40 #:use-module (gnu packages algebra)
41 #:use-module (gnu packages apr)
42 #:use-module (gnu packages audio)
43 #:use-module (gnu packages bison)
44 #:use-module (gnu packages boost)
45 #:use-module (gnu packages code)
46 #:use-module (gnu packages cpp)
47 #:use-module (gnu packages compression)
48 #:use-module (gnu packages curl)
49 #:use-module (gnu packages documentation)
50 #:use-module (gnu packages flex)
51 #:use-module (gnu packages gettext)
52 #:use-module (gnu packages ghostscript)
53 #:use-module (gnu packages gl)
54 #:use-module (gnu packages gnome)
55 #:use-module (gnu packages graphics)
56 #:use-module (gnu packages image)
57 #:use-module (gnu packages kde-frameworks)
58 #:use-module (gnu packages kde-pim)
59 #:use-module (gnu packages kde-plasma)
60 #:use-module (gnu packages linux)
61 #:use-module (gnu packages llvm)
62 #:use-module (gnu packages maths)
63 #:use-module (gnu packages pdf)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages photo)
66 #:use-module (gnu packages pkg-config)
67 #:use-module (gnu packages pulseaudio)
68 #:use-module (gnu packages python)
69 #:use-module (gnu packages tls)
70 #:use-module (gnu packages qt)
71 #:use-module (gnu packages version-control)
72 #:use-module (gnu packages video)
73 #:use-module (gnu packages xdisorg)
74 #:use-module (gnu packages xml)
75 #:use-module (gnu packages xorg))
76
77 (define-public baloo-widgets
78 (package
79 (name "baloo-widgets")
80 (version "20.04.1")
81 (source
82 (origin
83 (method url-fetch)
84 (uri (string-append "mirror://kde/stable/release-service/" version
85 "/src/baloo-widgets-" version ".tar.xz"))
86 (sha256
87 (base32 "1x4v79vhvc5ixkbsf3jyjz5ig1lf78rfw3r7g3llpb4j1kcp3wh0"))))
88 (build-system qt-build-system)
89 (native-inputs
90 `(("extra-cmake-modules" ,extra-cmake-modules)))
91 (inputs
92 `(("baloo" ,baloo)
93 ("kconfig" ,kconfig)
94 ("ki18n" ,ki18n)
95 ("kio" ,kio)
96 ("qtbase" ,qtbase)))
97 (arguments
98 `(#:phases
99 (modify-phases %standard-phases
100 (add-before 'check 'check-setup
101 (lambda _
102 (setenv "QT_QPA_PLATFORM" "offscreen")
103 #t)))))
104 (home-page "https://community.kde.org/Baloo")
105 (synopsis "Wigets for use with Baloo")
106 (description "Baloo is a framework for searching and managing metadata.
107 This package contains GUI widgets for baloo.")
108 (license license:lgpl2.0+)))
109
110 (define-public grantleetheme
111 (package
112 (name "grantleetheme")
113 (version "20.04.1")
114 (source
115 (origin
116 (method url-fetch)
117 (uri (string-append "mirror://kde/stable/release-service/" version
118 "/src/grantleetheme-" version ".tar.xz"))
119 (sha256
120 (base32 "0gabc5cb0sf00s7m5v2jnq55qsrdbrq6nqd15y1i15p788zifsjx"))
121 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
122 (build-system qt-build-system)
123 (native-inputs
124 `(("extra-cmake-modules" ,extra-cmake-modules)
125 ("libxml2" ,libxml2))) ;; xmllint required for tests
126 (inputs
127 `(("grantlee" ,grantlee)
128 ("kguiaddons" ,kguiaddons)
129 ("ki18n" ,ki18n)
130 ("kiconthemes" ,kiconthemes)
131 ("knewstuff" ,knewstuff)
132 ("qtbase" ,qtbase)))
133 (home-page "https://cgit.kde.org/grantleetheme.git")
134 (synopsis "Library providing Grantlee theme support")
135 (description "This library provides Grantlee theme support.")
136 (license ;; LGPL for libraries, FDL for documentation
137 (list license:lgpl2.1+ license:fdl1.2+))))
138
139 (define-public kdenlive
140 (let ((version "20.08.2"))
141 (package
142 (name "kdenlive")
143 (version version)
144 (source
145 (origin
146 (method git-fetch)
147 (uri (git-reference
148 (url "https://invent.kde.org/multimedia/kdenlive")
149 (commit (string-append "v" version))))
150 (file-name (string-append name "-" version "-checkout"))
151 (sha256
152 (base32 "1zcckv4wj12pvxjg85c8l67vi3amz79yv8mf7m4fbxnam3yxhy90"))))
153 (build-system cmake-build-system)
154 (native-inputs
155 `(("extra-cmake-modules" ,extra-cmake-modules)
156 ("pkg-config" ,pkg-config)
157 ("qttools" ,qttools)))
158 (inputs
159 `(("shared-mime-info" ,shared-mime-info)
160 ("frei0r-plugins" ,frei0r-plugins)
161 ("ffmpeg" ,ffmpeg)
162 ("rttr" ,rttr)
163 ("mlt" ,mlt)
164 ("qtbase" ,qtbase)
165 ("qtscript" ,qtscript)
166 ("qtsvg" ,qtsvg)
167 ("qtmultimedia" ,qtmultimedia)
168 ("kparts" ,kparts)
169 ("knotifications" ,knotifications)
170 ("karchive" ,karchive)
171 ("kdbusaddons" ,kdbusaddons)
172 ("kcrash" ,kcrash)
173 ("kguiaddons" ,kguiaddons)
174 ("knewstuff" ,knewstuff)
175 ("knotifyconfig" ,knotifyconfig)
176 ("kfilemetadata" ,kfilemetadata)
177 ("kdoctools" ,kdoctools)
178 ("kdeclarative" ,kdeclarative)
179 ("qtdeclarative" ,qtdeclarative)
180 ("qtquickcontrols" ,qtquickcontrols)
181 ("qtquickcontrols2" ,qtquickcontrols2)
182 ("kiconthemes" ,kiconthemes)
183 ("breeze" ,breeze)
184 ("purpose" ,purpose)
185 ("qtwebkit" ,qtwebkit)
186 ("qtgraphicaleffects" ,qtgraphicaleffects)
187 ("kplotting" ,kplotting)))
188 (arguments
189 `(#:tests? #f ;TODO needs X
190 #:phases
191 (modify-phases %standard-phases
192 (add-after 'install 'wrap-executable
193 (lambda* (#:key inputs outputs #:allow-other-keys)
194 (let* ((out (assoc-ref outputs "out"))
195 (qtbase (assoc-ref inputs "qtbase"))
196 (frei0r (assoc-ref inputs "frei0r-plugins"))
197 (ffmpeg (assoc-ref inputs "ffmpeg"))
198 (breeze (assoc-ref inputs "breeze")))
199 (wrap-program (string-append out "/bin/kdenlive")
200 `("PATH" ":" prefix
201 ,(list (string-append ffmpeg "/bin")))
202 `("XDG_DATA_DIRS" ":" prefix
203 ,(list (string-append breeze "/share")))
204 `("QT_PLUGIN_PATH" ":" prefix
205 ,(list (getenv "QT_PLUGIN_PATH")))
206 `("FREI0R_PATH" ":" =
207 (,(string-append frei0r "/lib/frei0r-1/")))
208 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
209 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
210 `("QML2_IMPORT_PATH" ":" prefix
211 ,(list (getenv "QML2_IMPORT_PATH")))
212 `("MLT_PREFIX" ":" =
213 (,(assoc-ref inputs "mlt")))))
214 #t)))))
215 (home-page "https://kdenlive.org")
216 (synopsis "Non-linear video editor")
217 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
218
219 Non-linear video editing is much more powerful than beginner's (linear)
220 editors, hence it requires a bit more organization before starting. However,
221 it is not reserved to specialists and can be used for small personal
222 projects.")
223 (license license:gpl2+))))
224
225 (define-public kdevelop
226 (package
227 (name "kdevelop")
228 (version "5.5.2")
229 (source
230 (origin
231 (method url-fetch)
232 (uri (string-append "mirror://kde/stable/kdevelop"
233 "/" version "/src/kdevelop-"
234 version ".tar.xz"))
235 (sha256
236 (base32 "1nkl3z1n1l7ly2zvmbx2sdhx5q72wcvpwhzsz3qgw1474qd9i3i2"))))
237 (build-system qt-build-system)
238 (native-inputs
239 `(("extra-cmake-modules" ,extra-cmake-modules)
240 ("pkg-config" ,pkg-config)
241 ("shared-mime-info" ,shared-mime-info)
242 ("qttools" ,qttools)))
243 (inputs
244 `(("boost" ,boost)
245 ("clang" ,clang)
246 ("grantlee" ,grantlee)
247 ("karchive" ,karchive)
248 ("kcmutils" ,kcmutils)
249 ("kcrash" ,kcrash)
250 ("kdeclarative" ,kdeclarative)
251 ("kdoctools" ,kdoctools)
252 ("kguiaddons" ,kguiaddons)
253 ("ki18n" ,ki18n)
254 ("kiconthemes" ,kiconthemes)
255 ("kio" ,kio) ;; not checked as requirement
256 ("kitemmodels" ,kitemmodels)
257 ("kitemviews" ,kitemviews)
258 ("kjobwidgets" ,kjobwidgets)
259 ("knotifications" ,knotifications)
260 ("knotifyconfig" ,knotifyconfig)
261 ("kparts" ,kparts)
262 ("kservice" ,kservice)
263 ("ktexteditor" ,ktexteditor)
264 ("kwindowsystem" ,kwindowsystem)
265 ("kxmlgui" ,kxmlgui)
266 ("libkomparediff2" ,libkomparediff2)
267 ("oxygen-icons" ,oxygen-icons)
268 ("qtbase" ,qtbase)
269 ("qtdeclarative" ,qtdeclarative)
270 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
271 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
272 ("qtwebkit" ,qtwebkit)
273 ("threadweaver" ,threadweaver)
274
275 ;; recommendes
276 ("astyle" ,astyle)
277 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
278 ("libksysguard" ,libksysguard)
279
280 ;; optional
281 ("apr" ,apr) ; required for subversion support
282 ("apr-util" ,apr-util) ; required for subversion support
283 ("attica" ,attica)
284 ("kconfigwidgets" ,kconfigwidgets)
285 ("knewstuff" ,knewstuff)
286 ("krunner" ,krunner)
287 ;; TODO: OktetaGui, OktetaKastenControllers
288 ("plasma" ,plasma-framework)
289 ;; TODO: purpose
290 ("sonnet" ,sonnet)
291 ("subversion" ,subversion)))
292
293 ;; run-time packages - TODO
294 ;; ClazyStandalone
295 ;; Cppcheck
296 ;; heaptrack
297 ;; heaptrack_gui
298 ;; meson
299 (arguments
300 `(#:tests? #f ;; there are some issues with the test suite
301 #:phases
302 (modify-phases %standard-phases
303 (add-before 'configure 'add-include-path
304 (lambda* (#:key inputs #:allow-other-keys)
305 (substitute* "cmake/modules/FindClang.cmake"
306 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
307 (string-append line " " (assoc-ref inputs "clang") "/lib")))
308 #t)))))
309 (home-page "https://kdevelop.org")
310 (synopsis "IDE for C, C++, Python, Javascript and PHP")
311 (description "The KDevelop IDE provides semantic syntax highlighting, as
312 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
313 JavaScript, Python and PHP. It also integrates with a debugger, different
314 build systems (CMake, QMake, custom Makefiles) and version control
315 software (Git, Subversion, Mercurial, CVS and Bazaar).")
316 (license license:lgpl2.1+)))
317
318 (define-public kdevelop-pg-qt
319 (package
320 (name "kdevelop-pg-qt")
321 (version "2.2.1")
322 (source
323 (origin
324 (method git-fetch)
325 (uri (git-reference
326 (url "https://github.com/KDE/kdevelop-pg-qt")
327 (commit (string-append "v" version))))
328 (file-name (git-file-name name version))
329 (sha256
330 (base32 "1kfab4p717acbdkcdi41d98vwch7v431gb2qi6s38hmclsf8bf8g"))))
331 (native-inputs
332 `(("extra-cmake-modules" ,extra-cmake-modules)))
333 (inputs
334 `(("qtbase" ,qtbase)))
335 (build-system cmake-build-system)
336 (home-page "https://kde.org")
337 (synopsis "Parser generator library for KDevplatform")
338 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
339 for some KDevelop language plugins (Ruby, PHP, CSS...).")
340 (license license:lgpl2.0+)))
341
342 ;; kdevplatform was merged into kdevelop as of 5.2.x
343 (define-deprecated kdevplatform kdevelop)
344
345 (define-public kdiagram
346 (package
347 (name "kdiagram")
348 (version "2.7.0")
349 (source
350 (origin
351 (method url-fetch)
352 (uri (string-append "mirror://kde/stable/kdiagram/" version
353 "/kdiagram-" version ".tar.xz"))
354 (sha256
355 (base32 "1pgvf2q8b59hw0jg5ajmj5nrn4q8cgnifpvdd0fynk2ml6zym8k3"))
356 (patches (search-patches
357 "kdiagram-Fix-missing-link-libraries.patch"))))
358 (build-system qt-build-system)
359 (native-inputs
360 `(("extra-cmake-modules" ,extra-cmake-modules)
361 ("qttools" ,qttools)))
362 (inputs
363 `(("qtbase" ,qtbase)
364 ("qtsvg" ,qtsvg)))
365 (home-page "https://cgit.kde.org/kdiagram.git/")
366 (synopsis "Libraries for creating business diagrams")
367 (description "This package provides libraries for integrating business
368 diagrams in Qt-based applications.
369
370 @code{KCharts} provides an implementation of the ODF Chart specification. It
371 supports stock charts, box charts, and whisker charts. @code{KGantt} provides
372 a module for implementing ODF Gantt charts, which are bar charts that
373 illustrate project schedules.")
374 (license license:gpl2+)))
375
376 (define-public krita
377 (package
378 (name "krita")
379 (version "4.4.0")
380 (source (origin
381 (method url-fetch)
382 (uri (string-append
383 "mirror://kde/stable/krita/" version
384 "/krita-" version ".tar.gz"))
385 (sha256
386 (base32
387 "13r7x4gql5wp88hmpv9m6m3lh7gsybm4la48hqbjcb3iwiv86pzw"))))
388 (build-system cmake-build-system)
389 (arguments
390 `(#:tests? #f
391 #:configure-flags
392 (list "-DBUILD_TESTING=OFF"
393 (string-append "-DCMAKE_CXX_FLAGS=-I"
394 (assoc-ref %build-inputs "openexr")
395 "/include/OpenEXR"))
396 #:phases
397 (modify-phases %standard-phases
398 ;; Ensure that icons are found at runtime.
399 ;; This works around <https://bugs.gnu.org/22138>.
400 (add-after 'install 'wrap-executable
401 (lambda* (#:key inputs outputs #:allow-other-keys)
402 (let ((out (assoc-ref outputs "out"))
403 (qt '("qtbase" "qtsvg")))
404 (wrap-program (string-append out "/bin/krita")
405 `("QT_PLUGIN_PATH" ":" prefix
406 ,(map (lambda (label)
407 (string-append (assoc-ref inputs label)
408 "/lib/qt5/plugins/"))
409 qt)))
410 #t))))))
411 (native-inputs
412 `(("curl" ,curl)
413 ("eigen" ,eigen)
414 ("extra-cmake-modules" ,extra-cmake-modules)
415 ("gettext-minimal" ,gettext-minimal)
416 ("kitemmodels" ,kitemmodels)
417 ("pkg-config" ,pkg-config)
418 ("qwt" ,qwt)
419 ("vc" ,vc)))
420 (inputs
421 `(("boost" ,boost)
422 ("exiv2" ,exiv2)
423 ("fftw" ,fftw)
424 ("gsl" ,gsl)
425 ("ilmbase" ,ilmbase)
426 ("karchive" ,karchive)
427 ("kcompletion" ,kcompletion)
428 ("kconfig" ,kconfig)
429 ("kcoreaddons" ,kcoreaddons)
430 ("kcrash" ,kcrash)
431 ("kguiaddons" ,kguiaddons)
432 ("ki18n" ,ki18n)
433 ("kiconthemes" ,kiconthemes)
434 ("kio" ,kio)
435 ("kitemviews" ,kitemviews)
436 ("kwidgetsaddons" ,kwidgetsaddons)
437 ("kwindowsystem" ,kwindowsystem)
438 ("kxmlgui" ,kxmlgui)
439 ("lcms" ,lcms)
440 ("libjpeg-turbo" ,libjpeg-turbo)
441 ("libpng" ,libpng)
442 ("libraw" ,libraw-0.18)
443 ("libtiff" ,libtiff)
444 ("libx11" ,libx11)
445 ("libxcb" ,libxcb)
446 ("libxi" ,libxi)
447 ("openexr" ,openexr)
448 ("perl" ,perl)
449 ("poppler-qt5" ,poppler-qt5)
450 ("qtbase" ,qtbase-for-krita)
451 ("qtdeclarative" ,qtdeclarative)
452 ("qtmultimedia" ,qtmultimedia)
453 ("qtsvg" ,qtsvg)
454 ("qtx11extras" ,qtx11extras)
455 ("quazip" ,quazip)
456 ("zlib" ,zlib)))
457 (home-page "https://krita.org")
458 (synopsis "Digital painting application")
459 (description
460 "Krita is a professional painting tool designed for concept artists,
461 illustrators, matte and texture artists, and the VFX industry. Notable
462 features include brush stabilizers, brush engines and wrap-around mode.")
463 (license license:gpl2+)))
464
465 (define-public libkomparediff2
466 (package
467 (name "libkomparediff2")
468 (version "20.04.1")
469 (source
470 (origin
471 (method url-fetch)
472 (uri (string-append "mirror://kde/stable/release-service/" version
473 "/src/libkomparediff2-" version ".tar.xz"))
474 (sha256
475 (base32 "0m8m7sgpf2f4nxpaaymyvihlk0pcyblyd99mcbibrnyr5kzkzzdc"))))
476 (native-inputs
477 `(("extra-cmake-modules" ,extra-cmake-modules)
478 ("pkg-config" ,pkg-config)))
479 (inputs
480 `(("kcodecs" ,kcodecs)
481 ("kconfig" ,kconfig)
482 ("kcoreaddons" ,kcoreaddons)
483 ("ki18n" ,ki18n)
484 ("kio" ,kio)
485 ("kxmlgui" ,kxmlgui)
486 ("qtbase" ,qtbase)))
487 (build-system cmake-build-system)
488 (home-page "https://kde.org")
489 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
490 (description "Libkomparediff2 is a library to work with diffs and patches,
491 used in KDE development tools Kompare and KDevelop.")
492
493 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
494 ;; source archive
495 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
496
497 (define-public qca
498 (package
499 (name "qca")
500 (version "2.3.0")
501 (source
502 (origin
503 (method url-fetch)
504 (uri (string-append "mirror://kde/stable/qca/" version
505 "/qca-" version ".tar.xz"))
506 (sha256
507 (base32
508 "1mrj748yz1grgzmfbmffgjkpcqiaj1l3m4pbddwcj7dnl50yys0x"))))
509 (build-system cmake-build-system)
510 (native-inputs
511 `(("pkg-config" ,pkg-config)))
512 (inputs
513 `(("openssl" ,openssl)
514 ("qtbase" ,qtbase)))
515 (home-page "https://userbase.kde.org/QCA")
516 (synopsis "Libraries for the Qt Cryptographic Architecture")
517 (description "The Qt Cryptographic Architecture (QCA) provides a
518 straightforward and cross-platform API for a range of cryptographic features,
519 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
520 cards.")
521 (license license:lgpl2.1)))
522
523 (define-public kpmcore
524 (package
525 (name "kpmcore")
526 (version "4.1.0")
527 (source (origin
528 (method url-fetch)
529 (uri (string-append
530 "mirror://kde/stable/kpmcore"
531 "/" version "/src/"
532 name "-" version ".tar.xz"))
533 (sha256
534 (base32
535 "0jsig7algmab9h0fb09my0axjqzw83zgscamhzl8931lribs6idm"))))
536 (build-system cmake-build-system)
537 (native-inputs
538 `(("extra-cmake-modules" ,extra-cmake-modules)
539 ("pkg-config" ,pkg-config)))
540 (inputs
541 `(("kauth" ,kauth)
542 ("kcoreaddons" ,kcoreaddons)
543 ("ki18n" ,ki18n)
544 ("kwidgetsaddons" ,kwidgetsaddons)
545 ("qtbase" ,qtbase)
546 ("qca" ,qca)
547 ("util-linux" ,util-linux "lib")))
548 (home-page "https://community.kde.org/Frameworks")
549 (synopsis "Library for managing partitions")
550 (description "Library for managing partitions.")
551 (license license:gpl3+)))
552
553 (define-public snorenotify
554 (package
555 (name "snorenotify")
556 (version "0.7.0")
557 (source
558 (origin
559 (method url-fetch)
560 (uri (string-append "mirror://kde/stable/snorenotify/"
561 version "/src/snorenotify-" version ".tar.xz"))
562 (sha256
563 (base32
564 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
565 (build-system cmake-build-system)
566 (arguments
567 `(#:tests? #f)) ; both tests fail, require display
568 (inputs
569 `(("qtbase" ,qtbase)))
570 (native-inputs
571 `(("extra-cmake-modules" ,extra-cmake-modules)
572 ("qttools" ,qttools)))
573 (home-page "https://techbase.kde.org/Projects/Snorenotify")
574 (synopsis "Qt notification framework")
575 (description "Snorenotify is a multi platform Qt notification framework.
576 Using a plugin system it is possible to create notifications with many
577 different notification systems.")
578 (license license:lgpl3)))
579
580 (define-public kdeconnect
581 (package
582 (name "kdeconnect")
583 (version "20.04.2")
584 (source
585 (origin
586 (method url-fetch)
587 (uri (string-append "mirror://kde/stable/release-service/"
588 version "/src/kdeconnect-kde-"
589 version ".tar.xz"))
590 (sha256
591 (base32
592 "0yq3afbbcc9gmlcachvh3xz3gdj57092fpagp36l5knw8gr0d9ip"))))
593 (build-system qt-build-system)
594 (arguments
595 `(#:configure-flags '("-DBUILD_TESTING=ON"
596 "-DKDE_INSTALL_LIBEXECDIR=libexec")
597 #:phases (modify-phases %standard-phases
598 (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
599 (lambda* (#:key inputs #:allow-other-keys)
600 ;; FIXME: <kcmutils_version.h> is not found during one
601 ;; of the compilation steps without this hack.
602 (setenv "CPLUS_INCLUDE_PATH"
603 (string-append (assoc-ref inputs "kcmutils")
604 "/include/KF5:"
605 (or (getenv "CPLUS_INCLUDE_PATH")
606 "")))
607 #t)))
608 #:tests? #f)) ; tests fail hard in our build environment
609 (native-inputs
610 `(("extra-cmake-modules" ,extra-cmake-modules)
611 ("kdoctools" ,kdoctools)
612 ("libxtst" ,libxtst)
613 ("pkg-config" ,pkg-config)
614 ("python" ,python-wrapper)))
615 (inputs
616 `(("kcmutils" ,kcmutils)
617 ("kconfigwidgets" ,kconfigwidgets)
618 ("kdbusaddons" ,kdbusaddons)
619 ("ki18n" ,ki18n)
620 ("kiconthemes" ,kiconthemes)
621 ("kio" ,kio)
622 ("kirigami" ,kirigami)
623 ("knotifications" ,knotifications)
624 ("kpeople" ,kpeople)
625 ("kpeoplevcard" ,kpeoplevcard)
626 ("kwayland" ,kwayland)
627 ("libfakekey" ,libfakekey)
628 ("pulseaudio-qt" ,pulseaudio-qt)
629 ("qca" ,qca)
630 ("qtbase" ,qtbase)
631 ("qtdeclarative" ,qtdeclarative)
632 ("qtgraphicaleffects" ,qtgraphicaleffects)
633 ("qtmultimedia" ,qtmultimedia)
634 ("qtquickcontrols" ,qtquickcontrols)
635 ("qtquickcontrols2" ,qtquickcontrols2)
636 ("qtx11extras" ,qtx11extras)))
637 (home-page "https://community.kde.org/KDEConnect")
638 (synopsis "Enable your devices to communicate with each other")
639 (description "KDE Connect is a project that enables all your devices to
640 communicate with each other. Here's a few things KDE Connect can do:
641 @enumerate
642 @item Receive your phone notifications on your desktop computer and reply to messages
643 @item Control music playing on your desktop from your phone
644 @item Use your phone as a remote control for your desktop
645 @item Run predefined commands on your PC from connected devices
646 @item Check your phones battery level from the desktop
647 @item Ring your phone to help finding it
648 @item Share files and links between devices
649 @item Browse your phone from the desktop
650 @item Control the desktop's volume from the phone
651 @end enumerate")
652 (properties `((upstream-name . "kdeconnect-kde")))
653 (license (list license:gpl2 license:gpl3)))) ; dual licensed
654
655 (define-public kqtquickcharts
656 (package
657 (name "kqtquickcharts")
658 (version "20.04.1")
659 (source
660 (origin
661 (method url-fetch)
662 (uri (string-append "mirror://kde/stable/release-service/"
663 version "/src/kqtquickcharts-" version ".tar.xz"))
664 (sha256
665 (base32
666 "1wxp35mf9zlpgzi4msdl86b2krdq2ipqw371gyx23r7j84vdyxi3"))))
667 (build-system cmake-build-system)
668 (native-inputs
669 `(("extra-cmake-modules" ,extra-cmake-modules)))
670 (inputs
671 `(("qtbase" ,qtbase)
672 ("qtdeclarative" ,qtdeclarative)))
673 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
674 (synopsis "Interactive charts for Qt Quick")
675 (description
676 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
677 charts.")
678 (license license:lgpl2.1+)))
679
680 (define-public kcachegrind
681 (package
682 (name "kcachegrind")
683 (version "20.04.1")
684 (source (origin
685 (method url-fetch)
686 (uri (string-append "mirror://kde/stable/release-service/" version
687 "/src/kcachegrind-" version ".tar.xz"))
688 (sha256
689 (base32
690 "0fx17s6fj1pxl1mgfrqhchk8sihkbji1x8y3nhb1r0971wzd1nsc"))))
691 (build-system cmake-build-system)
692 (native-inputs
693 `(("extra-cmake-modules" ,extra-cmake-modules)
694 ("perl" ,perl)
695 ("python" ,python)
696 ("qttools" ,qttools)
697 ("kdoctools" ,kdoctools)))
698 (inputs
699 `(("qtbase" ,qtbase)
700 ("karchive" ,karchive)
701 ("ki18n" ,ki18n)
702 ("kio" ,kio)
703 ("kdbusaddons" ,kdbusaddons)))
704 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
705 ;; Python and PHP, respectively. These are optional and we ignore them
706 ;; for now.
707 (home-page "https://kcachegrind.github.io/html/Home.html")
708 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
709 (description
710 "The data files generated by the Callgrind of Valgrind, an application
711 profiler, can be loaded into KCachegrind for browsing the performance results.
712 There is also a command-line tool to get ASCII reports from data files without
713 the need to use KCachegrind.
714
715 The format of Callgrind output is documented. With conversion scripts,
716 KCachegrind is able to visualize output of other profilers like OProfile, a
717 system-wide profiler for Linux using statistical sampling with hardware
718 performance counters. There also exist converters for profiling output of
719 Python, PHP, and Perl.")
720 (license license:gpl2)))
721
722 (define-public libkdegames
723 (package
724 (name "libkdegames")
725 (version "20.04.1")
726 (source
727 (origin
728 (method url-fetch)
729 (uri (string-append "mirror://kde/stable/release-service/" version
730 "/src/libkdegames-" version ".tar.xz"))
731 (sha256
732 (base32 "1xsrrvhwjwi5aajcaxydmzc69i4yx6shs8ly8vr85njc188ycg13"))))
733 (build-system qt-build-system)
734 (native-inputs
735 `(("extra-cmake-modules" ,extra-cmake-modules)))
736 (inputs
737 `(("karchive" ,karchive)
738 ("kbookmarks" ,kbookmarks)
739 ("kcodecs" ,kcodecs)
740 ("kcompletion" ,kcompletion)
741 ("kconfigwidgets" ,kconfigwidgets)
742 ("kcrash" ,kcrash)
743 ("kdbusaddons" ,kdbusaddons)
744 ("kdeclarative" ,kdeclarative)
745 ("kdnssd" ,kdnssd)
746 ("kglobalaccel" ,kglobalaccel)
747 ("kguiaddons" ,kguiaddons)
748 ("ki18n" ,ki18n)
749 ("kiconthemes" ,kiconthemes)
750 ;("kio" ,kio)
751 ("kitemviews" ,kitemviews)
752 ("kjobwidgets" ,kjobwidgets)
753 ("knewstuff" ,knewstuff)
754 ("kservice" ,kservice)
755 ("ktextwidgets" ,ktextwidgets)
756 ("kwidgetsaddons" ,kwidgetsaddons)
757 ("kxmlgui" ,kxmlgui)
758 ("libsndfile" ,libsndfile)
759 ("openal" ,openal)
760 ("qtbase" ,qtbase)
761 ("qtdeclarative" ,qtdeclarative)
762 ("qtsvg" ,qtsvg)))
763 (home-page "https://games.kde.org/")
764 (synopsis "Runtime library for kdegames")
765 (description "Runtime library for kdegames")
766 (license (list license:gpl2+ license:fdl1.2+))))
767
768 (define-public zeroconf-ioslave
769 (package
770 (name "zeroconf-ioslave")
771 (version "20.04.1")
772 (source
773 (origin
774 (method url-fetch)
775 (uri (string-append "mirror://kde/stable/release-service/" version
776 "/src/zeroconf-ioslave-" version ".tar.xz"))
777 (sha256
778 (base32 "1qck5jyc4psslpibhki8sz8aj0hsnx8z791vzyn10lmdzn71vx8c"))))
779 (build-system qt-build-system)
780 (native-inputs
781 `(("extra-cmake-modules" ,extra-cmake-modules)))
782 (inputs
783 `(("kdbusaddons" ,kdbusaddons)
784 ("kdnssd" ,kdnssd)
785 ("ki18n" ,ki18n)
786 ("kio" ,kio)
787 ("qtbase" ,qtbase)))
788 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
789 (synopsis "DNS-SD Service Discovery Monitor")
790 (description "Adds an entry to Dolphin's Network page to show local
791 services such as printers which advertise themselves with DNSSD (called Avahi
792 or Bonjour by other projects).")
793 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
794 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
795
796
797 (define-public kuserfeedback
798 ;; FIXME: Try to reduce data collection and ensure transmission i disabled by default.
799 ;; FIXME: Check https://www.reddit.com/r/kde/comments/f7ojg9 for insights
800 (package
801 (name "kuserfeedback")
802 (version "1.0.0")
803 (source
804 (origin
805 (method url-fetch)
806 (uri (string-append "mirror://kde/stable/kuserfeedback/"
807 "/kuserfeedback-" version ".tar.xz"))
808 (sha256
809 (base32 "1dwx9fscnfp3zsxdir774skn8xvad2dvscnaaw3ji6mrnkmm6bss"))))
810 (build-system qt-build-system)
811 (native-inputs
812 `(("extra-cmake-modules" ,extra-cmake-modules)
813 ("qttools" ,qttools)
814 ;; For optional component "Survey target expression parser"
815 ("bison" ,bison)
816 ("flex" ,flex)
817 ;; For syntax checking and unit tests of PHP server code
818 ;;("php" ,php)
819 ;;("phpunit" ,phpunit)
820 ))
821 (inputs
822 `(("qtbase" ,qtbase)
823 ("qtcharts" ,qtcharts)
824 ("qtdeclarative" ,qtdeclarative)
825 ("qtsvg" ,qtsvg)))
826 (arguments
827 `(#:tests? #f)) ;; 4/17 fail
828 (home-page "https://api.kde.org/frameworks/kuserfeedback/html/")
829 (synopsis "Framework for collecting feedback from application users via
830 telemetry and targeted surveys")
831 (description "This framework consists of the following components:
832 @itermize
833 @item Libraries for use in applications.
834 @item QML bindings for the above.
835 @item A server application.
836 @item A management and analytics application.
837 @end itemize")
838 (license license:expat)))