gnu: python-file: Don't create a compressed egg.
[jackhill/guix/guix.git] / gnu / packages / messaging.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
3 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
4 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
6 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
8 ;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
9 ;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages messaging)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix utils)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix git-download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system glib-or-gtk)
34 #:use-module (guix build-system python)
35 #:use-module (gnu packages)
36 #:use-module (gnu packages aidc)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages avahi)
39 #:use-module (gnu packages check)
40 #:use-module (gnu packages crypto)
41 #:use-module (gnu packages cyrus-sasl)
42 #:use-module (gnu packages databases)
43 #:use-module (gnu packages documentation)
44 #:use-module (gnu packages enchant)
45 #:use-module (gnu packages gnome)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages xorg)
48 #:use-module (gnu packages xdisorg)
49 #:use-module (gnu packages libcanberra)
50 #:use-module (gnu packages networking)
51 #:use-module (gnu packages libidn)
52 #:use-module (gnu packages lua)
53 #:use-module (gnu packages xml)
54 #:use-module (gnu packages gnupg)
55 #:use-module (gnu packages ncurses)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages glib)
58 #:use-module (gnu packages python)
59 #:use-module (gnu packages perl)
60 #:use-module (gnu packages tcl)
61 #:use-module (gnu packages compression)
62 #:use-module (gnu packages check)
63 #:use-module (gnu packages admin)
64 #:use-module (gnu packages linux)
65 #:use-module (gnu packages tls)
66 #:use-module (gnu packages icu4c)
67 #:use-module (gnu packages qt)
68 #:use-module (gnu packages video)
69 #:use-module (gnu packages xiph)
70 #:use-module (gnu packages audio)
71 #:use-module (gnu packages fontutils))
72
73 (define-public libotr
74 (package
75 (name "libotr")
76 (version "4.1.1")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "https://otr.cypherpunks.ca/libotr-"
80 version ".tar.gz"))
81 (sha256
82 (base32
83 "1x8rliydhbibmzwdbyr7pd7n87m2jmxnqkpvaalnf4154hj1hfwb"))
84 (patches (search-patches "libotr-test-auth-fix.patch"))))
85 (build-system gnu-build-system)
86 (propagated-inputs
87 `(("libgcrypt" ,libgcrypt))) ; libotr headers include gcrypt.h
88 (inputs `(("libgpg-error" ,libgpg-error)))
89 (native-inputs `(("perl" ,perl))) ; for the test suite
90 (synopsis "Off-the-Record (OTR) Messaging Library and Toolkit")
91 (description
92 "OTR allows you to have private conversations over instant messaging by
93 providing: (1) Encryption: No one else can read your instant messages. (2)
94 Authentication: You are assured the correspondent is who you think it is. (3)
95 Deniability: The messages you send do not have digital signatures that are
96 checkable by a third party. Anyone can forge messages after a conversation to
97 make them look like they came from you. However, during a conversation, your
98 correspondent is assured the messages he sees are authentic and
99 unmodified. (4) Perfect forward secrecy: If you lose control of your private
100 keys, no previous conversation is compromised.")
101 (home-page "https://otr.cypherpunks.ca/")
102 (license (list license:lgpl2.1 license:gpl2))))
103
104 ;; These patches together fix https://github.com/bitlbee/bitlbee/pull/55, are
105 ;; already upstream, and should be unnecessary when the next bitlbee comes
106 ;; out.
107 (define %bitlbee-buddy-nick-change-patch
108 (origin
109 (method url-fetch)
110 (uri "https://github.com/bitlbee/bitlbee/commit/a42fda42.patch")
111 (sha256
112 (base32
113 "1mzjhcdn0rxir5mzgqz9kv142ai38p1iq2lajqx89wb7x0bp51zx"))))
114 (define %bitlbee-always-use-nicks-patch
115 (origin
116 (method url-fetch)
117 (uri "https://github.com/bitlbee/bitlbee/commit/3320d6d9.patch")
118 (sha256
119 (base32
120 "14d9kb5zdzh5hzakdvrbviz83rix0j2lq9rzb58b2fn92fp8yixd"))))
121
122 (define-public bitlbee
123 (package
124 (name "bitlbee")
125 (version "3.4.2")
126 (source (origin
127 (method url-fetch)
128 (uri (string-append "https://get.bitlbee.org/src/bitlbee-"
129 version ".tar.gz"))
130 (sha256
131 (base32 "0mza8lnfwibmklz8hdzg4f7p83hblf4h6fbf7d732kzpvra5bj39"))
132 (patches
133 (list %bitlbee-buddy-nick-change-patch
134 %bitlbee-always-use-nicks-patch))))
135 (build-system gnu-build-system)
136 (native-inputs `(("pkg-config" ,pkg-config)
137 ("check" ,check)))
138 (inputs `(("glib" ,glib)
139 ("libotr" ,libotr)
140 ("gnutls" ,gnutls)
141 ("python" ,python-2)
142 ("perl" ,perl)))
143 (arguments
144 `(#:phases (alist-cons-after
145 'install 'install-etc
146 (lambda* (#:key (make-flags '()) #:allow-other-keys)
147 (zero? (apply system* "make" "install-etc" make-flags)))
148 (alist-replace
149 'configure
150 ;; bitlbee's configure script does not tolerate many of the
151 ;; variable settings that Guix would pass to it.
152 (lambda* (#:key outputs #:allow-other-keys)
153 (zero? (system* "./configure"
154 (string-append "--prefix="
155 (assoc-ref outputs "out"))
156 "--otr=1")))
157 %standard-phases))))
158 (synopsis "IRC to instant messaging gateway")
159 (description "BitlBee brings IM (instant messaging) to IRC clients, for
160 people who have an IRC client running all the time and don't want to run an
161 additional IM client. BitlBee currently supports XMPP/Jabber (including
162 Google Talk), MSN Messenger, Yahoo! Messenger, AIM and ICQ, and the Twitter
163 microblogging network (plus all other Twitter API compatible services like
164 identi.ca and status.net).")
165 (home-page "http://www.bitlbee.org/")
166 (license (list license:gpl2+ license:bsd-2))))
167
168 (define-public hexchat
169 (package
170 (name "hexchat")
171 (version "2.12.2")
172 (source (origin
173 (method url-fetch)
174 (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
175 version ".tar.xz"))
176 (sha256
177 (base32
178 "1xnclfbrgbkqndxygi5f27q00jd7yy54jbd1061jmhxa6wzpibbd"))))
179 (build-system gnu-build-system)
180 (native-inputs `(("pkg-config" ,pkg-config)
181 ("intltool" ,intltool)))
182 (inputs `(("dbus-glib" ,dbus-glib)
183 ("dbus" ,dbus)
184 ("enchant" ,enchant)
185 ("glib:bin" ,glib "bin") ;need glib-genmarshal
186 ("gtk" ,gtk+-2)
187 ("libcanberra" ,libcanberra)
188 ("libnotify" ,libnotify)
189 ("openssl" ,openssl)
190
191 ;; Bindings for add-on scripts.
192 ("luajit" ,luajit)
193 ("perl-xml-parser" ,perl-xml-parser)
194 ("python-2" ,python-2)))
195 (synopsis "Graphical IRC Client")
196 (description
197 "HexChat lets you connect to multiple IRC networks at once. The main
198 window shows the list of currently connected networks and their channels, the
199 current conversation and the list of users. It uses colors to differentiate
200 between users and to highlight messages. It checks spelling using available
201 dictionaries. HexChat can be extended with multiple addons.")
202 (home-page "http://hexchat.net/")
203 (license license:gpl2+)))
204
205 (define-public ngircd
206 (package
207 (name "ngircd")
208 (version "22")
209 (source (origin
210 (method url-fetch)
211 (uri (string-append "http://arthur.barton.de/pub/ngircd/ngircd-"
212 version ".tar.xz"))
213 (sha256
214 (base32
215 "17k3g9qd9d010czk5846qxvzkmw4fihv8l6m2a2287crbxm3xhd4"))
216 (patches (search-patches "ngircd-no-dns-in-tests.patch"
217 "ngircd-handle-zombies.patch"))))
218 (build-system gnu-build-system)
219 ;; Needed for the test suite.
220 (native-inputs `(("procps" ,procps)
221 ("expect" ,expect)
222 ("inetutils" ,inetutils)))
223 ;; XXX Add libident.
224 (inputs `(("zlib" ,zlib)
225 ("libwrap" ,tcp-wrappers)
226 ("gnutls" ,gnutls)
227 ,@(if (string-suffix? "-linux"
228 (or (%current-target-system)
229 (%current-system)))
230 `(("linux-pam" ,linux-pam))
231 '())))
232 (arguments
233 `(#:configure-flags
234 '("--with-gnutls" "--with-iconv" "--enable-ipv6" "--with-tcp-wrappers"
235 ,@(if (string-suffix? "-linux"
236 (or (%current-target-system)
237 (%current-system)))
238 '("--with-pam")
239 '()))
240 #:phases
241 ;; Necessary for the test suite.
242 (alist-cons-after
243 'configure 'post-configure
244 (lambda _
245 (substitute* "src/ngircd/Makefile"
246 (("/bin/sh") (which "sh")))
247 ;; The default getpid.sh does a sloppy grep over 'ps -ax' output,
248 ;; which fails arbitrarily.
249 (with-output-to-file "src/testsuite/getpid.sh"
250 (lambda ()
251 (display
252 (string-append
253 "#!" (which "sh") "\n"
254 "ps -C \"$1\" -o pid=\n"))))
255 ;; Our variant of getpid.sh does not work for interpreter names if a
256 ;; shebang script is run directly as "./foo", so patch cases where
257 ;; the test suite relies on this.
258 (substitute* "src/testsuite/start-server.sh"
259 ;; It runs 'getpid.sh sh' to test if it works at all. Run it on
260 ;; 'make' instead.
261 (("getpid.sh sh") "getpid.sh make")))
262 %standard-phases)))
263 (home-page "http://ngircd.barton.de/")
264 (synopsis "Lightweight Internet Relay Chat server for small networks")
265 (description
266 "ngIRCd is a lightweight Internet Relay Chat server for small or private
267 networks. It is easy to configure, can cope with dynamic IP addresses, and
268 supports IPv6, SSL-protected connections as well as PAM for authentication.")
269 (license license:gpl2+)))
270
271 (define-public pidgin
272 (package
273 (name "pidgin")
274 (version "2.11.0")
275 (source
276 (origin
277 (method url-fetch)
278 (uri (string-append "mirror://sourceforge/pidgin/Pidgin/"
279 version "/" name "-" version ".tar.bz2"))
280 (sha256
281 (base32
282 "0crkggjj6y07v1kdwil9vw532b0vrs6p33nmlvdkpnl60m2169pp"))
283 (patches (search-patches "pidgin-add-search-path.patch"))))
284 (build-system glib-or-gtk-build-system)
285 (native-inputs
286 `(("pkg-config" ,pkg-config)
287 ("check" ,check)
288 ("intltool" ,intltool)
289 ("gconf" ,gconf)
290 ("python" ,python-2)
291 ("doxygen" ,doxygen)))
292 (inputs
293 `(("gtk+" ,gtk+-2)
294 ("libgcrypt" ,libgcrypt)
295 ("gnutls" ,gnutls)
296 ("cyrus-sasl" ,cyrus-sasl)
297 ("dbus" ,dbus)
298 ("dbus-glib" ,dbus-glib)
299 ("python2-dbus" ,python2-dbus)
300 ("libidn" ,libidn)
301 ("libltdl" ,libltdl)
302 ("libxml2" ,libxml2)
303 ;; TODO: gstreamer: patches needed to support gstreamer-1.0 or later
304 ;; TODO: farstream
305 ;; TODO: meanwhile
306 ;; TODO: network-manager
307 ;; TODO: gtkspell
308 ;; TODO: libxephyr
309 ;; TODO: libgadu
310 ("libxslt" ,libxslt)
311 ("avahi" ,avahi)
312 ("ncurses" ,ncurses)
313 ("sqlite" ,sqlite)
314 ("libice" ,libice)
315 ("libsm" ,libsm)
316 ("libxscrnsaver" ,libxscrnsaver)
317 ("startup-notification" ,startup-notification)))
318 (arguments
319 `(#:configure-flags
320 (list "--disable-gtkspell"
321 "--disable-tcl"
322 "--disable-meanwhile"
323 "--disable-nm" ; XXX remove when we have network-manager
324 "--disable-vv" ; XXX remove when we have farstream and gstreamer
325 "--disable-gstreamer" ; XXX patches needed to support gstreamer-1.0
326 "--enable-cyrus-sasl"
327 (string-append "--with-ncurses-headers="
328 (assoc-ref %build-inputs "ncurses")
329 "/include"))))
330 (native-search-paths
331 (list (search-path-specification
332 (variable "PURPLE_PLUGIN_PATH")
333 (files (list (string-append "lib/purple-"
334 (version-prefix version 1))
335 "lib/pidgin")))))
336 (home-page "http://www.pidgin.im/")
337 (synopsis "Graphical multi-protocol instant messaging client")
338 (description
339 "Pidgin is a modular instant messaging client that supports many popular
340 chat protocols.")
341 (license
342 (list
343 license:gpl2+ ; Most of the code
344 license:lgpl2.1 ; GG protocol plugin (libpurple/protocols/gg/lib)
345 license:lgpl2.0+ ; OSCAR protocol plugin (libpurple/protocols/oscar)
346 ;; The following licenses cover the zephyr protocol plugin:
347 (license:non-copyleft
348 "file://libpurple/protocols/zephyr/mit-copyright.h"
349 "See libpurple/protocols/zephyr/mit-copyright.h in the distribution.")
350 (license:non-copyleft
351 "file://libpurple/protocols/zephyr/mit-sipb-copyright.h"
352 "See libpurple/protocols/zephyr/mit-sipb-copyright.h in the distribution.")))))
353
354 (define-public pidgin-otr
355 (package
356 (name "pidgin-otr")
357 (version "4.0.2")
358 (source (origin
359 (method url-fetch)
360 (uri (string-append "https://otr.cypherpunks.ca/"
361 name "-" version ".tar.gz"))
362 (sha256
363 (base32
364 "1i5s9rrgbyss9rszq6c6y53hwqyw1k86s40cpsfx5ccl9bprxdgl"))))
365 (build-system gnu-build-system)
366 (native-inputs
367 `(("pkg-config" ,pkg-config)
368 ("intltool" ,intltool)))
369 (inputs
370 `(("pidgin" ,pidgin)
371 ("libotr" ,libotr)
372 ("libgpg-error" ,libgpg-error)
373 ("libgcrypt" ,libgcrypt)
374 ("glib" ,glib)
375 ("gtk+" ,gtk+-2)))
376 (home-page "https://otr.cypherpunks.ca/")
377 (synopsis "Off-the-Record Messaging plugin for Pidgin")
378 (description
379 "Pidgin-OTR is a plugin that adds support for OTR to the Pidgin instant
380 messaging client. OTR (Off-the-Record) Messaging allows you to have private
381 conversations over instant messaging by providing: (1) Encryption: No one else
382 can read your instant messages. (2) Authentication: You are assured the
383 correspondent is who you think it is. (3) Deniability: The messages you send
384 do not have digital signatures that are checkable by a third party. Anyone
385 can forge messages after a conversation to make them look like they came from
386 you. However, during a conversation, your correspondent is assured the
387 messages he sees are authentic and unmodified. (4) Perfect forward secrecy:
388 If you lose control of your private keys, no previous conversation is
389 compromised.")
390 (license license:gpl2)))
391
392 (define-public znc
393 (package
394 (name "znc")
395 (version "1.6.3")
396 (source (origin
397 (method url-fetch)
398 (uri (string-append "http://znc.in/releases/archive/znc-"
399 version ".tar.gz"))
400 (sha256
401 (base32
402 "09xqi5fs40x6nj9gq99bnw1a7saq96bvqxknxx0ilq7yfvg4c733"))))
403 (build-system gnu-build-system)
404 (arguments
405 '(#:tests? #f ; tries to download GoogleTest with wget
406 #:configure-flags '("--enable-python"
407 "--enable-perl"
408 "--enable-cyrus")))
409 (native-inputs
410 `(("pkg-config" ,pkg-config)
411 ("perl" ,perl)
412 ("python" ,python)))
413 (inputs
414 `(("openssl" ,openssl)
415 ("zlib" ,zlib)
416 ("icu4c" ,icu4c)
417 ("cyrus-sasl" ,cyrus-sasl)))
418 (home-page "http://znc.in")
419 (synopsis "IRC network bouncer")
420 (description "ZNC is an IRC network bouncer or BNC. It can detach the
421 client from the actual IRC server, and also from selected channels. Multiple
422 clients from different locations can connect to a single ZNC account
423 simultaneously and therefore appear under the same nickname on IRC.")
424 (license license:asl2.0)))
425
426 (define-public python-nbxmpp
427 (package
428 (name "python-nbxmpp")
429 (version "0.5.3")
430 (source
431 (origin
432 (method url-fetch)
433 (uri (string-append "https://pypi.python.org/packages/source/n/nbxmpp/"
434 "nbxmpp-" version ".tar.gz"))
435 (sha256
436 (base32
437 "0dcr786dyips1fdvgsn8yvpgcz5j7217fi05c29cfypdl8jnp6mp"))))
438 (build-system python-build-system)
439 ;; No tests included
440 (arguments `(#:tests? #f))
441 (home-page "http://python-nbxmpp.gajim.org")
442 (synopsis "Non-blocking Jabber/XMPP module")
443 (description
444 "The goal of this python library is to provide a way for Python
445 applications to use Jabber/XMPP networks in a non-blocking way. This library
446 was initially a fork of xmpppy, but is using non-blocking sockets.")
447 (license license:gpl3+)))
448
449 (define-public python2-nbxmpp
450 (package-with-python2 python-nbxmpp))
451
452 (define-public gajim
453 (package
454 (name "gajim")
455 (version "0.16.5")
456 (source (origin
457 (method url-fetch)
458 (uri (string-append "https://gajim.org/downloads/"
459 (version-major+minor version)
460 "/gajim-" version ".tar.bz2"))
461 (sha256
462 (base32
463 "14fhcqnkqygh91132dnf1idayj4r3iqbwb44sd3mxv20n6ribh55"))))
464 (build-system gnu-build-system)
465 (arguments
466 `(;; The only check done by gajim-0.16.x is to check that the
467 ;; translations are up-to-date, and in 0.16.5 they are not, so
468 ;; "make check" fails. Therefore, we disable tests for now.
469 ;;
470 ;; XXX TODO Try re-enabling tests in gajim-0.16.6 or later.
471 ;;
472 #:tests? #f
473 #:phases
474 (modify-phases %standard-phases
475 (add-after 'install 'wrap-program
476 (lambda* (#:key outputs #:allow-other-keys)
477 ;; Make sure all Python scripts run with the correct PYTHONPATH.
478 (let ((out (assoc-ref outputs "out"))
479 (path (getenv "PYTHONPATH")))
480 (for-each (lambda (name)
481 (let ((file (string-append out "/bin/" name)))
482 ;; Wrapping destroys identification of intended
483 ;; application, so we need to override "APP".
484 (substitute* file
485 (("APP=`basename \\$0`")
486 (string-append "APP=" name)))
487 (wrap-program file
488 `("PYTHONPATH" ":" prefix (,path)))))
489 '("gajim" "gajim-remote" "gajim-history-manager")))
490 #t)))))
491 (native-inputs
492 `(("intltool" ,intltool)))
493 (propagated-inputs
494 `(("python2-nbxmpp" ,python2-nbxmpp)
495 ("python2-pyopenssl" ,python2-pyopenssl)
496 ("python2-gnupg" ,python2-gnupg)))
497 (inputs
498 `(("python2-pygtk" ,python2-pygtk)
499 ("python" ,python-2)))
500 (home-page "https://gajim.org/")
501 (synopsis "Jabber (XMPP) client")
502 (description "Gajim is a feature-rich and easy to use Jabber/XMPP client.
503 Among its features are: a tabbed chat window and single window modes; support
504 for group chat (with Multi-User Chat protocol), invitation, chat to group chat
505 transformation; audio and video conferences; file transfer; TLS, GPG and
506 end-to-end encryption support; XML console.")
507 (license license:gpl3+)))
508
509 (define-public prosody
510 (package
511 (name "prosody")
512 (version "0.9.10")
513 (source (origin
514 (method url-fetch)
515 (uri (string-append "https://prosody.im/downloads/source/"
516 "prosody-" version ".tar.gz"))
517 (sha256
518 (base32
519 "0bv6s5c0iizz015hh1lxlwlw1iwvisywajm2rcrbdfyrskzfwdj8"))))
520 (build-system gnu-build-system)
521 (arguments
522 `(#:tests? #f ; no "check" target
523 #:configure-flags (list "--no-example-certs")
524 #:modules ((ice-9 match)
525 (srfi srfi-1)
526 (guix build gnu-build-system)
527 (guix build utils))
528 #:phases
529 (modify-phases %standard-phases
530 (add-after 'unpack 'fix-configure-script
531 (lambda _
532 ;; The configure script aborts when it encounters unexpected
533 ;; arguments. Make it more tolerant.
534 (substitute* "configure"
535 (("exit 1") ""))
536 #t))
537 (add-after 'install 'wrap-programs
538 (lambda* (#:key inputs outputs #:allow-other-keys)
539 ;; Make sure all executables in "bin" find the required Lua
540 ;; modules at runtime.
541 (let* ((out (assoc-ref outputs "out"))
542 (bin (string-append out "/bin/"))
543 (deps (delete #f (map (match-lambda
544 ((label . directory)
545 (if (string-prefix? "lua" label)
546 directory #f)))
547 inputs)))
548 (path (string-join
549 (map (lambda (path)
550 (string-append path "/share/lua/5.1/?.lua;"
551 path "/share/lua/5.1/?/?.lua"))
552 (cons out deps))
553 ";"))
554 (cpath (string-join
555 (map (lambda (path)
556 (string-append path "/lib/lua/5.1/?.so;"
557 path "/lib/lua/5.1/?/?.so"))
558 (cons out deps))
559 ";")))
560 (for-each (lambda (file)
561 (wrap-program file
562 `("LUA_PATH" ";" = (,path))
563 `("LUA_CPATH" ";" = (,cpath))))
564 (find-files bin ".*"))
565 #t))))))
566 (inputs
567 `(("libidn" ,libidn)
568 ("openssl" ,openssl)
569 ("lua" ,lua-5.1)
570 ("lua5.1-expat" ,lua5.1-expat)
571 ("lua5.1-socket" ,lua5.1-socket)
572 ("lua5.1-filesystem" ,lua5.1-filesystem)
573 ("lua5.1-sec" ,lua5.1-sec)))
574 (home-page "https://prosody.im/")
575 (synopsis "Jabber (XMPP) server")
576 (description "Prosody is a modern XMPP communication server. It aims to
577 be easy to set up and configure, and efficient with system resources.
578 Additionally, for developers it aims to be easy to extend and give a flexible
579 system on which to rapidly develop added functionality, or prototype new
580 protocols.")
581 (license license:x11)))
582
583 (define-public libtoxcore
584 (let ((revision "1")
585 (commit "755f084e8720b349026c85afbad58954cb7ff1d4"))
586 (package
587 (name "libtoxcore")
588 (version (string-append "0.0.0" "-"
589 revision "."(string-take commit 7)))
590 (source (origin
591 (method git-fetch)
592 (uri (git-reference
593 (url "https://github.com/irungentoo/toxcore.git")
594 (commit commit)))
595 (file-name (string-append name "-" version "-checkout"))
596 (sha256
597 (base32
598 "0ap1gvlyihnfivv235dbrgsxsiiz70bhlmlr5gn1027w3h5kqz8w"))))
599 (build-system gnu-build-system)
600 (native-inputs
601 `(("autoconf" ,autoconf)
602 ("automake" ,automake)
603 ("libtool" ,libtool)
604 ;; TODO: Add when test suite is capable of passing.
605 ;; ("check" ,check)
606 ("pkg-config" ,pkg-config)))
607 (inputs
608 `(("libsodium" ,libsodium)
609 ("opus" ,opus)
610 ("libvpx" ,libvpx)))
611 (arguments
612 `(#:phases
613 (modify-phases %standard-phases
614 (add-after 'unpack 'autoconf
615 (lambda _
616 (zero? (system* "autoreconf" "-vfi")))))
617 #:tests? #f)) ; FIXME: Testsuite fails, reasons unspecific.
618 (synopsis "Library for the Tox encrypted messenger protocol")
619 (description
620 "C library implementation of the Tox encrypted messenger protocol.")
621 (license license:gpl3+)
622 (home-page "https://tox.chat"))))
623
624 (define-public utox
625 (package
626 (name "utox")
627 (version "0.9.8")
628 (source
629 (origin
630 (method url-fetch)
631 (uri (string-append "https://github.com/GrayHatter/uTox/archive/v"
632 version ".tar.gz"))
633 (file-name (string-append name "-" version ".tar.gz"))
634 (sha256
635 (base32
636 "13hfqbwzcgvfbvf9yjm62aqsvxnpqppb50c88sys43m7022yqcsy"))))
637 (build-system gnu-build-system)
638 (arguments
639 '(#:make-flags (list (string-append "PREFIX=" %output)
640 "CC=gcc")
641 #:tests? #f ; No tests
642 #:phases
643 (modify-phases %standard-phases
644 ;; No configure script
645 (delete 'configure))))
646 (inputs
647 `(("dbus" ,dbus)
648 ("filteraudio" ,filteraudio)
649 ("fontconfig" ,fontconfig)
650 ("freetype" ,freetype)
651 ("libsodium" ,libsodium)
652 ("libtoxcore" ,libtoxcore)
653 ("libvpx" ,libvpx)
654 ("libx11" ,libx11)
655 ("libxext" ,libxext)
656 ("libxrender" ,libxrender)
657 ("openal" ,openal)
658 ("v4l-utils" ,v4l-utils)))
659 (native-inputs
660 `(("pkg-config" ,pkg-config)))
661 (synopsis "Lightweight Tox client")
662 (description "A lightweight Tox client. Tox is a distributed and secure
663 instant messenger with audio and video chat capabilities.")
664 (home-page "http://utox.org/")
665 (license license:gpl3)))
666
667 (define-public qtox
668 (package
669 (name "qtox")
670 (version "1.5.1")
671 (source
672 (origin
673 (method url-fetch)
674 (uri (string-append "https://github.com/qTox/qTox/archive/v"
675 version ".tar.gz"))
676 (sha256
677 (base32 "0y15mc39x54k1kz36cw9412kl1p1p6nzlx97gagv4gg3vybfhbjv"))
678 (file-name (string-append name "-" version ".tar.gz"))))
679 (inputs
680 `(("ffmpeg" ,ffmpeg)
681 ("glib" ,glib)
682 ("gtk+" ,gtk+-2)
683 ("libsodium" ,libsodium)
684 ("libtoxcore" ,libtoxcore)
685 ("libvpx" ,libvpx)
686 ("libxscrnsaver" ,libxscrnsaver)
687 ("libx11" ,libx11)
688 ("openal" ,openal)
689 ("qrencode" ,qrencode)
690 ("qt" ,qt)
691 ("sqlcipher" ,sqlcipher)))
692 (native-inputs
693 `(("pkg-config" ,pkg-config)
694 ("qmake" ,qt)))
695 (build-system gnu-build-system)
696 (arguments
697 '(#:phases
698 (modify-phases %standard-phases
699 (add-after 'unpack 'fix-reproducibility-issues
700 (lambda _
701 (substitute* "src/main.cpp"
702 (("__DATE__") "\"\"")
703 (("__TIME__") "\"\"")
704 (("TIMESTAMP") "\"\""))
705 #t))
706 (replace 'configure
707 (lambda* (#:key outputs #:allow-other-keys)
708 (zero?
709 (system* "qmake"
710 (string-append "PREFIX="
711 (assoc-ref outputs "out")))))))))
712 (home-page "https://qtox.github.io/")
713 (synopsis "Tox chat client using Qt")
714 (description "qTox is a Tox client that follows the Tox design
715 guidelines. It provides an easy to use application that allows you to
716 connect with friends and family without anyone else listening in.")
717 (license license:gpl3+)))
718
719 (define-public pybitmessage
720 (package
721 (name "pybitmessage")
722 (version "0.6.1")
723 (source
724 (origin
725 (method url-fetch)
726 (uri (string-append "https://github.com/Bitmessage/"
727 "PyBitmessage/archive/v" version ".tar.gz"))
728 (file-name (string-append name "-" version ".tar.gz"))
729 (sha256
730 (base32
731 "1ffj7raxpp277kphj98190fxrwfx16vmbspk7k3azg3bh5f5idnf"))))
732 (inputs
733 `(("python" ,python-2)
734 ("python:tk" ,python-2 "tk")
735 ("openssl" ,openssl)
736 ("sqlite" ,sqlite)
737 ("qt" ,qt-4)
738 ("python2-pyqt-4" ,python2-pyqt-4)
739 ("python2-sip" ,python2-sip)
740 ("python2-pysqlite" ,python2-pysqlite)
741 ("python2-pyopenssl" ,python2-pyopenssl)))
742 (native-inputs
743 `(("pkg-config" ,pkg-config)))
744 (build-system gnu-build-system)
745 (arguments
746 `(#:imported-modules ((guix build python-build-system)
747 ,@%gnu-build-system-modules)
748 #:make-flags (list (string-append "PREFIX="
749 (assoc-ref %outputs "out")))
750 #:tests? #f ; no test target
751 #:phases
752 (modify-phases %standard-phases
753 (add-before 'build 'fix-makefile
754 (lambda* (#:key inputs #:allow-other-keys)
755 (substitute* "Makefile"
756 (("mkdir -p \\$\\{DESTDIR\\}/usr") "")
757 (("/usr/local") "")
758 (("/usr") "")
759 (("#!/bin/sh") (string-append "#!" (which "bash")))
760 (("python2") (which "python"))
761 (("/opt/openssl-compat-bitcoin/lib/")
762 (string-append (assoc-ref inputs "openssl") "/lib/")))
763 #t))
764 (add-after 'unpack 'fix-unmatched-python-shebangs
765 (lambda* (#:key inputs #:allow-other-keys)
766 (substitute* "src/bitmessagemain.py"
767 (("#!/usr/bin/env python2.7")
768 (string-append "#!" (which "python"))))
769 (substitute* "src/bitmessagecli.py"
770 (("#!/usr/bin/env python2.7.x")
771 (string-append "#!" (which "python"))))
772 #t))
773 (add-after 'unpack 'fix-depends
774 (lambda* (#:key inputs #:allow-other-keys)
775 (substitute* "src/depends.py"
776 (("libcrypto.so")
777 (string-append (assoc-ref inputs "openssl")
778 "/lib/libcrypto.so")))
779 #t))
780 (add-after 'unpack 'fix-local-files-in-paths
781 (lambda* (#:key outputs #:allow-other-keys)
782 (substitute* "src/proofofwork.py"
783 (("bitmsghash.so")
784 (string-append (assoc-ref outputs "out")
785 "/lib/bitmsghash.so")))
786 #t))
787 (add-after 'unpack 'fix-pyelliptic
788 (lambda* (#:key inputs #:allow-other-keys)
789 (substitute* "src/pyelliptic/openssl.py"
790 (("libcrypto.so")
791 (string-append (assoc-ref inputs "openssl")
792 "/lib/libcrypto.so"))
793 (("libssl.so")
794 (string-append (assoc-ref inputs "openssl")
795 "/lib/libssl.so")))
796 #t))
797 ;; XXX: Make does not build and install bitmsghash, do it
798 ;; and place it in /lib.
799 (add-before 'build 'build-and-install-bitmsghash
800 (lambda* (#:key outputs #:allow-other-keys)
801 (chdir "src/bitmsghash")
802 (system* "make")
803 (chdir "../..")
804 (install-file "src/bitmsghash/bitmsghash.so"
805 (string-append (assoc-ref outputs "out") "/lib"))
806 #t))
807 (add-after 'install 'wrap
808 (@@ (guix build python-build-system) wrap)))))
809 (license license:expat)
810 (description
811 "Distributed and trustless peer-to-peer communications protocol
812 for sending encrypted messages to one person or many subscribers.")
813 (synopsis "Distributed peer-to-peer communication")
814 (home-page "https://bitmessage.org/")))
815
816 (define-public ytalk
817 (package
818 (name "ytalk")
819 (version "3.3.0")
820 (source
821 (origin
822 (method url-fetch)
823 (uri (string-append "ftp://ftp.ourproject.org/pub/ytalk/ytalk-"
824 version ".tar.gz"))
825 (sha256
826 (base32
827 "1d3jhnj8rgzxyxjwfa22vh45qwzjvxw1qh8fz6b7nfkj3zvk9jvf"))))
828 (build-system gnu-build-system)
829 (inputs
830 `(("ncurses" ,ncurses)))
831 (home-page "http://ytalk.ourproject.org")
832 (synopsis "Multi-user chat program")
833 (description "Ytalk is a replacement for the BSD talk program. Its main
834 advantage is the ability to communicate with any arbitrary number of users at
835 once. It supports both talk protocols (\"talk\" and \"ntalk\") and can communicate
836 with several different talk daemons at the same time.")
837 (license license:gpl2+)))
838
839 (define-public gloox
840 (package
841 (name "gloox")
842 (version "1.0.17")
843 (source
844 (origin
845 (method url-fetch)
846 (uri (string-append "https://camaya.net/download/gloox-"
847 version ".tar.bz2"))
848 (sha256
849 (base32
850 "09c01jr5nrm7f1ly42wg0pqqscmp48pv8y2fjx1vwbavjxdq59ri"))))
851 (build-system gnu-build-system)
852 (inputs
853 `(("libidn" ,libidn)
854 ("gnutls" ,gnutls)
855 ("zlib" ,zlib)))
856 (native-inputs
857 `(("pkg-config" ,pkg-config)))
858 (synopsis "Portable high-level Jabber/XMPP library for C++")
859 (description
860 "gloox is a full-featured Jabber/XMPP client library,
861 written in ANSI C++. It makes writing spec-compliant clients easy
862 and allows for hassle-free integration of Jabber/XMPP functionality
863 into existing applications.")
864 (home-page "https://camaya.net/gloox")
865 (license license:gpl3)))
866
867 ;;; messaging.scm ends here