gnu: python-file: Don't create a compressed egg.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages kde)
20 #:use-module (guix build-system cmake)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (gnu packages kde-frameworks)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages tls)
28 #:use-module (gnu packages qt))
29
30 (define-public qca
31 (package
32 (name "qca")
33 (version "2.1.1")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "http://download.kde.org/stable/qca/" version
38 "/src/qca-" version ".tar.xz"))
39 (sha256
40 (base32
41 "10z9icq28fww4qbzwra8d9z55ywbv74qk68nhiqfrydm21wkxplm"))))
42 (build-system cmake-build-system)
43 (native-inputs
44 `(("pkg-config" ,pkg-config)))
45 (inputs
46 `(("openssl" ,openssl)
47 ("qtbase" ,qtbase)))
48 (home-page "http://delta.affinix.com/qca/")
49 (synopsis "Libraries for the Qt Cryptographic Architecture")
50 (description "The Qt Cryptographic Architecture (QCA) provides a
51 straightforward and cross-platform API for a range of cryptographic features,
52 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
53 cards.")
54 (license license:lgpl2.1)))
55
56 (define-public snorenotify
57 (package
58 (name "snorenotify")
59 (version "0.7.0")
60 (source
61 (origin
62 (method url-fetch)
63 (uri (string-append "http://download.kde.org/stable/snorenotify/"
64 version "/src/snorenotify-" version ".tar.xz"))
65 (sha256
66 (base32
67 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
68 (build-system cmake-build-system)
69 (arguments
70 `(#:tests? #f)) ; both tests fail, require display
71 (inputs
72 `(("extra-cmake-modules" ,extra-cmake-modules)
73 ("qtbase" ,qtbase)
74 ("qttools" ,qttools)))
75 (home-page "https://techbase.kde.org/Projects/Snorenotify")
76 (synopsis "Qt notification framework")
77 (description "Snorenotify is a multi platform Qt notification framework.
78 Using a plugin system it is possible to create notifications with many
79 different notification systems.")
80 (license license:lgpl3)))