Import Debian changes 20180207-1
[hcoop/debian/mlton.git] / debian / patches / linux-pic.patch
1 --- a/mlton/main/main.fun
2 +++ b/mlton/main/main.fun
3 @@ -977,6 +977,7 @@
4 (* On ELF systems, we only need PIC for LibArchive/Library *)
5 | (_, _, Library) => true
6 | (_, _, LibArchive) => true
7 + | (Linux, _, _) => true
8 | _ => false
9 val () = Control.positionIndependent := positionIndependent
10