* apt-pkg/deb/debversion.cc:
[ntk/apt.git] / debian / changelog
index 7e38cda..b0d7cb5 100644 (file)
-apt (0.7.25.1) UNRELEASED; urgency=low
+apt (0.7.26) UNRELEASED; urgency=low
 
-  * merged lp:~mvo/apt/history
+  * Switch to dpkg-source 3.0 (native) format
+  * cmdline/apt-mark:
+    - don't crash if no arguments are given (Closes: #570962)
+  * debian/control:
+    - remove some years old and obsolete Replaces
+  * apt-pkg/contrib/mmap.{h,cc}:
+    - add char[] fallback for filesystems without shared writable
+      mmap() like JFFS2. Thanks to Marius Vollmer for writing
+      and to Loïc Minier for pointing to the patch! (Closes: #314334)
+  * doc/apt_preferences.5.xml:
+    - fix two typos and be more verbose in the novice warning.
+      Thanks to Osamu Aoki for pointing it out! (Closes: #567669)
+  * apt-pkg/deb/dpkgpm.cc:
+    - fix error message construction in OpenLog()
+    - if available store the Commandline in the history
+  * cmdline/apt-get.cc:
+    - add a --only-upgrade flag to install command (Closes: #572259)
+    - fix memory leaks in error conditions in DoSource()
+  * apt-pkg/contrib/cmndline.cc:
+    - save Commandline in Commandline::AsString for logging
+  * apt-pkg/deb/debversion.cc:
+    - consider absent of debian revision equivalent to 0 (Closes: #573592)
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 19 Feb 2010 21:21:43 +0100
+
+apt (0.7.26~exp2) experimental; urgency=low
+
+  * fix crash when LANGUAGE is not set
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 18 Feb 2010 22:07:23 +0100
+
+apt (0.7.26~exp1) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * [BREAK] add possibility to download and use multiply
+    Translation files, configurable with Acquire::Translation
+    (Closes: #444222, #448216, #550564)
+  * Ignore :qualifiers after package name in build dependencies
+    for now as long we don't understand them (Closes: #558103)
+  * apt-pkg/contrib/mmap.{cc,h}:
+    - extend it to have a growable flag - unused now but maybe...
+  * apt-pkg/pkgcache.h:
+    - use long instead of short for {Ver,Desc}File size,
+      patch from Víctor Manuel Jáquez Leal, thanks! (Closes: #538917)
+  * apt-pkg/acquire-item.cc:
+    - allow also to skip the last patch if target is reached,
+      thanks Bernhard R. Link! (Closes: #545699)
+  * ftparchive/writer.{cc,h}:
+    - add --arch option for packages and contents commands
+    - if an arch is given accept only *_all.deb and *_arch.deb instead
+      of *.deb. Thanks Stephan Bosch for the patch! (Closes: #319710)
+    - add APT::FTPArchive::AlwaysStat to disable the too aggressive
+      caching if versions are build multiply times (not recommend)
+      Patch by Christoph Goehre, thanks! (Closes: #463260)
+  * apt-pkg/deb/dpkgpm.cc:
+    - stdin redirected to /dev/null takes all CPU (Closes: #569488)
+      Thanks to Aurelien Jarno for providing (again) a patch!
+  * buildlib/apti18n.h.in, po/makefile:
+    - add ngettext support with P_()
+  * aptconfiguration.cc:
+    - include all existing Translation files in the Cache (Closes: 564137)
+  * debian/control:
+    - update with no changes to debian policy 3.8.4
+  * doc/apt_preferences.5.xml:
+    - explicitly warn against careless use (Closes: #567669)
+  * debian/rules:
+    - remove creation of empty dir /usr/share/apt
+  * doc/apt-cdrom.8.xml:
+    - fix typo spotted by lintian: proc(c)eed
+
+  [ Ivan Masár ]
+  * Slovak translation update. Closes: #568294
+  
+  [ Michael Vogt ]
+  * [BREAK] merged lp:~mvo/apt/history
     - this writes a /var/log/apt/history tagfile that contains details
       from the transaction (complements term.log)
+  * methods/http.cc:
+    - add cache-control headers even if no cache is given to allow
+      adding options for intercepting proxies
+    - add Acquire::http::ProxyAutoDetect configuration that 
+      can be used to call a external helper to figure out the 
+      proxy configuration and return it to apt via stdout
+      (this is a step towards WPAD and zeroconf/avahi support)
+  * abicheck/
+    - add new abitest tester using the ABI Compliance Checker from
+      http://ispras.linuxfoundation.org/index.php/ABI_compliance_checker
+
+  [ Robert Collins ]
+  * Change the package index Info methods to allow apt-cache policy to be
+    useful when using several different archives on the same host.
+    (Closes: #329814, LP: #22354)
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 18 Feb 2010 16:11:39 +0100
+
+apt (0.7.25.3) unstable; urgency=low
+
+  [ Christian Perrier ]
+  * Italian translation update. Closes: #567532
+
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/macros.h:
+    - install the header system.h with a new name to be able to use
+      it in other headers (Closes: #567662)
+  * cmdline/acqprogress.cc:
+    - Set Mode to Medium so that the correct prefix is used.
+      Thanks Stefan Haller for the patch! (Closes: #567304 LP: #275243)
+  * ftparchive/writer.cc:
+    - generate sha1 and sha256 checksums for dsc (Closes: #567343)
   * cmdline/apt-get.cc:
-    - fix apt-get source pkg=version regression (closes: #561971)
+    - don't mark as manually if in download only (Closes: #468180)
+
+ -- Michael Vogt <mvo@debian.org>  Mon, 01 Feb 2010 18:41:15 +0100
+
+apt (0.7.25.2) unstable; urgency=low
+
+  [ Michael Vogt ]
   * apt-pkg/contrib/cdromutl.cc:
     - fix UnmountCdrom() fails, give it a bit more time and try
       the umount again
+  * apt-pkg/cdrom.cc:
+    - fix crash in pkgUdevCdromDevices
   * methods/cdrom.cc:
-    - fixes in multi cdrom setup code
-    - add new "Acquire::cdrom::AutoDetect" variable that enables/disables
-      the dlopen of libudev for automatic cdrom detection
+    - fixes in multi cdrom setup code (closes: #549312)
+    - add new "Acquire::cdrom::AutoDetect" config that enables/disables
+      the dlopen of libudev for automatic cdrom detection. Off by default
+      currently, feedback/testing welcome
+  * cmdline/apt-cdrom.cc:
+    - add new --auto-detect option that uses libudev to figure out
+      the cdrom/mount-point
+  * cmdline/apt-mark:
+    - merge fix from Gene Cash that supports markauto for
+      packages that are not in the extended_states file yet
+      (closes: #534920)
+  * ftparchive/writer.{cc,h}:
+    - merge crash fix for apt-ftparchive on hurd, thanks to
+      Samuel Thibault for the patch (closes: #566664)
+
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/fileutl.cc:
+    - Fix the newly introduced method GetListOfFilesInDir to not
+      accept every file if no extension is enforced
+      (= restore old behaviour). (Closes: #565213)
+  * apt-pkg/policy.cc:
+    - accept also partfiles with "pref" file extension as valid
+  * apt-pkg/contrib/configuration.cc:
+    - accept also partfiles with "conf" file extension as valid
+  * doc/apt.conf.5.xml:
+    - reorder description and split out syntax
+    - add partfile name convention (Closes: #558348)
+  * doc/apt_preferences.conf.5.xml:
+    - describe partfile name convention also here
+  * apt-pkg/deb/dpkgpm.cc:
+    - don't segfault if term.log file can't be opened.
+      Thanks Sam Brightman for the patch! (Closes: #475770)
+  * doc/*:
+    - replace the per language addendum with a global addendum
+    - add a explanation why translations include (maybe) english
+      parts to the new global addendum (Closes: #561636)
+  * apt-pkg/contrib/strutl.cc:
+    - fix malloc asseration fail with ja_JP.eucJP locale in
+      apt-cache search. Thanks Kusanagi Kouichi! (Closes: #548884)
+
+  [ Christian Perrier ]
+  * French translation update
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 27 Jan 2010 16:16:10 +0100
+
+apt (0.7.25.1) unstable; urgency=low
+
+  [ Christian Perrier ]
+  * French manpage translation update
+  * Russian translation update by Yuri Kozlov
+    Closes: #564171
+
+  [Chris Leick]
+  * spot & fix various typos in all manpages
+  * German manpage translation update
+
+  [ David Kalnischkies ]
+  * cmdline/apt-cache.cc:
+    - remove translatable marker from the "%4i %s\n" string
+  * buildlib/po4a_manpage.mak:
+    - instruct debiandoc to build files with utf-8 encoding
+  * buildlib/tools.m4:
+    - fix some warning from the buildtools
+  * apt-pkg/acquire-item.cc:
+    - add configuration PDiffs::Limit-options to not download
+      too many or too big patches (Closes: #554349)
+  * debian/control:
+    - let all packages depend on ${misc:Depends}
+  * share/*-archive.gpg:
+    - remove the horrible outdated files. We already depend on
+      the keyring so we don't need to ship our own version
+  * cmdline/apt-key:
+    - errors out if wget is not installed (Closes: #545754)
+    - add --keyring option as we have now possibly many
+  * methods/gpgv.cc:
+    - pass all keyrings (TrustedParts) to gpgv instead of
+      using only one trusted.gpg keyring (Closes: #304846)
+  * methods/https.cc:
+    - finally merge the rest of the patchset from Arnaud Ebalard
+      with the CRL and Issuers options, thanks! (Closes: #485963)
+  * apt-pkg/deb/debindexfile.cc, apt-pkg/pkgcachegen.cc:
+    - add debug option Debug::pkgCacheGen
+
+  [ Michael Vogt ]
+  * cmdline/apt-get.cc:
+    - merge fix for apt-get source pkg=version regression
+      (closes: #561971)
+  * po/ru.po:
+    - merged updated ru.po, thanks to Yuri Kozlov (closes: #564171)
 
- -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 18 Dec 2009 16:54:18 +0100
+ -- Michael Vogt <mvo@debian.org>  Sat, 09 Jan 2010 21:52:36 +0100
 
 apt (0.7.25) unstable; urgency=low