* apt-pkg/contrib/error.{cc,h}
[ntk/apt.git] / debian / changelog
index f819908..5457036 100644 (file)
@@ -1,4 +1,103 @@
-apt (0.7.26~exp8) UNRELEASED; urgency=low
+apt (0.7.26~exp11) experimental; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Write architecture information to history file.
+    - Add to history whether a change was automatic or not.
+  * apt-pkg/contrib/fileutl.cc:
+    - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+  * cmdline/apt-get.cc:
+    - Support large filesystems by using statvfs64() instead of statvfs()
+      and statfs64() instead of statfs() (Closes: #590513).
+  * apt-pkg/cdrom.cc:
+    - Use link() instead of rename() for creating the CD database backup;
+      otherwise there would be a short time without any database.
+
+  [ David Kalnischkies ]
+  * apt-pkg/depcache.cc:
+    - handle "circular" conflicts for "all" packages correctly
+  * cmdline/apt-cache.cc:
+    - be able to omit dependency types in (r)depends (Closes: #319006)
+    - show in (r)depends the canidate per default instead of newest
+    - share the (r)depends code instead of codecopy
+  * apt-pkg/cacheset.cc:
+    - move them back to the library as they look stable now
+    - add a 'newest' pseudo target release as in pkg/newest
+  * apt-pkg/pkgcache.cc:
+    - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+  * test/integration/*:
+    - add with bug#590041 testcase a small test "framework"
+  * apt-pkg/orderlist.cc:
+    - try to install another or-group member in DepRemove before
+      breaking the or group (Closes: #590438)
+    - configure also the replacement before remove by adding Immediate flag
+  
+  [ Michael Vogt ]
+  * apt-pkg/contrib/error.{cc,h}
+    - docstring cleanup
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Mon, 26 Jul 2010 12:40:44 +0200
+
+apt (0.7.26~exp10) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/error.{cc,h}:
+    - remove constness of va_list parameter to fix build on amd64 and co
+      Thanks Eric Valette! (Closes: #588610)
+  * apt-pkg/deb/debmetaindex.cc:
+    - do not query each architecture for flat file archives
+    - fix typo preventing display of architecture in Info()
+  * methods/bzip2.cc:
+    - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
+
+  [ Martin Pitt ]
+  * debian/rules:
+    - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+      CXXFLAGS.
+  * apt-pkg/contrib/fileutl.{h,cc}:
+    - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+      OpenMode. (Closes: #188407)
+    - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
+    - [ABI BREAK] This adds a new private member to FileFd, but its
+      initialization is in the public header file.
+  * configure.in:
+    - Check for zlib library and headers.
+  * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+    apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+    cmdline/apt-cache.cc:
+    - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
+  * apt-pkg/deb/debindexfile.cc:
+    - If we do not find uncompressed package/source/translation indexes, look
+      for gzip compressed ones.
+  * apt-pkg/acquire-item.cc:
+    - If the Acquire::GzipIndexes option is true and we download a gzipped
+      index file, keep it as it is (and rename to .gz) instead of
+      uncompressing it.
+  * doc/apt.conf.5.xml:
+    - Document the new Acquire::GzipIndexes option.
+  * doc/po/apt-doc.pot, doc/po/de.po:
+    - German translation of new Acquire::GzipIndexes option.
+  * Add test/test-indexes.sh:
+    - Test behaviour of index retrieval and usage, in particular with
+      uncompressed and gzip compressed indexes.
+  * methods/gzip.cc: With FileFd now being able to read gzipped files, there
+    is no need for the gzip method any more to spawn an external gzip process.
+    Rewrite it to use FileFd directly, which makes the code a lot simpler, and
+    also using less memory and overhead.
+
+ -- Michael Vogt <mvo@debian.org>  Mon, 12 Jul 2010 11:41:01 +0200
+
+apt (0.7.26~exp9) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * doc/apt.conf.5.xml:
+    - add and document APT::Cache-{Start,Grow,Limit} options for mmap control
+  * apt-pkg/contrib/fileutl.cc:
+    - do not fail von double close()
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 09 Jul 2010 21:51:55 +0200
+
+apt (0.7.26~exp8) experimental; urgency=low
 
   [ David Kalnischkies ]
   * cmdline/cacheset.cc:
@@ -40,8 +139,10 @@ apt (0.7.26~exp8) UNRELEASED; urgency=low
   * apt-pkg/pkgcachegen.{cc,h}:
     - make the used MMap moveable (and therefore dynamic resizeable) by
       applying (some) mad pointer magic (Closes: #195018)
-  * doc/apt.conf.5.xml:
-    - add and document APT::Cache-{Start,Grow,Limit} options for mmap control
+
+  [ Michael Vogt ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - make the apt/term.log output unbuffered (thanks to Matt Zimmerman)
 
   [ Julian Andres Klode ]
   * methods/ftp.h:
@@ -57,7 +158,7 @@ apt (0.7.26~exp8) UNRELEASED; urgency=low
   * debian/control:
     - Set Standards-Version to 3.9.0
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 09 Jul 2010 16:55:53 +0200
+ -- Michael Vogt <mvo@debian.org>  Fri, 09 Jul 2010 19:16:20 +0200
 
 apt (0.7.26~exp7) experimental; urgency=low