* apt-pkg/acquire-item.cc:
[ntk/apt.git] / debian / changelog
index e82740f..5b56577 100644 (file)
-apt (0.7.13) UNRELEASED; urgency=low
+apt (0.7.17~exp2) experimental; urgency=low
 
+  [ Eugene V. Lyubimkin ]
+  * apt-pkg/acquire-item.cc:
+    - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
+      available. (Closes: #409284)
+  * apt-pkg/algorithm.cc:
+    - Strip username and password from source URL in error message.
+      (Closes: #425150)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com>  Fri, 24 Oct 2008 23:45:17 +0300
+
+
+apt (0.7.17~exp1) experimental; urgency=low
+
+  [ Luca Bruno ]
+  * Fix typos:
+    - apt-pkg/depcache.cc
+  * Fix compilation warnings:
+    - apt-pkg/acquire.cc
+    - apt-pkg/versionmatch.cc
+  * Compilation fixes and portability improvement for compiling APT against non-GNU libc
+    (thanks to Martin Koeppe, closes: #392063):
+    - buildlib/apti18n.h.in:
+      + textdomain() and bindtextdomain() must not be visible when --disable-nls
+    - buildlib/inttypes.h.in: undefine standard int*_t types
+    - Append INTLLIBS to SLIBS:
+      + cmdline/makefile
+      + ftparchive/makefile
+      + methods/makefile
+  * doc/apt.conf.5.xml:
+    - clarify whether configuration items of apt.conf are case-sensitive
+      (thanks to Vincent McIntyre, closes: #345901)
+
+ -- Luca Bruno <lethalman88@gmail.com>  Sat, 11 Oct 2008 09:17:46 +0200
+
+apt (0.7.16) unstable; urgency=low
+
+  [ Luca Bruno ]
+  * doc/apt-cache.8.xml:
+    - search command uses POSIX regex, and searches for virtual packages too
+      (closes: #277536)
+  * doc/offline.sgml: clarify remote and target hosts
+    (thanks to Nikolaus Schulz, closes: #175940)
+  * Fix several typos in docs, translations and debian/changelog
+    (thanks to timeless, Nicolas Bonifas and Josh Triplett,
+    closes: #368665, #298821, #411532, #431636, #461458)
+  * Document apt-key finger and adv commands
+    (thanks to Stefan Schmidt, closes: #350575)
+  * Better documentation for apt-get --option
+    (thanks to Tomas Pospisek, closes: #386579)
+  * Retitle the apt-mark.8 manpage (thanks to Justin Pryzby, closes: #471276)
+  * Better documentation on using both APT::Default-Release and
+    /etc/apt/preferences (thanks to Ingo Saitz, closes: #145575)
+  
+  [ Michael Vogt ]
+  * doc/apt-cache.8.xml:
+    - add missing citerefentry
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 10 Oct 2008 23:44:50 +0200
+
+apt (0.7.15) unstable; urgency=low
+
+  * Upload to unstable
+
+ -- Michael Vogt <mvo@debian.org>  Sun, 05 Oct 2008 13:23:47 +0200
+
+apt (0.7.15~exp3) experimental; urgency=low
+
+  [Daniel Burrows]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Store the trigger state descriptions in a way that does not break
+      the ABI.  The approach taken makes the search for a string O(n) rather
+      than O(lg(n)), but since n == 4, I do not consider this a major
+      concern.  If it becomes a concern, we can sort the static array and
+      use std::equal_range().  (Closes: #499322)
+
+  [ Michael Vogt ]
+  * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+    - move the state file writting into the Go() implementation
+      of dpkgpm (closes: #498799)
+  * apt-pkg/algorithms.cc:
+    - fix simulation performance drop (thanks to Ferenc Wagner
+      for reporting the issue)
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 01 Oct 2008 18:09:49 +0200
+
+apt (0.7.15~exp2) experimental; urgency=low
+
+  [ Michael Vogt ]
+  * apt-pkg/pkgcachegen.cc:
+    - do not add multiple identical descriptions for the same 
+      language (closes: #400768)
+
+  [ Program translations ]
+  * Catalan updated. Closes: #499462
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 23 Sep 2008 07:29:59 +0200
+
+apt (0.7.15~exp1) experimental; urgency=low
+
+  [ Christian Perrier ]
+  * Fix typo in cron.daily script. Closes: #486179
+
+  [ Program translations ]
+  * Traditional Chinese updated. Closes: #488526
+  * German corrected and completed. Closes: #490532, #480002, #498018
+  * French completed
+  * Bulgarian updated. Closes: #492473
+  * Slovak updated. Closes: #492475
+  * Galician updated. Closes: #492794
+  * Japanese updated. Closes: #492975
+  * Fix missing space in Greek translation. Closes: #493922
+  * Greek updated.
+  * Brazilian Portuguese updated.
+  * Basque updated. Closes: #496754
+  * Romanian updated. Closes: #492773, #488361
+  * Portuguese updated. Closes: #491790
+  * Simplified Chinese updated. Closes: #489344
+  * Norwegian Bokmål updated. Closes: #480022
+  * Czech updated. Closes: #479628, #497277
+  * Korean updated. Closes: #464515
+  * Spanish updated. Closes: #457706
+  * Lithuanian added. Closes: #493328
+  * Swedish updated. Closes: #497496
+  * Vietnamese updated. Closes: #497893
+  * Portuguese updated. Closes: #498411
+  * Greek updated. Closes: #498687
+  * Polish updated.
+
+  [ Michael Vogt ]
+  * merge patch that enforces stricter https server certificate
+    checking (thanks to Arnaud Ebalard, closes: #485960)
+  * allow per-mirror specific https settings
+    (thanks to Arnaud Ebalard, closes: #485965)
+  * add doc/examples/apt-https-method-example.cof
+    (thanks to Arnaud Ebalard, closes: #485964)
+  * apt-pkg/depcache.cc:
+    - when checking for new important deps, skip critical ones
+      (closes: #485943)
+  * improve apt progress reporting, display trigger actions
+  * add DPkg::NoTriggers option so that applications that call
+    apt/aptitude (like the installer) defer trigger processing
+    (thanks to Joey Hess)
+  * doc/makefile:
+    - add examples/apt-https-method-example.conf
+  
+ -- Michael Vogt <mvo@debian.org>  Tue, 16 Sep 2008 21:27:03 +0200
+
+apt (0.7.14) unstable; urgency=low
+
+  [ Christian Perrier ]
+  * Mark a message from dselect backend as translatable
+    Thanks to Frédéric Bothamy for the patch
+    Closes: #322470
+
+  [ Program translations ]
+  * Simplified Chinese updated. Closes: #473360
+  * Catalan fixes. Closes: #387141
+  * Typo fix in Greek translation. Closes: #479122
+  * French updated.
+  * Thai updated. Closes: #479313
+  * Italian updated. Closes: #479326
+  * Polish updated. Closes: #479342
+  * Bulgarian updated. Closes: #479379
+  * Finnish updated. Closes: #479403
+  * Korean updated. Closes: #479426
+  * Basque updated. Closes: #479452
+  * Vietnamese updated. Closes: #479748
+  * Russian updated. Closes: #479777, #499029
+  * Galician updated. Closes: #479792
+  * Portuguese updated. Closes: #479847
+  * Swedish updated. Closes: #479871
+  * Dutch updated. Closes: #480125
+  * Kurdish added. Closes: #480150
+  * Brazilian Portuguese updated. Closes: #480561
+  * Hungarian updated. Closes: #480662
+
+  [ Otavio Salvador ]
+  * Apply patch to avoid truncating of arbitrary files. Thanks to Bryan
+    Donlan <bdonlan@fushizen.net> for the patch. Closes: #482476
+  * Avoid using dbus if dbus-daemon isn't running. Closes: #438803
+  
+  [ Michael Vogt ]
+  * debian/apt.cron.daily:
+    - apply patch based on the ideas of Francesco Poli for better 
+      behavior when the cache can not be locked (closes: #459344)
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 28 May 2008 15:19:12 +0200
+
+apt (0.7.13) unstable; urgency=low
+
+  [ Otavio Salvador ]
   * Add missing build-depends back from build-depends-indep field.
     Closes: #478231
   * Make cron script quiet if cache is locked. Thanks to Ted Percival
     <ted@midg3t.net> for the patch. Closes: #459344
+  * Add timeout support for https. Thanks to Andrew Martens
+    <andrew.martens@strangeloopnetworks.com> for the patch.
 
+  [ Goswin von Brederlow ]
+  * Add support for --no-download on apt-get update. Closes: #478517
+  
   [ Program translations ]
     - Vietnamese updated. Closes: #479008
     
- -- Otavio Salvador <otavio@debian.org>  Fri, 02 May 2008 12:07:08 -0300
+ -- Otavio Salvador <otavio@debian.org>  Fri, 02 May 2008 14:46:00 -0300
 
 apt (0.7.12) unstable; urgency=low
 
@@ -39,6 +235,7 @@ apt (0.7.12) unstable; urgency=low
       starting the upate to hit the mirrors less hard
   * doc/apt_preferences.5.xml:
     - fix typo
+  * added debian/README.source
 
   [ Christian Perrier ]
   * Fix typos in manpages. Thanks to Daniel Leidert for the fixes
@@ -378,7 +575,7 @@ apt (0.7.3) unstable; urgency=low
     Daniel Burrows, closes: #429378)
   * fixes in the auto-mark code (thanks to Daniel
     Burrows)
-  * fix FTFBFS by changing build-depends to
+  * fix FTBFS by changing build-depends to
     libcurl4-gnutls-dev (closes: #428363)
   * cmdline/apt-get.cc:
     - fix InstallTask code when a pkgRecord ends 
@@ -442,7 +639,7 @@ apt (0.7.2) unstable; urgency=low
 
 apt (0.7.1) experimental; urgency=low
 
-  * ABI library name change because its build against
+  * ABI library name change because it's built against
     new glibc
   * implement SourceVer() in pkgRecords 
      (thanks to Daniel Burrows for the patch!)
@@ -492,9 +689,9 @@ apt (0.7.1) experimental; urgency=low
 
 apt (0.7.0) experimental; urgency=low
 
-  * Package that contains tall the new features
+  * Package that contains all the new features
   * Removed all #pragma interface/implementation
-  * Branch that contains tall the new features:
+  * Branch that contains all the new features:
   * translated package descriptions
   * task install support
   * automatic dependency removal (thanks to Daniel Burrows)