* apt-pkg/contrib/error.{cc,h}
[ntk/apt.git] / debian / changelog
index cfac232..5457036 100644 (file)
@@ -1,4 +1,44 @@
-apt (0.7.26~exp10) UNRELEASED; urgency=low
+apt (0.7.26~exp11) experimental; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Write architecture information to history file.
+    - Add to history whether a change was automatic or not.
+  * apt-pkg/contrib/fileutl.cc:
+    - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+  * cmdline/apt-get.cc:
+    - Support large filesystems by using statvfs64() instead of statvfs()
+      and statfs64() instead of statfs() (Closes: #590513).
+  * apt-pkg/cdrom.cc:
+    - Use link() instead of rename() for creating the CD database backup;
+      otherwise there would be a short time without any database.
+
+  [ David Kalnischkies ]
+  * apt-pkg/depcache.cc:
+    - handle "circular" conflicts for "all" packages correctly
+  * cmdline/apt-cache.cc:
+    - be able to omit dependency types in (r)depends (Closes: #319006)
+    - show in (r)depends the canidate per default instead of newest
+    - share the (r)depends code instead of codecopy
+  * apt-pkg/cacheset.cc:
+    - move them back to the library as they look stable now
+    - add a 'newest' pseudo target release as in pkg/newest
+  * apt-pkg/pkgcache.cc:
+    - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+  * test/integration/*:
+    - add with bug#590041 testcase a small test "framework"
+  * apt-pkg/orderlist.cc:
+    - try to install another or-group member in DepRemove before
+      breaking the or group (Closes: #590438)
+    - configure also the replacement before remove by adding Immediate flag
+  
+  [ Michael Vogt ]
+  * apt-pkg/contrib/error.{cc,h}
+    - docstring cleanup
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Mon, 26 Jul 2010 12:40:44 +0200
+
+apt (0.7.26~exp10) experimental; urgency=low
 
   [ David Kalnischkies ]
   * apt-pkg/contrib/error.{cc,h}:
@@ -45,7 +85,7 @@ apt (0.7.26~exp10) UNRELEASED; urgency=low
     Rewrite it to use FileFd directly, which makes the code a lot simpler, and
     also using less memory and overhead.
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Sun, 11 Jul 2010 21:56:36 +0200
+ -- Michael Vogt <mvo@debian.org>  Mon, 12 Jul 2010 11:41:01 +0200
 
 apt (0.7.26~exp9) experimental; urgency=low