[cmdline/apt-get.cc] check for availability ofstatfs.f_type
[ntk/apt.git] / debian / changelog
index 4e3177e..fd6f853 100644 (file)
@@ -1,16 +1,53 @@
-apt (0.7.23) unstable; urgency=low
+apt (0.7.22.3) unstable; urgency=low
+
+  [ David Kalnischkies ]
+  * cmdline/apt-get.cc:
+    - add APT::Get::HideAutoRemove=small to display only a short line
+      instead of the full package list. (Closes: #537450)
+    - ShowBroken() in build-dep (by Mike O'Connor, Closes: #145916)
+    - check for statfs.f_type (by Robert Millan, Closes: #509313)
+  * apt-pkg/contrib/strutl.cc:
+    - enable thousand separator according to the current locale
+      (by Luca Bruno, Closes: #223712)
+  * doc/apt.conf.5.xml:
+    - mention the apt.conf.d dir (by Vincent McIntyre, Closes: #520831)
+
+  [ George Danchev ]
+  * cmdline/apt-cache.cc:
+    - fix a memory leak in the xvcg method (Closes: #511557)
+  * apt-pkg/indexcopy.cc:
+    - fix a memory leak then the Release file not exists (Closes: #511556)
+
+ -- David Kalnischkies <david@kalnischkies.com>  Sat, 08 Aug 2009 09:40:08 +0200
+
+apt (0.7.22.2) unstable; urgency=low
+
+  * debian/apt.cron.daily:
+    - Make sure that VERBOSE is always set (Closes: #539366)
+    - Script can be disabled by APT::Periodic::Enable=0 (Closes: #485476)
+    - Support using debdelta to download packages (Closes: #532079)
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 06 Aug 2009 12:17:19 +0200
+
+apt (0.7.22.1) unstable; urgency=low
 
   [ Michael Vogt ]
   * cmdline/apt-get.cc:
     - honor APT::Get::Only-Source properly in FindSrc() (thanks to
-      Martin Pitt for reporting the problem)
+      Martin Pitt for reporting the problem), also Closes: #535362.
 
   [ Julian Andres Klode ]
   * apt-pkg/contrib/mmap.cc:
     - Fix FTBFS on GNU/kFreeBSD by disabling DynamicMMap::Grow() on
-      non-Linux architectures (as it uses mremap).
+      non-Linux architectures as it uses mremap (Closes: #539742).
+  * apt-pkg/sourcelist.cc:
+    - Only warn about missing sources.list if there is no sources.list.d
+      and vice versa as only one of them is needed (Closes: #539731).
+  * debian/control:
+    - Add myself to Uploaders.
+    - Increase Standards-Version to 3.8.2.0.
 
- -- Julian Andres Klode <jak@debian.org>  Sun, 02 Aug 2009 19:35:23 +0200
+ -- Julian Andres Klode <jak@debian.org>  Mon, 03 Aug 2009 12:48:31 +0200
 
 apt (0.7.22) unstable; urgency=low
 
@@ -69,7 +106,7 @@ apt (0.7.22) unstable; urgency=low
       (off by default)
     - send "dpkg-exec" message on the status fd when dpkg is run
     - provide DPkg::Chroot-Directory config option (useful for testing)
-    - fix potential hang when in a backgroud process group
+    - fix potential hang when in a background process group
   * apt-pkg/algorithms.cc:
     - consider recommends when making the scores for the problem 
       resolver
@@ -98,7 +135,7 @@ apt (0.7.22) unstable; urgency=low
   * apt-pkg/deb/debsystem.cc:
     - make strings i18n able 
   * fix problematic use of tolower() when calculating the version 
-    hash by using locale independant tolower_ascii() function. 
+    hash by using locale independent tolower_ascii() function. 
     Thanks to M. Vefa Bicakci (LP: #80248)
   * build fixes for g++-4.4
   * cmdline/apt-mark: