* apt-pkg/acquire-item.cc:
[ntk/apt.git] / debian / changelog
index 32f2ac6..7b71c36 100644 (file)
-apt (0.6.46.4ubuntu11) UNRELEASED; urgency=low
+apt (0.7.6ubuntu5) UNRELEASED; urgency=low
 
+  * apt-pkg/acquire-item.cc:
+    - fix file removal on local repo i-m-s hit (LP: #131166)
+  * tests/local-repo:
+    - added regression test for this bug
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 09 Aug 2007 12:34:07 +0200
+
+apt (0.7.6ubuntu4) gutsy; urgency=low
+
+  * cmdline/apt-get.cc:
+    - remove YnPrompt when a XS-Vcs- tag is found, improve the
+      notice (LP: #129575)
+  * methods/copy.cc:
+    - take hashes here too
+  * apt-pkg/acquire-worker.cc:
+    - only pass on computed hash if we recived one from the method
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 08 Aug 2007 19:30:29 +0200
+
+apt (0.7.6ubuntu3) gutsy; urgency=low
+
+  * apt-pkg/deb/dpkgpm.cc:
+    - fix packagename extraction when writting apport reports
+  * apt-pkg/pkgcachegen.cc:
+    - increase default mmap size (LP: #125640)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 07 Aug 2007 09:52:00 +0200
+
+apt (0.7.6ubuntu2) gutsy; urgency=low
+
+  * doc/examples/sources.list:
+    - change example source to gutsy
+  * apt-pkg/deb/dpkgpm.cc:
+    - do not break if no /dev/pts is available
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 06 Aug 2007 15:17:57 +0200
+
+apt (0.7.6ubuntu1) gutsy; urgency=low
+
+  * apt-inst/contrib/extracttar.cc:
+    - fix fd leak for zero size files (thanks to Bill Broadley for
+      reporting this bug)
+  * apt-pkg/acquire-item.cc:
+    - remove zero size files on I-M-S hit
+  * methods/https.cc:
+    - only send LastModified if we actually have one
+    - send range request with if-range 
+    - delete failed downloads
+    (thanks to Thom May for his help here)
+  * apt-pkg/deb/dpkgpm.{cc,h}:
+    - merged dpkg-log branch, this lets you specify a 
+      Dir::Log::Terminal file to log dpkg output to
+    (ABI break)
+    - when writting apport reports, attach the dpkg
+      terminal log too
+  * merged apt--sha256 branch to fully support the new
+    sha256 checksums in the Packages and Release files
+    (ABI break)
+  * apt-pkg/pkgcachegen.cc:
+    - increase default mmap size
+  * tests/local-repo:
+    - added local repository testcase
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 02 Aug 2007 11:55:54 +0200
+
+apt (0.7.6) unstable; urgency=low
+
+  * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+    directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org>  Wed, 01 Aug 2007 19:49:51 -0300
+
+apt (0.7.5) unstable; urgency=low
+
+  [ Otavio Salvador ]
+  * Applied patch from Guillem Jover <guillem@debian.org> to use
+    dpkg-architecture to get the host architecture (closes: #407187)
+  * Applied patch from Guillem Jover <guillem@debian.org> to add
+    support to add lzma support (closes: #408201)
+
+  [ Michael Vogt ]
+  * apt-pkg/depcache.cc:
+    - support a list of sections for:
+      APT::Install-Recommends-Sections
+      APT::Never-MarkAuto-Sections
+  * methods/makefile:
+    - install lzma symlink method (for full lzma support)
+  * debian/control:
+    - suggest "lzma"
+
+ -- Otavio Salvador <otavio@ossystems.com.br>  Wed, 25 Jul 2007 20:16:46 -0300
+
+apt (0.7.4ubuntu1) gutsy; urgency=low
+
+  * debian/apt.conf.ubuntu, apt.conf.autoremove:
+    - Change metapackages to {restricted,universe,multiverse}/metapackages 
+      in Install-Recommends-Sections and Never-MarkAuto-Sections
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 26 Jul 2007 10:42:29 +0200
+
+apt (0.7.4) unstable; urgency=low
+
+  [ Michael Vogt ]
+  * cmdline/apt-get.cc:
+    - fix in the task-install code regexp (thanks to Adam Conrad and
+      Colin Watson)
+    - support task removal too: apt-get remove taskname^
+      (thanks to Matt Zimmerman reporting this problem)
+
+  [ Otavio Salvador ]
+  * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+  * Fix compilation warnings:
+    - apt-pkg/contrib/configuration.cc: wrong argument type;
+    - apt-pkg/deb/dpkgpm.cc: wrong signess;
+    - apt-pkg-acquire-item.cc: wrong signess and orderned initializers;
+    - methods/https.cc:
+      - type conversion;
+      - unused variable;
+      - changed SetupProxy() method to void;
+  * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+  * Fix pipeline handling on http.cc (closes: #413324)
+  * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+    <schepler@math.unipd.it> by the patch (closes: #359634)
+  * Fix example for Install-{Recommends,Suggests} options on
+    configure-index example file. Thanks to Peter Eisentraut
+    <peter_e@gmx.net> by the patch (closes: #432223)
+
+  [ Christian Perrier ]
+  * Basque translation update. Closes: ##423766
+  * Unfuzzy formerly complete translations
+  * French translation update
+  * Re-generate PO(T) files
+  * Spanish translation update
+  * Swedish translation update
+
+ -- Otavio Salvador <otavio@debian.org>  Tue, 24 Jul 2007 09:55:50 -0300
+
+apt (0.7.3) unstable; urgency=low
+
+  * fixed compile errors with g++ 4.3 (thanks to 
+    Daniel Burrows, closes: #429378)
+  * fixes in the auto-mark code (thanks to Daniel
+    Burrows)
+  * fix FTFBFS by changing build-depends to
+    libcurl4-gnutls-dev (closes: #428363)
+  * cmdline/apt-get.cc:
+    - fix InstallTask code when a pkgRecord ends 
+      with a single '\n' (thanks to Soren Hansen for reporting)
+  * merged from Christian Perrier:
+        * vi.po: completed to 532t, again. Closes: #429899
+        * gl.po: completed to 532t. Closes: #429506
+        * vi.po: completed to 532t. Closes: #428672
+        * Update all PO and the POT. Gives 514t14f4u for formerly
+          complete translations
+        * fr.po: completed to 532t
+        * ku.po, uk.po, LINGUAS: reintegrate those translations
+          which disappeared from the BZR repositories
+
+ -- Michael Vogt <mvo@debian.org>  Sun, 01 Jul 2007 12:31:29 +0200
+  
+apt (0.7.2ubuntu7) gutsy; urgency=low
+
+  * fix build-dependencies 
+  * fixes in the auto-mark code (thanks to Daniel
+    Burrows)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon,  9 Jul 2007 19:02:54 +0200
+
+apt (0.7.2ubuntu6) gutsy; urgency=low
+
+  [ Michael Vogt]
+  * cmdline/apt-get.cc:
+    - make the XS-Vcs-$foo warning more copy'n'paste
+      friendly (thanks to Matt Zimmerman)
+    - ignore the Vcs-Browser tag (Fixes LP: #121770)
+  * debian/apt.conf.autoremove:
+    - added "linux-ubuntu-modules" to APT::NeverAutoRemove
+
+  [ Sarah Hobbs ]
+  * Change metapackages to *metapackages in Install-Recommends-Section
+    and Never-MarkAuto-Section of debian/apt.conf.autoremove, so that
+    the Recommends of metapackages in universe and multiverse will get
+    installed.
+  * Also make this change in doc/examples/configure-index.
+  * Added a Build Dependancies of automake, docbook-xsl, xsltproc, xmlto,
+    docbook to fix FTBFS.
+  * Added in previous changelog entries, as those who uploaded did not
+    actually commit to Bzr.
+
+ -- Sarah Hobbs <hobbsee@ubuntu.com>  Mon, 09 Jul 2007 01:15:57 +1000
+
+apt (0.7.2ubuntu5) gutsy; urgency=low
+
+  * Rerun autoconf to fix the FTBFS.
+
+ -- Michael Bienia <geser@ubuntu.com>  Fri, 06 Jul 2007 19:17:33 +0200
+
+apt (0.7.2ubuntu4) gutsy; urgency=low
+
+  * Rebuild for the libcurl4 -> libcurl3 transition mess.
+
+ -- Steve Kowalik <stevenk@ubuntu.com>  Fri,  6 Jul 2007 12:44:05 +1000
+
+apt (0.7.2ubuntu3) gutsy; urgency=low
+
+  * cmdline/apt-get.cc:
+    - fix InstallTask code when a pkgRecord ends 
+      with a single '\n' (thanks to Soren Hansen for reporting)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 27 Jun 2007 13:33:38 +0200
+
+apt (0.7.2ubuntu2) gutsy; urgency=low
+
+  * fixed compile errors with g++ 4.3 (thanks to 
+    Daniel Burrows, closes: #429378)
+  * fix FTFBFS by changing build-depends to
+    libcurl4-gnutls-dev (closes: #428363)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 19 Jun 2007 13:47:03 +0200
+
+apt (0.7.2ubuntu1) gutsy; urgency=low
+
+  * apt-pkg/deb/dpkgpm.cc:
+    - apport integration added, this means that a apport
+      report is written on dpkg failures
+  * cmdline/apt-get.cc:
+    - merged http://people.ubuntu.com/~mvo/bzr/apt/xs-vcs-bzr/
+      this will warn when Vcs- headers are found on apt-get source
+      (Fixes LP:#115959)
+  * merged from debian/unstable, remaining changes:
+    - maintainer field changed
+    - merged the apt--mirror branch 
+      http://people.ubuntu.com/~mvo/bzr/apt/apt--mirror/
+    - apport reporting on package install/upgrade/remove failure
+    - support for "Originial-Maintainer" field
+    - merged apt--xs-vcs-bzr branch
+      (http://people.ubuntu.com/~mvo/bzr/apt/xs-vcs-bzr/)
+    - use ubuntu archive keyring by default
+    - debian/apt.conf.autoremove
+      + install recommands for section "metapackages"
+      + do not mark direct dependencies of "metapackages" as autoremoved
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 14 Jun 2007 10:38:36 +0200
+
+apt (0.7.2-0.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Build-depend on libcurl4-gnutls-dev instead of the obsolete
+    libcurl3-gnutls-dev.  Closes: #428363.
+
+ -- Steve Langasek <vorlon@debian.org>  Thu, 28 Jun 2007 18:46:53 -0700
+
+apt (0.7.2) unstable; urgency=low
+  
+  * merged the debian/experimental changes back
+    into the debian/sid branch
+  * merged from Christian Perrier:
+    * mr.po: New Marathi translation  Closes: #416806
+    * zh_CN.po: Updated by Eric Pareja  Closes: #416822
+    * tl.po: Updated by Eric Pareja   Closes: #416638
+    * gl.po: Updated by Jacobo Tarrio
+            Closes: #412828
+    * da.po: Updated by Claus Hindsgaul
+            Closes: #409483
+    * fr.po: Remove a non-breakable space for usability
+            issues. Closes: #408877
+    * ru.po: Updated Russian translation. Closes: #405476
+    * *.po: Unfuzzy after upstream typo corrections
+  * buildlib/archtable:
+    - added support for sh3/sh4 (closes: #424870)
+    - added support for m32r (closes: #394096)
+  * buildlib/systemtable:
+    - added support for lpia
+  * configure.in:
+    - check systemtable for architecture mapping too
+  * fix error in AutocleanInterval, closes: #319339
+    (thanks to Israel G. Lugo for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * fix FTBFS with gcc 4.3, closes: #417090
+    (thanks to Martin Michlmayr for the patch)
+  * add --dsc-only option, thanks to K. Richard Pixley
+  * Removed the more leftover #pragma interface/implementation
+    closes: #306937 (thanks to Andreas Henriksson for the patch)
+  
+ -- Michael Vogt <mvo@debian.org>  Wed, 06 Jun 2007 23:19:50 +0200
+
+apt (0.7.1) experimental; urgency=low
+
+  * ABI library name change because its build against
+    new glibc
+  * implement SourceVer() in pkgRecords 
+     (thanks to Daniel Burrows for the patch!)
+  * apt-pkg/algorithm.cc:
+    - use clog for all debugging
+    - only increase the score of installed applications if they 
+      are not obsolete 
+    - fix resolver bug on removal triggered by weak-dependencies 
+      with or-groups
+  * methods/http.cc:
+    - send apt version in User-Agent
+  * apt-pkg/deb/debrecords.cc:
+    - fix SHA1Hash() return value
+  * apt-pkg/cdrom.cc:
+    - only unmount if APT::CDROM::NoMount is false
+  * methods/cdrom.cc:  
+    - only umount if it was mounted by the method before
   * po/gl.po:
     - fix error in translation that causes trouble to lsb_release 
       (LP#79165)
   * apt-pkg/acquire-item.cc:
-    - if decompression of a index fails, delete the index (LP#68202)
+    - if decompression of a index fails, delete the index 
   * apt-pkg/acquire.{cc,h}:
     - deal better with duplicated sources.list entries (avoid
       double queuing of  URLs) - this fixes hangs in bzip/gzip
@@ -23,13 +332,16 @@ apt (0.6.46.4ubuntu11) UNRELEASED; urgency=low
              issues. Closes: #408877
     * ru.po: Updated Russian translation. Closes: #405476
     * *.po: Unfuzzy after upstream typo corrections
+    * vi.po: Updated to 515t. Closes: #426976
+    * eu.po: Updated to 515t. Closes: #423766
+    * pt.po: 515t. Closes: #423111
+    * fr.po: Updated by Christian Perrier
+    * Update all PO and the POT. Gives 513t2f for formerly
+      complete translations
   * apt-pkg/policy.cc:
     - allow multiple packages (thanks to David Foerster)
-  * apt-pkg/deb/dpkgpm.cc:
-    - apport integration added, this means that a apport
-      report is written on dpkg failures
 
- -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 17 Apr 2007 15:53:37 +0200
+ -- Michael Vogt <mvo@debian.org>  Wed,  2 May 2007 13:43:44 +0200
 
 apt (0.6.46.4ubuntu10) feisty; urgency=low
 
@@ -118,6 +430,23 @@ apt (0.6.46.4ubuntu4) feisty; urgency=low
 
  -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 18 Dec 2006 19:39:05 +0100
 
+apt (0.7.0) experimental; urgency=low
+
+  * Package that contains tall the new features
+  * Removed all #pragma interface/implementation
+  * Branch that contains tall the new features:
+  * translated package descriptions
+  * task install support
+  * automatic dependency removal (thanks to Daniel Burrows)
+  * merged support for the new dpkg "Breaks" field 
+    (thanks to Ian Jackson)
+  * handle network failures more gracefully on "update"
+  * support for unattended-upgrades (via unattended-upgrades
+    package)
+  * added apt-transport-https method
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 12 Jan 2007 20:48:07 +0100
+
 apt (0.6.46.4ubuntu3) feisty; urgency=low
 
   * apt-pkg/algorithm.cc:
@@ -214,40 +543,53 @@ apt (0.6.46.3) unstable; urgency=low
       messages 
 
   * Merged from Christian Perrier bzr branch:
-     - ca.po: Updated to 514t
-     - be.po: Updated to 514t
-     - it.po: Updated to 514t
-     - hu.po: Updated to 514t
-     - zh_TW.po: Updated to 514t
-     - ar.po: Updated to 293t221u.
-     - ru.po: Updated to 514t. Closes: #392466
-     - nb.po: Updated to 514t. Closes: #392466
-     - pt.po: Updated to 514t. Closes: #393199
-     - fr.po: One spelling error corrected: s/accèder/accéder
-     - km.po: Updated to 514t.
-     - ko.po: Updated to 514t.
-     - bg.po: Updated to 514t.
-     - de.po: Updated to 514t.
-     - en_GB.po: Updated to 514t.
-
- -- Michael Vogt <mvo@debian.org>  Thu, 2 Nov 2006 11:37:58 +0100 
+    - ca.po: Updated to 514t
+    - be.po: Updated to 514t
+    - it.po: Updated to 514t
+    - hu.po: Updated to 514t
+    - zh_TW.po: Updated to 514t
+    - ar.po: Updated to 293t221u.
+    - ru.po: Updated to 514t. Closes: #392466
+    - nb.po: Updated to 514t. Closes: #392466
+    - pt.po: Updated to 514t. Closes: #393199
+    - fr.po: One spelling error corrected: s/accèder/accéder
+    - km.po: Updated to 514t.
+    - ko.po: Updated to 514t.
+    - bg.po: Updated to 514t.
+    - de.po: Updated to 514t.
+    - en_GB.po: Updated to 514t.
+
+ -- Michael Vogt <mvo@debian.org>  Thu,  2 Nov 2006 11:37:58 +0100
 
 apt (0.6.46.2) unstable; urgency=low
 
+  * debian/control:
+    - depend on debian-archive-keyring to offer clean upgrade path 
+      (closes: #386800)
   * Merged from Christian Perrier bzr branch:
     - es.po: Updated to 514t. Closes: #391661
     - da.po: Updated to 514t. Closes: #391424
     - cs.po: Updated. Closes: #391064
     - es.po: Updated to 514t. Closes: #391661
     - da.po: Updated to 514t. Closes: #391424
-  
+
  -- Michael Vogt <mvo@debian.org>  Wed, 11 Oct 2006 09:03:15 +0200
 
 apt (0.6.46.1) unstable; urgency=low
 
+  * merged "install-recommends" branch (ABI break): 
+    - new "--install-recommends"
+    - install new recommends on "upgrade" if --install-recommends is 
+      given
+    - new "--fix-policy" option to install all packages with unmet
+      important dependencies (usefull with --install-recommends to
+      see what not-installed recommends are on the system)
+    - fix of recommended packages display (only show CandidateVersion
+      fix or-group handling)
+  * merged "install-task" branch (use with "apt-get install taskname^")
   * methods/gzip.cc:
     - deal with empty files 
-  * Applied patch from Daniel Schepler to make apt bin-NMU able.  
+  * Applied patch from Daniel Schepler to make apt bin-NMU able.
     (closes: bug#359634)
   * rebuild against current g++ because of:
     http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29289
@@ -538,22 +880,32 @@ apt (0.6.44.1-0.1) unstable; urgency=low
 
 apt (0.6.44.1) unstable; urgency=low
 
+  * apt-pkg/acquire-item.cc:
+    - fix reversed logic of the "Acquire::PDiffs" option
   * merged from 
     http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
     - po/LINGUAS: added "bg" Closes: #360262
     - po/gl.po: Galician translation update. Closes: #366849
     - po/hu.po: Hungarian translation update. Closes: #365448
     - po/cs.po: Czech translation updated. Closes: #367244
+  * apt-pkg/contrib/sha256.cc:
+    - applied patch to fix unaligned access problem. Closes: #367417
+      (thanks to David Mosberger)
 
  -- Michael Vogt <mvo@debian.org>  Tue, 16 May 2006 21:51:16 +0200
 
 apt (0.6.44) unstable; urgency=low
 
   * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+  * apt-pkg/contrib/sha256.{cc,h},hashes.{cc,h}: support for sha256 
+    (thanks to Anthony Towns)
+  * ftparchive/cachedb.{cc,h},writer.{cc,h}: optimizations 
+    (thanks to Anthony Towns)
+  * apt pdiff support from experimental merged
+  * apt-pkg/deb/dpkgpm.cc: wording fixes (thanks to Matt Zimmerman)
   * apt-pkg/deb/dpkgpm.cc: 
     - wording fixes (thanks to Matt Zimmerman)
-    - fix error in dpkg interaction (closes: #364513, 
-      thanks to Martin Dickopp)
+    - fix error in dpkg interaction (closes: #364513, thanks to Martin Dickopp)
   * apt-pkg/tagfile.{cc,h}:
     - use MMap to read the entries (thanks to Zephaniah E. Hull for the
       patch) Closes: #350025
@@ -2915,4 +3267,3 @@ apt (0.0.1) unstable; urgency=low
   * Initial Release.
 
  -- Scott K. Ellis <scott@debian.org>  Tue, 31 Mar 1998 12:49:28 -0500
-