* merged latest fixes from debian-sid
[ntk/apt.git] / debian / apt.postinst
index df04330..4d87c4e 100644 (file)
@@ -15,11 +15,12 @@ set -e
 
 case "$1" in
     configure)
-
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
-        fi
-
+       SECRING='/etc/apt/secring.gpg'
+       # test if secring is an empty normal file
+       if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
+       fi
+       apt-key update
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)