Add support to debian/rules to update config.sub and co...
[ntk/apt.git] / debian / changelog
index 60fa2f7..d03bce7 100644 (file)
-apt (0.3.16.1) unstable; urgency=low
+apt (0.5.5) unstable; urgency=low
+
+  * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
+  * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
+  * "apt-get --arch-only build-dep" to install only architecture-
+    dependent build dependencies. Bump minor shared lib number to reflect
+    small change in BuildDepend API.
+  * APT::Build-Essential configuration option (defaults to "build-essential")
+    so that "apt-get build-dep" will ensure build essential packages are
+    installed prior to installing other build-dependencies. Closes: #148879
+  * LD_LIBRARY_PATH thing. Closes: #109430, #147529
+  * /usr/doc reference in postinst. Closes: #126189
+  * Doc updates. Closes: #120689
+  * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
+          #131062, #136749
+  * Print special message for EAI_AGAIN. Closes: #131397
+  * libapt-pkg-dev needs to bring in the apt-inst library if linking
+    is to work. Closes: #133943
+  * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
+         #109591, #105920, #103678, #139752, #138186, #138054, #138050,
+        #139994, #142955, #151654, #151834, #147611, #154268
+  * Fix possibility for tag file parsing to fail in some unlikely situations.
+    Closes: #139328
+  * Use std C++ names for some header files. Closes: #128741
+  * Do not check for free space if --no-download. Closes: #117856
+  * Actually implement or group handling for 'upgrade'. Closes: #133950
+  * "Internal Error, Couldn't configure pre-depend" is not actually an
+    internal error, it is a packaging error and now it says so, and
+    pinpoints the problem dependency. Closes: #155621
+  * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
+  * Use usr/share/doc for dhelp. Closes: #115701
+  * --print-uris works with 'update'. Closes: #57070
+  * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
+    command line.
+  * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
+    #142298
+  * Allow an uninstalled package to be marked for removal on an install
+    line (meaning not to automatically install it), also fix some dodgy
+    handling of protected packages. Closes: #92287, #116011
+  * Fix errant prefix matching in version selection. Closes: #105968
+  * Ensure that all files needed to run APT as a user are readable and
+    ignore roots umask for these files. Closes: #108801
+  * Support larger config spaces. Closes: #111914
+  * 'apt-get update' no longer does 'Building Dependency Tree'.
+  * When matching regexs allways print a message. Change regex activation
+    charset. Closes: #147817
+  * Don't die if lines in sources.list are too long. Closes: #146846
+  * Show file name on apt-extracttemplate error messges. Closes: #151835
+  * i18n gettext stuff, based on work from Michael Piefel
+  * Some highly unlikely memory faults. Closes: #155842
+  * C++ stuff for G++3.2. Closes: #162617
+  * apt-config dumps sends to stdout not stderr now.  Closes: #146294
+  * Fix segfault in FindAny when /i is used, and there is no default.
+    Closes: #165891
+  * Add s390x to archtable.  Closese: #160992.
+  * Update config.sub/config.guess in cvs, and add support to debian/rules
+    to update them from /usr/share/misc if they exist.  Closes: #155014
+
+ -- Jason Gunthorpe <jgg@debian.org>  Sun, 15 Sep 2002 17:16:59 -0600
+
+apt (0.5.4) unstable; urgency=low
+
+  * M68k config.guess patch. Closes: #88913
+  * Bi-yearly test on OpenBSD and Solaris
+  * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
+          #97520, #102867, #101071, #102421, #101565, #98272, #106914,
+          #105606, #105377
+  * Various cosmetic code updates. Closes: #89066, #89066, #89152
+  * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
+    update).
+  * More patches from Alfredo for Vendors and more SHA-1 stuff
+  * Fix for AJ's 'desire to remove perl-5.005' and possibly other
+    similar situations. Closes: #56708, #59432
+  * no_proxy and ftp. Closes: #89671
+  * Philippe Batailler's man page patches.
+  * Fix for display bug. Closes: #92033, #93652, #98468
+  * Use more than 16bits for the dep ID. Some people ran out..
+    Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
+            #106911, #107395, #108968
+  * Reordered some things to make dante and FTP happier. Closes: #92757
+  * James R. Van Zandt's guide.sgml updates. Closes: #90027
+  * apt-ftparchive copes with no uncompressed package files + contents.
+  * French man pages from philippe batailler - well sort of. They 
+    don't build yet..
+  * run-parts. Closes: #94286
+  * 'apt-cache policy' preferences debug tool.
+  * Whatever. Closes: #89762
+  * libstdc++ and HURD. Closes: #92025
+  * More apt-utils verbage. Closes: #86954
+  * Fliped comparision operator. Closes: #94618
+  * Used the right copyright file. Closes: #65691
+  * Randolph's G++3 patches. 
+  * Fixed no_proxy tokanizing. Closes: #100046
+  * Strip Config-Version when copying status to available. Closes: #97520
+  * Segfault with missing source files. Closes: #100325
+  * EINTR check. Closes: #102293
+  * Various changes to the locking metholodgy for --print-uris. 
+    Closes: #100590
+  * Lame LD_LIBRARY_PATH thing. Closes: #98928
+  * apt-cache search searchs provide names too now. Closes: #98695
+  * Checksum and long lines problem. Closes: #106591
+  * .aptignr and empty files are just a warning. Closes: #97364  
+  
+ -- Jason Gunthorpe <jgg@debian.org>  Sat, 18 Aug 2001 17:21:59 -0500
+
+apt (0.5.3) unstable; urgency=low
+
+  * JoeyH's dpkg::preconfig not working. Closes: #88675
+  * Fixed apt override disparity
+  * Alfredo's SHA-1 and related patches
+  
+ -- Jason Gunthorpe <jgg@debian.org>  Sun,  4 Mar 2001 15:39:43 -0700
+
+apt (0.5.2) unstable; urgency=low
+
+  * Fixed mention of /usr/doc in the long description
+  * JoeyH's downgrade bug -- don't use 0.5.1
+  * Doc bug. Closes: #88538
+  * Fault in building release strings. Closes: #88533
+  
+ -- Jason Gunthorpe <jgg@debian.org>  Sun,  4 Mar 2001 15:39:43 -0700
+
+apt (0.5.1) unstable; urgency=low
+
+  * Fixed #82894 again, or should be and.
+  * Process the option string right. Closes: #86921
+  * Don't eat the last command for pipes. Closes: #86923
+  * Ignore .* for configuration directory processing. Closes: #86923
+  * Alfredo's no_proxy patch
+  * Documentation fixes. Closes: #87091
+  * JoeyH's double slash bug. Closes: #87266
+  * Unintitialized buffer and apt-ftparchive contents generation. 
+     Closes: #87612
+  * Build-deps on virtual packages. Closes: #87639
+  * Fixes glibc/libstdc++ symbol dependencies by including glibc and
+    libstdc++ version info in the library soname and in the package
+    provides. Closes: #87426
+  * Updated soname version to 0.3.2
+  * apt-extracttemplates moved from debconf into apt-utils
+  * s390 archtable entry. Closes: #88232
+  * Dan's segfault
+  * Some instances where the status file can source a package in a
+    non-sensical way. Closes: #87390
+  * Work better if there are duplicate sources.list entries.
+  * Fixed the resetting of Dir with "dir {};". Closes: #87323
+  
+ -- Randolph Chung <tausq@debian.org>  Sat, 3 Mar 2001 15:37:38 -0700
+
+apt (0.5.0) unstable; urgency=low
+
+  * Fixed an obscure bug with missing final double new lines in 
+    package files
+  * Changed the apt-cdrom index copy routine to use the new section
+    rewriter
+  * Added a package file sorter, apt-sortpkgs
+  * Parse obsolete Optional dependencies.
+  * Added Ben's rsh method. Closes: #57794
+  * Added IPv6 FTP support and better DNS rotation support.
+  * Include the server IP in error messages when using a DNS rotation.
+    Closes: #64895
+  * Made most of the byte counters into doubles to prevent 32bit overflow.
+    Closes: #65349
+  * HTTP Authorization. Closes: #61158
+  * Ability to parse and return source index build depends from Randolph.
+  * new 'apt-get build-dep' command from Randolph. Closes: #63982
+  * Added apt-ftparchive the all dancing all singing FTP archive
+    maintinance program
+  * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
+    in apt-get. 
+  * Removed useless internal cruft including the xstatus file.
+  * Fixed config parser bugs. Closes: #67848, #71108
+  * Brain Damanged apt-get config options changed, does not change the command
+    line interface, except to allow --enable-* to undo a configuration
+    option:
+      No-Remove -> Remove
+      No-Download -> Download
+      No-Upgrade -> Upgrade
+  * Made this fix configable (DSelect::CheckDir) and default to disabled:
+     * No remove prompt if the archives dir has not changed. Closes: #55709
+    Because it is stupid in the case where no files were downloaded due to
+    a resumed-aborted install, or a full cache! Closes: #65952
+  * Obscure divide by zero problem. Closes: #64394
+  * Update sizetable for mips. Closes: #62288
+  * Fixed a bug with passive FTP connections
+  * Has sizetable entry for sparc64. Closes: #64869
+  * Escape special characters in the ::Label section of the cdroms.lst
+  * Created apt-utils and python-apt packages
+  * Due to the new policy engine, the available file may contain entries
+    from the status file. These are generated if the package is not obsolete
+    but the policy engine prohibits using the version from the package files. 
+    They can be identified by the lack of a Filename field.
+  * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
+    #36223, #33468, #22551
+  * Fixed deb-src line for non-us. Closes: #71501, #71601
+  * Fixes for G++ 2.96, s/friend/friend class/
+  * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
+  * Confirmed fix for missing new line problem. Closes: #69386
+  * Fixed up dhelp files. Closes: #71312
+  * Added some notes about dselect and offline usage. Closes: #66473, #38316
+  * Lock files on read only file systems are ignored w/ warning. 
+    Closes: #61701
+  * apt-get update foo now gives an error! Closes: #42891
+  * Added test for shlibs on hurd. Closes: #71499
+  * Clarified apt-cache document. Closes: #71934
+  * DocBook SGML man pages and some improvements in the text.. 
+  * sigwinch thing. Closes: #72382
+  * Caching can be turned off by setting the cache file names blank.
+  * Ignores arches it does not know about when autocleaning. Closes: #72862
+  * New function in apt-config to return dirs, files, bools and integers.
+  * Fixed an odd litle bug in MarkInstall and fixed it up to handle 
+    complex cases involving OR groups and provides.
+    68754 describes confusing messages which are the result of this..
+    Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
+  * Speeling mistake and return code for the 'wicked' resolver error
+    Closes: #72621, #75226, #77464
+  * Solved unable to upgrade libc6 from potato to woody due to 3 package
+    libc6 dependency loop problem.
+  * Leading sources.list spaces. Closes: #76010
+  * Removed a possible infinite loop while processing installations.
+  * Man page updates. Closes: #75411, #75560, #64292, #78469
+  * ReduceSourceList bug. Closes: #76027
+  * --only-source option. Closes: #76320
+  * Typos. Closes: #77812, #77999
+  * Different status messages. Closes: #76652, #78353
+  * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
+  * OS detection an support for the new pseduo standard of os-arch for the
+    Architecture string. Also uses regexing.. Closes: #39227, #72349
+  * Various i18n stuff. Note that this still needs some i18n wizard
+    to do the last gettextization right. Closes: #62386
+  * Fixed a problem with some odd http servers/proxies that did not return
+    the content size in the header. Closes: #79878, #44379
+  * Little acquire bugs. Closes: #77029, #55820
+  * _POSIX_THREADS may not be defined to anything, just defined..
+    Closes: #78996
+  * Spelling of Ignore-Hold correctly. Closes: #78042
+  * Unlock the dpkg db if in download only mode. Closes: #84851
+  * Brendan O'Dea's dselect admindir stuff. Closes: #62811
+  * Patch from BenC. Closes: #80810
+  * Single output of some names in lists. Closes: #80498, #43286  
+  * Nice message for people who can't read syserror output. Closes: #84734
+  * OR search function. Closes: #82894
+  * User's guide updates. Closes: #82469  
+  * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
+  * Various CD bugs, again thanks to Greenbush 
+    Closes: #80946, #76547, #71810, #70049, #69482
+  * Using potato debhelper. Closes: #57977
+  * I cannot self-terminate. Closes: #74928
+  
+ -- Jason Gunthorpe <jgg@debian.org>  Wed, 21 Feb 2001 00:39:15 -0500
+apt (0.3.19) frozen unstable; urgency=low
+  
+  * Updates to apt-cdrom to support integrated non-us nicely, thanks to
+    Paul Wade.
+  * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
+  * Fixed hardcoded path. Closes: #59743
+  * Fixed Jay's relative path bug
+  * Allowed source only CDs. Closes: #58952
+  * Space check is supressed if --print-uris is given. Closes: #58965
+  * Clarified the documenation examples for non-us. Closes: #58646
+  * Typo in the package description. Closes: #60230
+  * Man Page typo. Closes: #60347 
+  * Typo in Algorithms.cc. Closes: #63577
+  * Evil dotty function in apt-cache for generating dependency graphs
+    with the as-yet-unpackaged GraphVis.
+  * Appears to have been fixed in Janurary.. Closes: #57981
+  * New config.guess/sub for the new archs. Closes: #60874
+  * Fixed error reporting for certain kinds of resolution failures. 
+    Closes: #61327
+  * Made autoclean respect 'q' settings. Closes: #63023
+  * Fixed up the example sources.list. Closes: #63676
+  * Added DPkg::FlushSTDIN to control the flushing of stdin before
+    forking dpkg. Closes: #63991
+    
+ -- Ben Gertzfield <che@debian.org>  Fri, 12 May 2000 21:10:54 -0700
+
+apt (0.3.18) frozen unstable; urgency=low
+  
+  * Changes in the postinst script. Closes: #56855, #57237
+  * Fixed bashism. Closes: #57216, #57335
+  * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
+     
+ -- Ben Gertzfield <che@debian.org>  Sun, 13 Feb 2000 01:52:31 -0800
+
+apt (0.3.17) unstable; urgency=low
 
   * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
   * Fixed the configuration parser to not blow up if ; is in the config 
     string
   * Applied visual patch to dselect install script . Closes #55214
   * Included the configure-index example
+  * Minimal CD swaps
+  * Library soname has increased
+  * Fixed default sources.list to have correct URLs for potato when it 
+    becomes stable
+  * Added a message about erasing sources.list to dselect setup script
+    Closes: #55755
+  * No remove prompt if the archives dir has not changed. Closes: #55709
+  * Fixed inclusion of 2nd sample config file. Closes: #55374
+  * Made file mtimes of 0 not confuse the methods If-Modifed-Since check. 
+    Closes: #55991
   
- -- Ben Gertzfield <che@debian.org>  Fri, 14 Jan 2000 08:04:15 -0800
+ -- Ben Gertzfield <che@debian.org>  Mon, 31 Jan 2000 12:12:40 -0800
  
 apt (0.3.16) unstable; urgency=low
  
@@ -455,7 +749,3 @@ apt (0.0.1) unstable; urgency=low
 
  -- Scott K. Ellis <scott@debian.org>  Tue, 31 Mar 1998 12:49:28 -0500
 
-Local variables:
-mode: debian-changelog
-add-log-mailing-address: "che@debian.org"
-End: