moved to git, updated gbp.conf to match the bzr version
[ntk/apt.git] / debian / apt.postinst
index cc0d8b1..bd814e1 100644 (file)
@@ -15,7 +15,19 @@ set -e
 
 case "$1" in
     configure)
+       SECRING='/etc/apt/secring.gpg'
+       # test if secring is an empty normal file
+       if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
+       fi
        apt-key update
+
+        # ensure tighter permissons on the logs, see LP: #975199
+        if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
+            # ensure permissions are right
+            chmod -f 0640 /var/log/apt/term.log* || true
+        fi
+
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)