* apt-pkg/acquire-item.cc:
[ntk/apt.git] / debian / changelog
index 051bfc5..22af470 100644 (file)
@@ -1,3 +1,159 @@
+apt (0.8.14.2) UNRELEASED; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/depcache.cc:
+    - Really release action groups only once (Closes: #622744)
+
+  [ David Kalnischkies ]
+  * fix a bunch of cppcheck warnings/errors based on a patch by
+    Niels Thykier, thanks! (Closes: #622805)
+  * apt-pkg/depcache.cc:
+    - really include 'rc' packages in the delete count by fixing a
+      typo which exists since 1999 in the sourceā€¦ (LP: #761175)
+  * apt-pkg/acquire-method.cc:
+    - write directly to stdout instead of creating the message in
+      memory first before writing to avoid hitting limits
+  * apt-pkg/orderlist.cc:
+    - let VisitRProvides report if the calls were successful
+  * apt-pkg/deb/dpkgpm.cc:
+    - replace obsolete usleep with nanosleep
+  * debian/apt{,-utils}.symbols:
+    - update both experimental symbol-files to reflect 0.8.14 state
+  * debian/rules:
+    - remove unused embedded jquery by doxygen from libapt-pkg-doc
+  * cmdline/apt-mark.cc:
+    - reimplement apt-mark in c++
+    - provide a 'showmanual' command (Closes: #582791)
+    - provide a 'dpkg --set-selections' wrapper to set/release holds
+  * cmdline/apt-get.cc:
+    - deprecate mostly undocumented 'markauto' in favor of 'apt-mark'
+  * cmdline/apt-cache.cc:
+    - deprecate mostly undocumented 'showauto' in favor of 'apt-mark'
+  * apt-pkg/pkgcache.cc:
+    - really ignore :arch in FindPkg() in non-multiarch environment
+  * doc/po/de.po:
+    - undo the translation of the command 'dump' in manpage of apt-config
+      as report by Burghard Grossmann on debian-l10n-german, thanks!
+  * apt-pkg/deb/debmetaindex.cc:
+    - do not download TranslationIndex if no Translation-* will be
+      downloaded later on anyway (Closes: #624218)
+  * test/versions.lst:
+    - disable obscure version number tests with versions dpkg doesn't
+      allow any more as they don't start with a number
+  * apt-pkg/acquire-worker.cc:
+    - print filename in the unmatching size warning (Closes: #623137)
+  * apt-pkg/acquire-item.cc:
+    - apply fix for poorly worded 'locate file' error message from
+      Ben Finney, thanks! (Closes: #623171)
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Tue, 26 Apr 2011 22:41:33 +0200
+
+apt (0.8.14.1) unstable; urgency=low
+
+  * apt-pkg/acquire-item.cc:
+    - Only try to rename existing Release files (Closes: #622912)
+
+ -- Julian Andres Klode <jak@debian.org>  Sat, 16 Apr 2011 14:36:10 +0200
+
+apt (0.8.14) unstable; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/indexcopy.cc:
+    - Use RealFileExists() instead of FileExists(), allows amongst other
+      things a directory named Sources to exist on a CD-ROM (LP: #750694).
+  * apt-pkg/acquire-item.cc:
+    - Use Release files even if they cannot be verified (LP: #704595)
+  * cmdline/apt-get.cc:
+    - Do not install recommends for build-dep (Closes: #454479) (LP: #245273)
+  * apt-pkg/deb/deblistparser.cc:
+    - Handle no space before "[" in build-dependencies (LP: #72344)
+  * apt-pkg/policy.cc:
+    - Allow pinning by glob() expressions, and regular expressions
+      surrounded by slashes (the "/" character) (LP: #399474)
+      (Closes: #121132)
+  * debian/control:
+    - Set Standards-Version to 3.9.2
+  
+  [ Michael Vogt ]
+  * mirror method:
+    - do not crash if the mirror file fails to download
+  * apt-pkg/aptconfiguration.cc:
+    - fix comparing for a empty string
+  * debian/apt.cron.daily:
+    - run unattended-upgrades even if there was a error during
+      the apt-get update (LP: #676295)
+
+  [ David Kalnischkies ]
+  * apt-pkg/pkgcache.cc:
+    - use the native Architecture stored in the cache header instead of
+      loading it from configuration as suggested by Julian Andres Klode
+
+ -- Julian Andres Klode <jak@debian.org>  Fri, 15 Apr 2011 14:28:15 +0200
+
+apt (0.8.13.2) unstable; urgency=low
+
+  [ David Kalnischkies ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - skip --configure if all packages disappeared
+  * apt-pkg/vendor.cc, apt-pkg/vendorlist.cc:
+    - mark them as deprecated as they are unused
+  * apt-pkg/deb/deblistparser.h:
+    - enable StripMultiArch by default for ParseDepends
+  * debian/apt.conf.autoremove:
+    - adapt to new gnumach kernel package naming (Closes: #619337)
+  * doc/apt_preferences.5.xml:
+    - correct typo spotted by Charles Plessy (Closes: #619088)
+    - document ButAutomaticUpgrades together with NotAutomatic
+      as suggested by Charles Plessy (Closes: #619083)
+  * apt-pkg/depcache.cc:
+    - remove pseudo handling leftover from SetReInstall
+    - do not change protected packages in autoinstall (Closes: #618848)
+  * apt-pkg/pkgcachegen.cc:
+    - make "all"->"native" an implementation detail of NewPackage
+      rather than rewrite it in higher methods
+  * apt-pkg/cacheiterator.h:
+    - return "all" instead of native architecture without breaking the abi
+      (too much) by extending enum instead of using bitflags (LP: #733741)
+  * apt-pkg/aptconfiguration.cc:
+    - use dpkg --print-foreign-architectures to get multiarch configuration
+      if non is specified with APT::Architectures (Closes: #612958)
+  * cmdline/apt-get.cc:
+    - do not show simulation notice for non-root commands (Closes: #619072)
+    - be able to disable resolver with APT::Get::CallResolver and disable
+      auto installation with APT::Get::AutoSolving
+  * apt-pkg/deb/deblistparser.cc:
+    - create foo:any provides for all architectures for an allowed package
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 05 Apr 2011 09:40:28 +0200
+
+apt (0.8.13.1) unstable; urgency=low
+
+  * apt-pkg/acquire-item.cc: Use stat buffer if stat was
+    successful, not if it failed (Closes: #620546)
+
+ -- Julian Andres Klode <jak@debian.org>  Sat, 02 Apr 2011 20:55:35 +0200
+
+apt (0.8.13) unstable; urgency=low
+
+  [ Thorsten Spindler ]
+  * methods/rsh.cc
+    - fix rsh/ssh option parsing (LP: #678080), thanks to
+      Ville Mattila 
+  
+  [ Michael Vogt ]
+  * apt-pkg/acquire-item.cc:
+    - mark pkgAcqIndexTrans as Index-File to avoid asking the
+      user to insert the CD on each apt-get update
+  * po/sl.po:
+    - updated, thanks to Andrej Znidarsic
+  * mirror method:
+    - when downloading data, show the mirror being used
+    - randomize mirror list after download in a host specific way
+      to ensure that the load is evenly spreaded accross the mirrors
+    - fix some missing "Fail-Ignore"
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 16 Mar 2011 08:04:42 +0100
+
 apt (0.8.12) unstable; urgency=low
 
   [ Michael Vogt ]