build: Convert from DebianDoc SGML to DocBook XML
[ntk/apt.git] / debian / rules
index 83e2388..c7b5aa3 100755 (executable)
@@ -3,6 +3,9 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
+
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -66,8 +69,8 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 # do not fail as we are just experimenting with symbol files for now
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
-build: build/build-stamp
-build-debiandoc: build/build-debiandoc-stamp
+build-binary: build/build-binary-stamp
+build-docbook: build/build-docbook-stamp
 build-manpages: build/build-manpages-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
@@ -76,15 +79,15 @@ build-manpages: build/build-manpages-stamp
 build/environment.mak: build/configure-stamp
        @true
 
-configure: configure.in
-build/configure-stamp: configure
+configure: configure.ac
+build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
        cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
        touch $@
 
-build/build-stamp: build/configure-stamp
+build/build-binary-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
        # compat symlink for the locale split
@@ -98,9 +101,9 @@ else
 endif
        touch $@
 
-build/build-debiandoc-stamp: build/configure-stamp
+build/build-docbook-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) debiandoc
+       $(MAKE) docbook
        touch $@
 
 build/build-manpages-stamp: build/configure-stamp
@@ -110,18 +113,20 @@ build/build-manpages-stamp: build/configure-stamp
 
 clean:
        dh_testdir
+       dh_clean
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
        rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
-             debian/libapt-pkg-dev.install
+             debian/libapt-pkg-dev.install debian/apt.install
+       test ! -L buildlib/config.guess || rm -f buildlib/config.guess
+       test ! -L buildlib/config.sub || rm -f buildlib/config.sub
 
 debian/%.install: debian/%.install.in
        sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
-binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build-debiandoc
+libapt-pkg-doc: build-docbook
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -129,6 +134,7 @@ libapt-pkg-doc: build-debiandoc
 #
 # libapt-pkg-doc install
 #
+       rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
        dh_installdocs -p$@ $(BLD)/docs/design* \
                            $(BLD)/docs/dpkg-tech* \
                            $(BLD)/docs/files* \
@@ -140,14 +146,14 @@ libapt-pkg-doc: build-debiandoc
 
        dh_installchangelogs -p$@
        dh_strip -p$@
-       dh_compress -p$@
+       dh_compress -p$@ -X.xhtml
        dh_fixperms -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-doc: build-debiandoc
+apt-doc: build-docbook
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -171,9 +177,8 @@ apt-doc: build-debiandoc
 
 # Build architecture-dependent files here.
 
-binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-manpages
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build-binary build-manpages debian/apt.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -182,6 +187,10 @@ apt: build build-manpages
 # apt install
 #
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       # install vendor specific apt confs
+       find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
@@ -200,10 +209,13 @@ apt: build build-manpages
        #mv debian/$@/usr/bin/apt-report-mirror-failure \
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
+       # move the apt-helper in place
+       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper 
+
        dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -211,13 +223,14 @@ apt: build build-manpages
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
        dh_shlibdeps -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build debian/libapt-pkg-dev.install
+libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -237,7 +250,7 @@ libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_builddeb -p$@
 
 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build build-manpages
+apt-utils: build-binary build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -253,7 +266,7 @@ apt-utils: build build-manpages
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -266,7 +279,7 @@ apt-utils: build build-manpages
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
+$(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -285,7 +298,7 @@ $(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
+$(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -304,7 +317,7 @@ $(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build libapt-pkg-dev
+apt-transport-https: build-binary libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -327,13 +340,18 @@ apt-transport-https: build libapt-pkg-dev
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+buildlib/config.guess buildlib/config.sub:
+       $(MAKE) "$@"
+
 configure:
        $(MAKE) configure
 
-really-clean: clean
-       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
-       find -name ChangeLog | xargs rm -f
-       rm -f l33ch-stamp
-
+# translate targets to targets required by debian-policy
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
+binary-indep: apt-doc libapt-pkg-doc
 binary: binary-indep binary-arch
+build-arch: build-binary
+build-indep: build-manpages build-docbook
+build: build-indep build-arch
+
 .PHONY: build clean binary-indep binary-arch binary