- support task removal too: apt-get remove taskname^
[ntk/apt.git] / debian / changelog
index 7893f25..131cdbe 100644 (file)
@@ -1,5 +1,106 @@
-apt (0.6.46.5) UNRELEASED; urgency=low
+apt (0.7.4) UNRELEASED; urgency=low
 
+  [Michael Vogt]
+  * cmdline/apt-get.cc:
+    - fix in the task-install code regexp (thanks to Adam Conrad and
+      Colin Watson)
+    - support task removal too: apt-get remove taskname^
+      (thanks to Matt Zimmerman reporting this problem)
+
+  [Otavio Salvador]
+  * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+  * Fix compilation warnings:
+    - apt-pkg/contrib/configuration.cc: wrong argument type;
+    - apt-pkg/deb/dpkgpm.cc: wrong signess;
+    - apt-pkg-acquire-item.cc: wrong signess and orderned initializers;
+    - methods/https.cc:
+      - type conversion;
+      - unused variable;
+      - changed SetupProxy() method to void;
+  * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+  * Fix pipeline handling on http.cc (closes: #413324)
+  * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+    <schepler@math.unipd.it> by the patch (closes: #359634)
+  * Fix example for Install-{Recommends,Suggests} options on
+    configure-index example file. Thanks to Peter Eisentraut
+    <peter_e@gmx.net> by the patch (closes: #432223)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 11 Jul 2007 23:20:15 +0100
+
+apt (0.7.3) unstable; urgency=low
+
+  * fixed compile errors with g++ 4.3 (thanks to 
+    Daniel Burrows, closes: #429378)
+  * fixes in the auto-mark code (thanks to Daniel
+    Burrows)
+  * fix FTFBFS by changing build-depends to
+    libcurl4-gnutls-dev (closes: #428363)
+  * cmdline/apt-get.cc:
+    - fix InstallTask code when a pkgRecord ends 
+      with a single '\n' (thanks to Soren Hansen for reporting)
+  * merged from Christian Perrier:
+       * vi.po: completed to 532t, again. Closes: #429899
+       * gl.po: completed to 532t. Closes: #429506
+       * vi.po: completed to 532t. Closes: #428672
+        * Update all PO and the POT. Gives 514t14f4u for formerly
+          complete translations
+        * fr.po: completed to 532t
+        * ku.po, uk.po, LINGUAS: reintegrate those translations
+          which disappeared from the BZR repositories
+
+ -- Michael Vogt <mvo@debian.org>  Sun, 01 Jul 2007 12:31:29 +0200
+
+apt (0.7.2-0.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Build-depend on libcurl4-gnutls-dev instead of the obsolete
+    libcurl3-gnutls-dev.  Closes: #428363.
+
+ -- Steve Langasek <vorlon@debian.org>  Thu, 28 Jun 2007 18:46:53 -0700
+
+apt (0.7.2) unstable; urgency=low
+  
+  * merged the debian/experimental changes back
+    into the debian/sid branch
+  * merged from Christian Perrier:
+    * mr.po: New Marathi translation  Closes: #416806
+    * zh_CN.po: Updated by Eric Pareja  Closes: #416822
+    * tl.po: Updated by Eric Pareja   Closes: #416638
+    * gl.po: Updated by Jacobo Tarrio
+            Closes: #412828
+    * da.po: Updated by Claus Hindsgaul
+            Closes: #409483
+    * fr.po: Remove a non-breakable space for usability
+            issues. Closes: #408877
+    * ru.po: Updated Russian translation. Closes: #405476
+    * *.po: Unfuzzy after upstream typo corrections
+  * buildlib/archtable:
+    - added support for sh3/sh4 (closes: #424870)
+    - added support for m32r (closes: #394096)
+  * buildlib/systemtable:
+    - added support for lpia
+  * configure.in:
+    - check systemtable for architecture mapping too
+  * fix error in AutocleanInterval, closes: #319339
+    (thanks to Israel G. Lugo for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * fix FTBFS with gcc 4.3, closes: #417090
+    (thanks to Martin Michlmayr for the patch)
+  * add --dsc-only option, thanks to K. Richard Pixley
+  * Removed the more leftover #pragma interface/implementation
+    closes: #306937 (thanks to Andreas Henriksson for the patch)
+  
+ -- Michael Vogt <mvo@debian.org>  Wed, 06 Jun 2007 23:19:50 +0200
+
+apt (0.7.1) experimental; urgency=low
+
+  * ABI library name change because its build against
+    new glibc
+  * implement SourceVer() in pkgRecords 
+     (thanks to Daniel Burrows for the patch!)
   * apt-pkg/algorithm.cc:
     - use clog for all debugging
     - only increase the score of installed applications if they 
@@ -10,8 +111,64 @@ apt (0.6.46.5) UNRELEASED; urgency=low
     - send apt version in User-Agent
   * apt-pkg/deb/debrecords.cc:
     - fix SHA1Hash() return value
+  * apt-pkg/cdrom.cc:
+    - only unmount if APT::CDROM::NoMount is false
+  * methods/cdrom.cc:  
+    - only umount if it was mounted by the method before
+  * po/gl.po:
+    - fix error translation that causes trouble to lsb_release
+  * apt-pkg/acquire-item.cc:
+    - if decompression of a index fails, delete the index 
+  * apt-pkg/acquire.{cc,h}:
+    - deal better with duplicated sources.list entries (avoid
+      double queuing of  URLs) - this fixes hangs in bzip/gzip
+  * merged from Christian Perrier:
+    * mr.po: New Marathi translation  Closes: #416806
+    * zh_CN.po: Updated by Eric Pareja  Closes: #416822
+    * tl.po: Updated by Eric Pareja   Closes: #416638
+    * gl.po: Updated by Jacobo Tarrio
+             Closes: #412828
+    * da.po: Updated by Claus Hindsgaul
+             Closes: #409483
+    * fr.po: Remove a non-breakable space for usability
+             issues. Closes: #408877
+    * ru.po: Updated Russian translation. Closes: #405476
+    * *.po: Unfuzzy after upstream typo corrections
+    * vi.po: Updated to 515t. Closes: #426976
+    * eu.po: Updated to 515t. Closes: #423766
+    * pt.po: 515t. Closes: #423111
+    * fr.po: Updated by Christian Perrier
+    * Update all PO and the POT. Gives 513t2f for formerly
+      complete translations
+  * apt-pkg/policy.cc:
+    - allow multiple packages (thanks to David Foerster)
+
+ -- Michael Vogt <mvo@debian.org>  Wed,  2 May 2007 13:43:44 +0200
+
+apt (0.7.0) experimental; urgency=low
+
+  * Package that contains tall the new features
+  * Removed all #pragma interface/implementation
+  * Branch that contains tall the new features:
+  * translated package descriptions
+  * task install support
+  * automatic dependency removal (thanks to Daniel Burrows)
+  * merged support for the new dpkg "Breaks" field 
+    (thanks to Ian Jackson)
+  * handle network failures more gracefully on "update"
+  * support for unattended-upgrades (via unattended-upgrades
+    package)
+  * added apt-transport-https method
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 12 Jan 2007 20:48:07 +0100
+
+apt (0.6.46.4-0.1) unstable; urgency=emergency
+  
+  * NMU
+  * Fix broken use of awk in apt-key that caused removal of the wrong keys
+    from the keyring. Closes: #412572
 
- -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 18 Dec 2006 19:39:05 +0100
+ -- Joey Hess <joeyh@debian.org>  Mon, 26 Feb 2007 16:00:22 -0500
 
 apt (0.6.46.4) unstable; urgency=high
 
@@ -58,40 +215,53 @@ apt (0.6.46.3) unstable; urgency=low
       messages 
 
   * Merged from Christian Perrier bzr branch:
-     - ca.po: Updated to 514t
-     - be.po: Updated to 514t
-     - it.po: Updated to 514t
-     - hu.po: Updated to 514t
-     - zh_TW.po: Updated to 514t
-     - ar.po: Updated to 293t221u.
-     - ru.po: Updated to 514t. Closes: #392466
-     - nb.po: Updated to 514t. Closes: #392466
-     - pt.po: Updated to 514t. Closes: #393199
-     - fr.po: One spelling error corrected: s/accèder/accéder
-     - km.po: Updated to 514t.
-     - ko.po: Updated to 514t.
-     - bg.po: Updated to 514t.
-     - de.po: Updated to 514t.
-     - en_GB.po: Updated to 514t.
-
- -- Michael Vogt <mvo@debian.org>  Thu, 2 Nov 2006 11:37:58 +0100 
+    - ca.po: Updated to 514t
+    - be.po: Updated to 514t
+    - it.po: Updated to 514t
+    - hu.po: Updated to 514t
+    - zh_TW.po: Updated to 514t
+    - ar.po: Updated to 293t221u.
+    - ru.po: Updated to 514t. Closes: #392466
+    - nb.po: Updated to 514t. Closes: #392466
+    - pt.po: Updated to 514t. Closes: #393199
+    - fr.po: One spelling error corrected: s/accèder/accéder
+    - km.po: Updated to 514t.
+    - ko.po: Updated to 514t.
+    - bg.po: Updated to 514t.
+    - de.po: Updated to 514t.
+    - en_GB.po: Updated to 514t.
+
+ -- Michael Vogt <mvo@debian.org>  Thu,  2 Nov 2006 11:37:58 +0100
 
 apt (0.6.46.2) unstable; urgency=low
 
+  * debian/control:
+    - depend on debian-archive-keyring to offer clean upgrade path 
+      (closes: #386800)
   * Merged from Christian Perrier bzr branch:
     - es.po: Updated to 514t. Closes: #391661
     - da.po: Updated to 514t. Closes: #391424
     - cs.po: Updated. Closes: #391064
     - es.po: Updated to 514t. Closes: #391661
     - da.po: Updated to 514t. Closes: #391424
-  
+
  -- Michael Vogt <mvo@debian.org>  Wed, 11 Oct 2006 09:03:15 +0200
 
 apt (0.6.46.1) unstable; urgency=low
 
+  * merged "install-recommends" branch (ABI break): 
+    - new "--install-recommends"
+    - install new recommends on "upgrade" if --install-recommends is 
+      given
+    - new "--fix-policy" option to install all packages with unmet
+      important dependencies (usefull with --install-recommends to
+      see what not-installed recommends are on the system)
+    - fix of recommended packages display (only show CandidateVersion
+      fix or-group handling)
+  * merged "install-task" branch (use with "apt-get install taskname^")
   * methods/gzip.cc:
     - deal with empty files 
-  * Applied patch from Daniel Schepler to make apt bin-NMU able.  
+  * Applied patch from Daniel Schepler to make apt bin-NMU able.
     (closes: bug#359634)
   * rebuild against current g++ because of:
     http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29289
@@ -179,26 +349,42 @@ apt (0.6.45) unstable; urgency=low
     * dz.po: New Dzongkha translation: 512t
     * ro.po: Updated to 512t
     * eu.po: Updated
+    * eu.po: Updated
+  * fix apt-get dist-upgrade
+  * fix warning if no /var/lib/apt/extended_states is present
+  * don't download Translations for deb-src sources.list lines
+  * apt-pkg/tagfile.cc:
+    - support not-mmapable files again
 
- -- Michael Vogt <mvo@debian.org>  Thu, 27 Jul 2006 00:52:05 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 25 Jul 2006 11:55:22 +0200
 
-apt  (0.6.44.2) unstable; urgency=low 
-  
-   * apt-pkg/depcache.cc:
-     - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
-   * apt-pkg/acquire-item.cc:
-     - fix missing chmod() in the new aquire code
-       (thanks to Bastian Blank, Closes: #367425)
-   * merged from
-     http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
-     * sk.po: Completed to 512t
-     * eu.po: Completed to 512t
-     * fr.po: Completed to 512t
-     * sv.po: Completed to 512t
-     * Update all PO and the POT. Gives 506t6f for formerly
-       complete translations
-
- -- Michael Vogt <mvo@debian.org>  Wed, 14 Jun 2006 12:00:57 +0200 
+apt (0.6.44.2exp1) experimental; urgency=low
+
+  * added support for i18n of the package descriptions
+  * added support for aptitude like auto-install tracking (a HUGE
+    HUGE thanks to Daniel Burrows who made this possible) 
+  * synced with the http://people.debian.org/~mvo/bzr/apt/debian-sid branch
+  * build from http://people.debian.org/~mvo/bzr/apt/debian-experimental
+
+ -- Michael Vogt <mvo@debian.org>  Mon,  3 Jul 2006 21:50:31 +0200
+
+apt (0.6.44.2) unstable; urgency=low
+
+  * apt-pkg/depcache.cc:
+    - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
+  * apt-pkg/acquire-item.cc:
+    - fix missing chmod() in the new aquire code 
+      (thanks to Bastian Blank, Closes: #367425)
+  * merged from 
+    http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+    * sk.po: Completed to 512t
+    * eu.po: Completed to 512t
+    * fr.po: Completed to 512t
+    * sv.po: Completed to 512t
+    * Update all PO and the POT. Gives 506t6f for formerly
+      complete translations
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 14 Jun 2006 12:00:57 +0200
 
 apt (0.6.44.1-0.1) unstable; urgency=low
 
@@ -210,22 +396,32 @@ apt (0.6.44.1-0.1) unstable; urgency=low
 
 apt (0.6.44.1) unstable; urgency=low
 
+  * apt-pkg/acquire-item.cc:
+    - fix reversed logic of the "Acquire::PDiffs" option
   * merged from 
     http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
     - po/LINGUAS: added "bg" Closes: #360262
     - po/gl.po: Galician translation update. Closes: #366849
     - po/hu.po: Hungarian translation update. Closes: #365448
     - po/cs.po: Czech translation updated. Closes: #367244
+  * apt-pkg/contrib/sha256.cc:
+    - applied patch to fix unaligned access problem. Closes: #367417
+      (thanks to David Mosberger)
 
  -- Michael Vogt <mvo@debian.org>  Tue, 16 May 2006 21:51:16 +0200
 
 apt (0.6.44) unstable; urgency=low
 
   * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+  * apt-pkg/contrib/sha256.{cc,h},hashes.{cc,h}: support for sha256 
+    (thanks to Anthony Towns)
+  * ftparchive/cachedb.{cc,h},writer.{cc,h}: optimizations 
+    (thanks to Anthony Towns)
+  * apt pdiff support from experimental merged
+  * apt-pkg/deb/dpkgpm.cc: wording fixes (thanks to Matt Zimmerman)
   * apt-pkg/deb/dpkgpm.cc: 
     - wording fixes (thanks to Matt Zimmerman)
-    - fix error in dpkg interaction (closes: #364513, 
-      thanks to Martin Dickopp)
+    - fix error in dpkg interaction (closes: #364513, thanks to Martin Dickopp)
   * apt-pkg/tagfile.{cc,h}:
     - use MMap to read the entries (thanks to Zephaniah E. Hull for the
       patch) Closes: #350025
@@ -420,7 +616,7 @@ apt (0.6.42) unstable; urgency=low
   * cmdline/apt-cdrom.cc: 
     - fix some missing gettext() calls (closes: #334539)
   * doc/apt-cache.8.xml: fix typo (closes: #334714)
-  
+
  -- Michael Vogt <mvo@debian.org>  Wed, 19 Oct 2005 22:02:09 +0200
 
 apt (0.6.41) unstable; urgency=low
@@ -520,6 +716,7 @@ apt (0.6.37) breezy; urgency=low
   * Add Welsh translation from Dafydd Harries
     (daf@muse.19inch.net--2005/apt--main--0--patch-1)
   * Change debian/bugscript to use #!/bin/bash (Closes: #313402)
+  * Fix a incorrect example in the man-page (closes: #282918)
 
  -- Matt Zimmerman <mdz@ubuntu.com>  Tue, 24 May 2005 14:38:25 -0700