moved to git, updated gbp.conf to match the bzr version
[ntk/apt.git] / debian / rules
index 1446a03..5051dab 100755 (executable)
@@ -5,6 +5,7 @@
 
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -18,6 +19,8 @@ endif
 
 ifneq (,$(shell which dpkg-buildflags))
   export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
+  export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+  export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 else
   ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
     export CXXFLAGS = -O0 -g -Wall
@@ -31,9 +34,6 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
-APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
-APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -50,19 +50,8 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
-# Rebuild configure.in to have the correct version from the change log
-ifneq ($(APT_DEBVER),$(APT_CONFVER))
-ifneq ($(APT_DEBVER),)
-.PHONY: configure.in
-configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
-endif
-else
-configure.in:
-endif
-
 # APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
+APT_UTILS=ftparchive sortpkgs extracttemplates
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -78,7 +67,8 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
 build: build/build-stamp
-build-doc: build/build-doc-stamp
+build-debiandoc: build/build-debiandoc-stamp
+build-manpages: build/build-manpages-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -91,7 +81,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
+       cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -100,12 +90,22 @@ build/build-stamp: build/configure-stamp
        # compat symlink for the locale split
        mkdir -p build/usr/share 
        cd build/usr/share && ln -f -s ../../locale .
-       # done here
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
-build/build-doc-stamp: build/configure-stamp
+build/build-debiandoc-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) doc
+       $(MAKE) debiandoc
+       touch $@
+
+build/build-manpages-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) manpages
        touch $@
 
 clean:
@@ -113,10 +113,15 @@ clean:
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
+       rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+             debian/libapt-pkg-dev.install
+
+debian/%.install: debian/%.install.in
+       sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
 binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build-doc
+libapt-pkg-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -142,7 +147,7 @@ libapt-pkg-doc: build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-doc: build-doc
+apt-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -167,8 +172,8 @@ apt-doc: build-doc
 # Build architecture-dependent files here.
 
 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-doc
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -186,7 +191,7 @@ apt: build build-doc
        dh_install -p$@ --sourcedir=$(BLD)
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
 
        # https has its own package
        rm debian/$@/usr/lib/apt/methods/https
@@ -212,7 +217,7 @@ apt: build build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -232,7 +237,7 @@ libapt-pkg-dev: build
        dh_builddeb -p$@
 
 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build
+apt-utils: build build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -240,6 +245,7 @@ apt-utils: build
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+       cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
 
        dh_install -p$@ --sourcedir=$(BLD)
        dh_link -p$@
@@ -260,7 +266,7 @@ apt-utils: build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_PKG): build
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -279,7 +285,7 @@ $(LIBAPT_PKG): build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_INST): build
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@