Add support to debian/rules to update config.sub and co...
[ntk/apt.git] / debian / rules
index e8a3363..6599a0d 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.40 2002/11/09 20:13:27 doogie Exp $
+# $Id: rules,v 1.41 2002/11/09 20:21:54 doogie Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -100,6 +100,14 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
+ifneq ($(wildcard /usr/share/misc/config.sub),)
+       cp -a /usr/share/misc/config.sub buildlib/config.sub
+       echo Updating buildlib/config.sub
+endif
+ifneq ($(wildcard /usr/share/misc/config.guess),)
+       cp -a /usr/share/misc/config.guess buildlib/config.guess
+       echo Updating buildlib/config.guess
+endif
        (cd build; ../configure $(confflags))
        touch $@