* cmdline/apt-get.cc:
[ntk/apt.git] / debian / changelog
index 41609bd..0482dff 100644 (file)
@@ -1,3 +1,18 @@
+apt (0.7.2ubuntu1) gutsy; urgency=low
+
+  * apt-pkg/deb/dpkgpm.cc:
+    - apport integration added, this means that a apport
+      report is written on dpkg failures
+  * cmdline/apt-get.cc:
+    - merged http://people.ubuntu.com/~mvo/bzr/apt/xs-vcs-bzr/
+      this will warn when Vcs- headers are found on apt-get source
+      (Fixes LP:#115959)
+  * merged from debian/unstable, remaining changes:
+    - maintainer field changed
+
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 14 Jun 2007 10:38:36 +0200
+
 apt (0.7.2) unstable; urgency=low
   
   * merged the debian/experimental changes back
@@ -56,12 +71,16 @@ apt (0.7.1) experimental; urgency=low
   * methods/cdrom.cc:  
     - only umount if it was mounted by the method before
   * po/gl.po:
-    - fix error translation that causes trouble to lsb_release
+    - fix error in translation that causes trouble to lsb_release 
+      (LP#79165)
   * apt-pkg/acquire-item.cc:
     - if decompression of a index fails, delete the index 
   * apt-pkg/acquire.{cc,h}:
     - deal better with duplicated sources.list entries (avoid
       double queuing of  URLs) - this fixes hangs in bzip/gzip
+      (LP#102511)
+  * Fix broken use of awk in apt-key that caused removal of the wrong keys
+    from the keyring. Closes: #412572
   * merged from Christian Perrier:
     * mr.po: New Marathi translation  Closes: #416806
     * zh_CN.po: Updated by Eric Pareja  Closes: #416822
@@ -83,7 +102,94 @@ apt (0.7.1) experimental; urgency=low
   * apt-pkg/policy.cc:
     - allow multiple packages (thanks to David Foerster)
 
- -- Michael Vogt <mvo@debian.org>  Wed,  2 May 2007 13:43:44 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 17 Apr 2007 15:53:37 +0200
+
+apt (0.6.46.4ubuntu10) feisty; urgency=low
+
+  * apt-pkg/depcache.cc:
+    - added "APT::Never-MarkAuto-Section" and consider dependencies 
+      of packages in this section manual (LP#59893)
+    - ensure proper permissions in the extended_state file (LP#67037)
+  * debian/apt.conf.ubuntu:
+    - added APT::Never-MarkAuto-Section "metapackages" (LP#59893)
+  * cmdline/apt-get.cc:
+    - "apt-get install foo" on a already installed package foo will
+      clean the automatic installed flag (LP#72007)
+    - do not show packages already marked for removal as auto-installed
+      (LP#64493)
+    - applied patch to (optionally) hide the auto-remove information
+      (thanks to Frode M. Døving) (LP#69148)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 14 Mar 2007 13:32:32 +0100
+
+apt (0.6.46.4ubuntu9) feisty; urgency=low
+
+  * debian/control:
+    - set XS-Vcs-Bzr header
+    - Set Ubuntu maintainer address
+  * apt-pkg/cdrom.cc:
+    - only unmount if APT::CDROM::NoMount is false
+    - only umount if it was mounted by the method before
+  * cmdline/apt-get.cc:
+    - fix version output in autoremove list (LP#68941)
+  * apt-pkg/packagemanager.cc:
+    - do not spin 100% cpu in FixMissing() (LP#84476)
+  * apt-pkg/indexfile.cc:
+    - fix problem overwriting APT::Acquire::Translation
+  * doc/examples/configure-index:
+    - document APT::Acquire::Translation
+  
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 13 Mar 2007 15:24:39 +0100
+
+apt (0.6.46.4ubuntu8) feisty; urgency=low
+
+  * fix segfault in the pkgRecords destructor
+  * Bump ABI version
+  * debian/control:
+    - make the libcurl3-gnutls-dev versionized (LP#86614)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 26 Feb 2007 14:26:33 +0100
+
+apt (0.6.46.4ubuntu7) feisty; urgency=low
+
+  * Merged the apt--mirror branch. This means that a new 'mirror' 
+    method is available that will allow dynamic mirror updates.
+    The sources.list entry looks something like this:
+    "deb mirror://mirrors.lp.net/get_mirror feisty main restricted"
+
+    It also supports error reporting to a configurable url for mirror
+    problems/failures.
+  * Bump ABI version
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue,  6 Feb 2007 11:38:06 +0100
+
+apt (0.6.46.4ubuntu6) feisty; urgency=low
+
+  * methods/http.cc:
+    - send apt version in User-Agent
+  * apt-pkg/deb/debrecords.cc:
+    - fix SHA1Hash() return value
+  * apt-pkg/algorithms.cc:
+    - fix resolver bug on removal triggered by weak-dependencies 
+      with or-groups
+    - fix segfault (lp: #76530)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 20 Dec 2006 11:04:36 +0100
+
+apt (0.6.46.4ubuntu5) feisty; urgency=low
+
+  * added apt-transport-https package to provide a optional
+    https transport (apt-https spec)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 19 Dec 2006 16:23:43 +0100
+
+apt (0.6.46.4ubuntu4) feisty; urgency=low
+  
+  * apt-pkg/algorithms.cc:
+    - only increase the score of installed applications if they 
+      are not obsolete 
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 18 Dec 2006 19:39:05 +0100
 
 apt (0.7.0) experimental; urgency=low
 
@@ -102,6 +208,29 @@ apt (0.7.0) experimental; urgency=low
 
  -- Michael Vogt <mvo@debian.org>  Fri, 12 Jan 2007 20:48:07 +0100
 
+apt (0.6.46.4ubuntu3) feisty; urgency=low
+
+  * apt-pkg/algorithm.cc:
+    - use clog for all debugging
+  * apt-pkg/depcache.cc:
+    - never mark Required package for autoremoval (lp: #75882)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 18 Dec 2006 11:56:05 +0100
+
+apt (0.6.46.4ubuntu2) feisty; urgency=low
+
+  * apt-pkg/algorithms.cc: add missing call to MarkKeep
+    so that dist-upgrade isn't broken by unsatisfiable Breaks.
+    (thanks to Ian Jackson)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu,  7 Dec 2006 23:07:24 +0100
+
+apt (0.6.46.4ubuntu1) feisty; urgency=low
+
+  * merged with debian
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu,  7 Dec 2006 12:13:14 +0100
+
 apt (0.6.46.4-0.1) unstable; urgency=emergency
   
   * NMU
@@ -148,6 +277,26 @@ apt (0.6.46.3-0.1) unstable; urgency=high
   
  -- Andreas Barth <aba@not.so.argh.org>  Tue,  5 Dec 2006 10:34:56 +0000
 
+apt (0.6.46.3ubuntu2) feisty; urgency=low
+
+  * apt-pkg/algorithms.cc: add missing call to MarkKeep
+    so that dist-upgrade isn't broken by unsatisfiable Breaks.
+
+ -- Ian Jackson <iwj@ubuntu.com>  Thu,  7 Dec 2006 15:46:52 +0000
+
+apt (0.6.46.3ubuntu1) feisty; urgency=low
+
+  * doc/apt-get.8.xml:
+    - documented autoremove, thanks to Vladimír Lapá\e%GÄ\8d\e%@ek 
+      (lp: #62919)
+  * fix broken i18n in the dpkg progress reporting, thanks to 
+    Frans Pop and Steinar Gunderson. (closes: #389261)
+  * po/en_GB.po:
+    - typo (lp: #61270)
+  * add apt-secure.8 to "See also" section
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 23 Nov 2006 07:24:12 +0100
+
 apt (0.6.46.3) unstable; urgency=low
 
   * apt-pkg/deb/dpkgpm.cc:
@@ -222,10 +371,46 @@ apt (0.6.46) unstable; urgency=low
   * debian/control:
     - switched to libdb4.4 for building (closes: #381019)
   * cmdline/apt-get.cc:
-    - show only the recommends/suggests for the candidate-version, not for all
-      versions of the package (closes: #257054)
-    - properly handle recommends/suggests or-groups when printing the list of
-      suggested/recommends packages (closes: #311619)
+    - fix in the TryInstallTask() code to make sure that all package
+      there are marked manual install (lp: #61684)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 28 Sep 2006 00:34:20 +0200
+
+apt (0.6.45ubuntu14) edgy; urgency=low
+
+  * cmdline/apt-get.cc:
+    - fix in the TryInstallTask() code to make sure that all package
+      there are marked manual install (lp: #61684)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 28 Sep 2006 00:34:20 +0200
+
+apt (0.6.45ubuntu13) edgy; urgency=low
+
+  * no-changes upload to make apt rebuild against latest g++ and
+    fix synaptic FTBFS (see bug: #62461 for details)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 26 Sep 2006 22:33:10 +0200
+
+apt (0.6.45ubuntu12) edgy; urgency=low
+
+  * apt-pkg/depcache.cc:
+    - fix in the sweep() code, set garbage flag for packages scheduled 
+      for removal too
+    - do not change the autoFlag in MarkKeep(), this can lead to suprising
+      side effects
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 21 Sep 2006 00:58:24 +0200
+
+apt (0.6.45ubuntu11) edgy; urgency=low
+
+  * removed "installtask" and change it so that tasknames can be given
+    with "apt-get install taskname^"
+  * improve the writeStateFile() code
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 20 Sep 2006 14:14:24 +0200
+
+apt (0.6.45ubuntu10) edgy; urgency=low
+
   * methods/http.cc:
     - check more careful for incorrect proxy settings (closes: #378868)
   * methods/gzip.cc:
@@ -250,8 +435,113 @@ apt (0.6.46) unstable; urgency=low
       caseinsensitive (closes: #384182)
     - reverted MMap use in the tagfile because it does not work 
       across pipes (closes: #383487) 
+  * added "installtask" command
+  * added new ubuntu specific rewrite rule for "Original-Maintainer"
   
- -- Michael Vogt <mvo@debian.org>  Thu, 21 Sep 2006 10:25:03 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 19 Sep 2006 15:07:51 +0200
+
+apt (0.6.45ubuntu9) edgy; urgency=low
+
+  * cmdline/apt-get.cc:
+    - if --no-remove is given, do not run the AutoRemove code 
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 13 Sep 2006 11:54:20 +0200
+
+apt (0.6.45ubuntu8) edgy; urgency=low
+
+  * apt-pkg/algorithm.cc:
+    - fix pkgProblemResolver.InstallProtect() to preserve the auto-install
+      information (lp: #59457)
+  * cmdline/apt-get.cc:
+    - fix typo in autoremove information (lp: #59420)
+  * install apt-mark to modify the automatically install information for
+    packages
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri,  8 Sep 2006 20:07:22 +0200
+
+apt (0.6.45ubuntu7) edgy; urgency=low
+
+  * apt-pkg/depcache.cc:
+    - fix a bug in the install-recommends-section code
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu,  7 Sep 2006 18:22:38 +0200
+
+apt (0.6.45ubuntu6) edgy; urgency=low
+
+  [Michael Vogt]
+  * cmdline/apt-get.cc:
+    - always show auto-removable packages and give a hint how to remove 
+      them
+  * debian/apt.conf.ubuntu:
+    - exlucde linux-image and linux-restricted-modules from ever being 
+      auto-removed
+    - added "metapackages" as the section we want to install recommends
+      by default
+  * apt-pkg/depcache.cc:
+    - added support to turn install-recommends selectively on/off by
+      section
+  [Ian Jackson]
+  * Tests pass without code changes!  Except that we need this:
+  * Bump cache file major version to force rebuild so that Breaks
+    dependencies are included.
+  * Don't depend on or suggest any particular dpkg or dpkg-dev versions;
+    --auto-deconfigure is very very old and dpkg-dev's Breaks support
+    is more or less orthogonal.
+  * Initial draft of `Breaks' implementation.  Appears to compile,
+    but as yet *completely untested*.
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu,  7 Sep 2006 11:50:52 +0200
+
+apt (0.6.45ubuntu5) edgy; urgency=low
+
+  * apt-pkg/pkgcachegen.cc:
+    - increase the APT::Cache-Limit to deal with the increased demand due
+      to the translated descriptions
+  * apt-pkg/deb/dpkgpm.cc:
+    - pass "--auto-deconfigure" to dpkg on install to support the
+      new "breaks" in dpkg
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 15 Aug 2006 12:06:26 +0200
+
+apt (0.6.45ubuntu4) edgy; urgency=low
+
+  * cmdline/apt-get.cc:
+    - fix in the new --fix-polciy code
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 14 Aug 2006 21:08:11 +0200
+
+apt (0.6.45ubuntu3) edgy; urgency=low
+
+  * ABI break
+  * merged latest apt--install-recommends (closes: #559000)
+  * added "--fix-policy" option to can be used as "--fix-broken" and
+    will install missing weak depends (recommends, and/or suggests 
+    depending on the settings)
+  * merged the apt--ddtp branch
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 11 Aug 2006 12:53:23 +0200
+
+apt (0.6.45ubuntu2) edgy; urgency=low
+
+  * debian/control:
+    - switched to libdb4.4 for building (closes: #381019)
+  * cmdline/apt-get.cc:
+    - show only the recommends/suggests for the candidate-version, not for all
+      versions of the package (closes: #257054)
+    - properly handle recommends/suggests or-groups when printing the list of
+      suggested/recommends packages (closes: #311619)
+  * merged "apt--install-recommends" branch:
+    - added "{no-}install-recommends" commandline option
+    - added APT::Install-{Recommends,Suggests} option
+    - currently Install-Recommends defaults to "False" 
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed,  9 Aug 2006 23:38:46 +0200
+
+apt (0.6.45ubuntu1) edgy; urgency=low
+
+  * merged with debian/unstable
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue,  1 Aug 2006 15:43:22 +0200
 
 apt (0.6.45) unstable; urgency=low
 
@@ -289,42 +579,57 @@ apt (0.6.45) unstable; urgency=low
     * dz.po: New Dzongkha translation: 512t
     * ro.po: Updated to 512t
     * eu.po: Updated
-    * eu.po: Updated
-  * fix apt-get dist-upgrade
-  * fix warning if no /var/lib/apt/extended_states is present
-  * don't download Translations for deb-src sources.list lines
-  * apt-pkg/tagfile.cc:
-    - support not-mmapable files again
 
- -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 25 Jul 2006 11:55:22 +0200
+ -- Michael Vogt <mvo@debian.org>  Thu, 27 Jul 2006 00:52:05 +0200
 
-apt (0.6.44.2exp1) experimental; urgency=low
+apt (0.6.44.2ubuntu4) edgy; urgency=low
 
-  * added support for i18n of the package descriptions
-  * added support for aptitude like auto-install tracking (a HUGE
-    HUGE thanks to Daniel Burrows who made this possible) 
-  * synced with the http://people.debian.org/~mvo/bzr/apt/debian-sid branch
-  * build from http://people.debian.org/~mvo/bzr/apt/debian-experimental
+  * Make apt-get dselect-upgrade happy again
 
- -- Michael Vogt <mvo@debian.org>  Mon,  3 Jul 2006 21:50:31 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 21 Jul 2006 11:03:02 +0200
 
-apt (0.6.44.2) unstable; urgency=low
+apt (0.6.44.2ubuntu3) edgy; urgency=low
 
-  * apt-pkg/depcache.cc:
-    - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
-  * apt-pkg/acquire-item.cc:
-    - fix missing chmod() in the new aquire code 
-      (thanks to Bastian Blank, Closes: #367425)
-  * merged from 
-    http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
-    * sk.po: Completed to 512t
-    * eu.po: Completed to 512t
-    * fr.po: Completed to 512t
-    * sv.po: Completed to 512t
-    * Update all PO and the POT. Gives 506t6f for formerly
-      complete translations
+  * Close extended_states file after writing it.
+
+ -- Colin Watson <cjwatson@ubuntu.com>  Tue, 18 Jul 2006 00:12:13 +0100
+
+apt (0.6.44.2ubuntu2) edgy; urgency=low
+
+  * create a empty extended_states file if none exists already
 
- -- Michael Vogt <mvo@debian.org>  Wed, 14 Jun 2006 12:00:57 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue,  4 Jul 2006 09:23:03 +0200
+
+apt (0.6.44.2ubuntu1) edgy; urgency=low
+
+  * merged with debian/unstable
+  * merged the "auto-mark" branch to support aptitude like
+    marking of automatically installed dependencies and added
+    "apt-get remove --auto-remove" to remove unused auto-installed
+    packages again
+  * changed library version from 3.11 to 3.50 to make it clearly 
+    different from the debian version (we are ABI incompatible because
+    of the auto-mark patch)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon,  3 Jul 2006 18:30:46 +0200
+
+apt (0.6.44.2) unstable; urgency=low
+  
+   * apt-pkg/depcache.cc:
+     - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
+   * apt-pkg/acquire-item.cc:
+     - fix missing chmod() in the new aquire code
+       (thanks to Bastian Blank, Closes: #367425)
+   * merged from
+     http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+     * sk.po: Completed to 512t
+     * eu.po: Completed to 512t
+     * fr.po: Completed to 512t
+     * sv.po: Completed to 512t
+     * Update all PO and the POT. Gives 506t6f for formerly
+       complete translations
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 14 Jun 2006 12:00:57 +0200 
 
 apt (0.6.44.1-0.1) unstable; urgency=low
 
@@ -386,6 +691,26 @@ apt (0.6.44) unstable; urgency=low
   
  -- Michael Vogt <mvo@debian.org>  Mon,  8 May 2006 22:28:53 +0200
 
+apt (0.6.43.3ubuntu3) dapper; urgency=low
+
+  * methods/http.cc:
+    - fix the user-agent string
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 26 May 2006 18:09:32 +0200
+
+apt (0.6.43.3ubuntu2) dapper; urgency=low
+
+  * apt-pkg/deb/dpkgpm.cc: wording fixes (thanks to Matt Zimmerman)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 18 Apr 2006 13:24:40 +0200
+
+apt (0.6.43.3ubuntu1) dapper; urgency=low
+
+  * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large in 
+    the status-fd (ubuntu #28954)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 28 Mar 2006 20:34:46 +0200
+
 apt (0.6.43.3) unstable; urgency=low
 
   * Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
@@ -395,16 +720,46 @@ apt (0.6.43.3) unstable; urgency=low
     * pl.po: Completed to 512t. Closes: #349514
     * sk.po: Completed to 512t. Closes: #349474
     * gl.po: Completed to 512 strings Closes: #349407
+    * vi.po: Completed to 512 strings
     * sv.po: Completed to 512 strings Closes: #349210
     * ru.po: Completed to 512 strings Closes: #349154
     * da.po: Completed to 512 strings Closes: #349084
     * fr.po: Completed to 512 strings
+    * LINGUAS: Add Welsh
+    * *.po: Updated from sources (512 strings)
     * vi.po: Completed to 511 strings  Closes: #348968
-    * zh_CN.po: Completed to 512t. Closes: #353936
-    * it.po: Completed to 512t. Closes: #352803
-    * pt_BR.po: Completed to 512t. Closes: #352419
+  * apt-pkg/deb/deblistparser.cc:
+    - don't explode on a DepCompareOp in a Provides line, but warn about
+      it and ignore it otherwise (thanks to James Troup for reporting it)
+  * cmdline/apt-get.cc:
+    - don't lock the lists directory in DoInstall, breaks --print-uri 
+      (thanks to James Troup for reporting it)
+  * debian/apt.dirs: create /etc/apt/sources.list.d 
+  * make apt-cache madison work without deb-src entries (#352583)
+  * cmdline/apt-get.cc: only run the list-cleaner if a update was 
+    successfull
+  * apt-get update errors are only warnings nowdays
+  * be more careful with the signature file on network failures
+
+ --  Michael Vogt <mvo@debian.org>  Wed, 22 Feb 2006 10:13:04 +0100
+
+apt (0.6.43.2ubuntu1) dapper; urgency=low
+
+  * Merge bubulle@debian.org--2005/apt--main--0 up to patch-182:
+  * ca.po: Completed to 512t. Closes: #351592
+    * eu.po: Completed to 512t. Closes: #350483
+    * ja.po: Completed to 512t. Closes: #349806
+    * pl.po: Completed to 512t. Closes: #349514
+    * sk.po: Completed to 512t. Closes: #349474
+    * gl.po: Completed to 512 strings Closes: #349407
+    * vi.po: Completed to 512 strings
+    * sv.po: Completed to 512 strings Closes: #349210
+    * ru.po: Completed to 512 strings Closes: #349154
+    * da.po: Completed to 512 strings Closes: #349084
+    * fr.po: Completed to 512 strings
     * LINGUAS: Add Welsh
     * *.po: Updated from sources (512 strings)
+    * vi.po: Completed to 511 strings  Closes: #348968
   * apt-pkg/deb/deblistparser.cc:
     - don't explode on a DepCompareOp in a Provides line, but warn about
       it and ignore it otherwise (thanks to James Troup for reporting it)
@@ -415,8 +770,10 @@ apt (0.6.43.3) unstable; urgency=low
   * make apt-cache madison work without deb-src entries (#352583)
   * cmdline/apt-get.cc: only run the list-cleaner if a update was 
     successfull
+  * apt-get update errors are only warnings nowdays
+  * be more careful with the signature file on network failures
 
- -- Michael Vogt <mvo@debian.org>  Wed, 22 Feb 2006 10:13:04 +0100
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 20 Feb 2006 22:27:48 +0100
 
 apt (0.6.43.2) unstable; urgency=low
 
@@ -441,8 +798,26 @@ apt (0.6.43.2) unstable; urgency=low
 
  -- Michael Vogt <mvo@debian.org>  Thu, 19 Jan 2006 00:06:33 +0100
 
-apt (0.6.43.1) unstable; urgency=low
+apt (0.6.43.1ubuntu1) dapper; urgency=low
+
+  * Merge bubulle@debian.org--2005/apt--main--0 up to patch-159:
+    - en_GB.po, de.po: fix spaces errors in "Ign " translations
+      Closes: #347258
+    - makefile: make update-po a pre-requisite of clean target so
+               that POT and PO files are always up-to-date
+    - sv.po: Completed to 511t. Closes: #346450
+    - sk.po: Completed to 511t. Closes: #346369
+    - fr.po: Completed to 511t
+    - *.po: Updated from sources (511 strings)
+  * add patch to fix http download corruption problem (thanks to
+    Petr Vandrovec, closes: #280844, #290694)
+  * added APT::Periodic::Unattended-Upgrade (requires the package
+    "unattended-upgrade")
 
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 10 Jan 2006 17:09:31 +0100
+
+apt (0.6.43.1) unstable; urgency=low
+  
   * Merge bubulle@debian.org--2005/apt--main--0 up to patch-148:
     * fr.po: Completed to 510 strings
     * it.po: Completed to 510t
@@ -464,6 +839,19 @@ apt (0.6.43.1) unstable; urgency=low
 
  -- Michael Vogt <mvo@debian.org>  Fri,  6 Jan 2006 01:17:08 +0100
 
+apt (0.6.43ubuntu2) dapper; urgency=low
+
+  * merged some missing bits that wheren't merged by baz in the previous
+    upload (*grumble*)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu,  8 Dec 2005 18:35:58 +0100
+
+apt (0.6.43ubuntu1) dapper; urgency=low
+
+  * merged with debian
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 25 Nov 2005 11:36:29 +0100
+
 apt (0.6.43) unstable; urgency=medium
 
   * Merge bubulle@debian.org--2005/apt--main--0 up to patch-132:  
@@ -484,6 +872,22 @@ apt (0.6.43) unstable; urgency=medium
   
  -- Michael Vogt <mvo@debian.org>  Tue, 29 Nov 2005 00:17:07 +0100
 
+apt (0.6.42.3ubuntu2) dapper; urgency=low
+
+  * Merge bubulle@debian.org--2005/apt--main--0 up to patch-131:  
+    * zh_CN.po: Completed to 507 strings(Closes: #338267)
+    * gl.po: Completed to 510 strings (Closes: #338356)
+  * added support for "/etc/apt/sources.list.d" directory 
+    (closes: #66325)
+  
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 14 Nov 2005 15:30:12 +0100
+
+apt (0.6.42.3ubuntu1) dapper; urgency=low
+
+  * synced with debian
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 10 Nov 2005 05:05:56 +0100
+
 apt (0.6.42.3) unstable; urgency=low
 
   * Merge bubulle@debian.org--2005/apt--main--0 up to patch-129:
@@ -531,13 +935,13 @@ apt (0.6.42) unstable; urgency=low
     - unmount the cdrom when apt failed to locate any package files
   * allow cdrom failures and fallback to other sources in that case
     (closes: #44135)
-  * better error text when dpkg-source fails 
+  * better error text when dpkg-source fails
   * Merge bubulle@debian.org--2005/apt--main--0 up to patch-115:
     - patch-99: Added Galician translation
     - patch-100: Completed Danish translation (Closes: #325686)
     - patch-104: French translation completed
     - patch-109: Italian translation completed
-    - patch-112: Swedish translation update 
+    - patch-112: Swedish translation update
     - patch-115: Basque translation completed (Closes: #333299)
   * applied french man-page update (thanks to Philippe Batailler)
     (closes: #316638, #327456)
@@ -551,9 +955,9 @@ apt (0.6.42) unstable; urgency=low
   * apt-pkg/contrib/md5.cc:
     - fix a alignment problem on sparc64 that gives random bus errors
       (thanks to Fabbione for providing a test-case)
-  * init the default ScreenWidth to 79 columns by default 
+  * init the default ScreenWidth to 79 columns by default
     (Closes: #324921)
-  * cmdline/apt-cdrom.cc: 
+  * cmdline/apt-cdrom.cc:
     - fix some missing gettext() calls (closes: #334539)
   * doc/apt-cache.8.xml: fix typo (closes: #334714)
 
@@ -564,8 +968,8 @@ apt (0.6.41) unstable; urgency=low
   * improved the support for "error" and "conffile" reporting from
     dpkg, added the format to README.progress-reporting
   * added README.progress-reporting to the apt-doc package
-  * improved the network timeout handling, if a index file from a 
-    sources.list times out or EAI_AGAIN is returned from getaddrinfo, 
+  * improved the network timeout handling, if a index file from a
+    sources.list times out or EAI_AGAIN is returned from getaddrinfo,
     don't try to get the other files from that entry
   * Support architecture-specific extra overrides
     (closes: #225947). Thanks to  Anthony Towns for idea and
@@ -573,10 +977,10 @@ apt (0.6.41) unstable; urgency=low
   * Javier Fernandez-Sanguino Pen~a:
     - Added a first version of an apt-secure.8 manpage, and modified
       apt-key and apt.end accordingly. Also added the 'update'
-      argument to apt-key which was previously not documented 
+      argument to apt-key which was previously not documented
       (Closes: #322120)
   * Andreas Pakulat:
-    - added example apt-ftparchive.conf file to doc/examples 
+    - added example apt-ftparchive.conf file to doc/examples
       (closes: #322483)
   * Fix a incorrect example in the man-page (closes: #282918)
   * Fix a bug for very long lines in the apt-cdrom code (closes: #280356)
@@ -585,10 +989,84 @@ apt (0.6.41) unstable; urgency=low
   * Change pkgPolicy::Pin from private to protected to let subclasses
     access it too (closes: #321799)
   * add default constructor for PrvIterator (closes: #322267)
-  * Reread status configuration on debSystem::Initialize() 
+  * Reread status configuration on debSystem::Initialize()
     (needed for apt-proxy, thanks to Otavio for this patch)
-  
+
  -- Michael Vogt <mvo@debian.org>  Mon,  5 Sep 2005 22:59:03 +0200
+  
+apt (0.6.40.1ubuntu8) breezy; urgency=low
+
+  * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-62:
+    - fix for a bad memory/file leak in the mmap code (ubuntu #15603)
+  * po/de.po, po/fr.po: 
+    - updated the translations
+  * po/makefile:
+    - create a single pot file in each domain dir to make rosetta happy
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed, 28 Sep 2005 10:16:06 +0200
+
+apt (0.6.40.1ubuntu7) breezy; urgency=low
+
+  * updated the pot/po files , no code changes
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 27 Sep 2005 18:38:16 +0200
+
+apt (0.6.40.1ubuntu6) breezy; urgency=low
+
+  * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-56:
+    - make it possible for apt to handle a failed MediaChange event and
+      fall back to other sources (ubuntu #13713)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 13 Sep 2005 22:09:50 +0200
+
+apt (0.6.40.1ubuntu5) breezy; urgency=low
+
+  * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-{50,51}.
+    This adds media-change reporting to the apt status-fd (ubuntu #15213)
+  * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-55:
+    apt-pkg/cdrom.cc:
+    - unmount the cdrom when apt failed to locate any package files
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Mon, 12 Sep 2005 15:44:26 +0200
+
+apt (0.6.40.1ubuntu4) breezy; urgency=low
+
+  * debian/apt.cron.daily:
+    - fix a embarrassing typo
+  
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Wed,  7 Sep 2005 10:10:37 +0200
+
+apt (0.6.40.1ubuntu3) breezy; urgency=low
+
+  * debian/apt.cron.daily:
+    - use the ctime as well when figuring what packages need to
+      be removed. This fixes the problem that packages copied with    
+      "cp -a" (e.g. from the installer) have old mtimes (ubuntu #14504)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue,  6 Sep 2005 18:30:46 +0200
+
+apt (0.6.40.1ubuntu2) breezy; urgency=low
+
+  * improved the support for "error" and "conffile" reporting from
+    dpkg, added the format to README.progress-reporting
+  * added README.progress-reporting to the apt-doc package
+  * Do md5sum checking for file and cdrom method (closes: #319142)
+  * Change pkgPolicy::Pin from private to protected to let subclasses
+    access it too (closes: #321799)
+  * methods/connect.cc:
+    - send failure reason for EAI_AGAIN (TmpResolveFailure) to acuire-item
+  * apt-pkg/acquire-item.cc:
+    - fail early if a FailReason is TmpResolveFailure (avoids hangs during
+      the install when no network is available)
+  * merged michael.vogt@ubuntu.com--2005/apt--trust-cdrom--0
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Tue, 23 Aug 2005 19:44:55 +0200
+
+apt (0.6.40.1ubuntu1) breezy; urgency=low
+
+  * Synchronize with Debian
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri,  5 Aug 2005 14:20:56 +0200
 
 apt (0.6.40.1) unstable; urgency=low
 
@@ -599,6 +1077,12 @@ apt (0.6.40.1) unstable; urgency=low
 
  -- Michael Vogt <mvo@debian.org>  Fri,  5 Aug 2005 13:24:58 +0200
 
+apt (0.6.40ubuntu1) breezy; urgency=low
+
+  * Synchronize with Debian
+
+ -- Matt Zimmerman <mdz@ubuntu.com>  Thu,  4 Aug 2005 15:53:22 -0700
+
 apt (0.6.40) unstable; urgency=low
 
   * Patch from Jordi Mallach to mark some additional strings for translation
@@ -614,6 +1098,39 @@ apt (0.6.40) unstable; urgency=low
 
  -- Matt Zimmerman <mdz@debian.org>  Thu, 28 Jul 2005 11:57:32 -0700
 
+apt (0.6.39ubuntu4) breezy; urgency=low
+
+  * Fix keyring paths in apt-key, apt.postinst (I swear I remember doing this
+    before...)
+
+ -- Matt Zimmerman <mdz@ubuntu.com>  Wed, 29 Jun 2005 08:39:17 -0700
+
+apt (0.6.39ubuntu3) breezy; urgency=low
+
+  * Fix keyring locations for Ubuntu in apt-key too.
+
+ -- Colin Watson <cjwatson@ubuntu.com>  Wed, 29 Jun 2005 14:45:36 +0100
+
+apt (0.6.39ubuntu2) breezy; urgency=low
+
+  * Install ubuntu-archive.gpg rather than debian-archive.gpg as
+    /etc/apt/trusted.gpg.
+
+ -- Colin Watson <cjwatson@ubuntu.com>  Wed, 29 Jun 2005 11:53:34 +0100
+
+apt (0.6.39ubuntu1) breezy; urgency=low
+
+  * Michael Vogt
+    - Change debian/bugscript to use #!/bin/bash (Closes: #313402)
+    - Fix a incorrect example in the man-page (closes: #282918)
+    - Support architecture-specific extra overrides
+      (closes: #225947). Thanks to  Anthony Towns for idea and
+      the patch, thanks to Colin Watson for testing it.
+    - better report network timeouts from the methods to the acuire code,
+      only timeout once per sources.list line
+
+ -- Matt Zimmerman <mdz@ubuntu.com>  Tue, 28 Jun 2005 11:52:24 -0700
+
 apt (0.6.39) unstable; urgency=low
 
   * Welsh translation update: daf@muse.19inch.net--2005/apt--main--0--patch-6
@@ -624,7 +1141,14 @@ apt (0.6.39) unstable; urgency=low
   * Update priority of apt-utils to important, to match the override file
   * Install only one keyring on each branch (Closes: #316119)
 
- -- Matt Zimmerman <mdz@debian.org>  Tue, 28 Jun 2005 11:51:09 -0700
+ -- Matt Zimmerman <mdz@debian.org>  Tue, 28 Jun 2005 11:35:21 -0700
+
+apt (0.6.38ubuntu1) breezy; urgency=low
+
+  * First release from Ubuntu branch
+  * Merge with --main--0, switch back to Ubuntu keyring
+
+ -- Matt Zimmerman <mdz@ubuntu.com>  Sat, 25 Jun 2005 16:52:41 -0700
 
 apt (0.6.38) unstable; urgency=low