* apt-pkg/acquire.cc:
[ntk/apt.git] / debian / changelog
index caef53b..30e7b75 100644 (file)
@@ -9,6 +9,13 @@ apt (0.7.21) UNRELEASED; urgency=low
   * Documented all cron script related configuration items in 
     configure-index.
 
+  [ Michael Vogt ]
+  * apt-pkg/acquire.cc:
+    - make the max pipeline depth of the acquire queue configurable
+      via Acquire::Max-Pipeline-Depth
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 28 May 2009 17:51:42 +0200
+
   [ Michael Vogt ]
   * apt-pkg/indexcopy.cc:
     - support having CDs with no Packages file (just a Packages.gz)
@@ -31,18 +38,41 @@ apt (0.7.21) UNRELEASED; urgency=low
   * cmdline/apt-get.cc:
     - fix "apt-get source pkg=ver" if binary name != source name
       and show a message (LP: #202219)
+    - fix "apt-get source pkg" if there is a binary package and
+      a source package of the same name but from different 
+      packages (LP: #330103)
   * apt-pkg/deb/debsystem.cc:
     - make strings i18n able 
   * apt-pkg/contrib/strutl.cc:
     - fix TimeToStr i18n (LP: #289807)
   * [ABI break] merge support for http redirects, thanks to
     Jeff Licquia and Anthony Towns
+  * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+  * apt-pkg/pkgcache.cc:
+    - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+      state (LP: #322955)
+  * methods/https.cc:
+    - add Acquire::https::AllowRedirect support
+  * methods/gpgv.cc:
+    - properly check for expired and revoked keys (closes: #433091)
+  * fix problematic use of tolower() when calculating the version 
+    hash by using locale independant tolower_ascii() function. 
+    Thanks to M. Vefa Bicakci (LP: #80248)
+  * build fixes for g++-4.4
+  * cmdline/apt-mark:
+    - add "showauto" option to show automatically installed packages
 
   [ Dereck Wonnacott ]
   * apt-ftparchive might write corrupt Release files (LP: #46439)
   * Apply --important option to apt-cache depends (LP: #16947) 
   * Clarify the --help for 'purge' (LP: #243948)
 
+
+  [ Colin Watson ]
+  * cmdline/acqprogress.cc:
+    - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+      dlstatus messages on the status-fd (LP: #290234).
+
  -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 12 Sep 2008 11:34:24 +0200
 
 apt (0.7.20) unstable; urgency=low