Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gnunet.scm
index a4514a7..44d6129 100644 (file)
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <ng0@no-reply.pragmatique.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -147,7 +147,7 @@ files, and archive files.  Each file format is implemented as a plugin, so
 new formats can be added easily.  The package also contains a command-line
 tool to extract metadata from a file and print the results.")
    (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/libextractor/")))
+   (home-page "https://www.gnu.org/software/libextractor/")))
 
 (define-public libmicrohttpd
   (package
@@ -184,16 +184,14 @@ and support for SSL3 and TLS.")
 (define-public gnurl
   (package
    (name "gnurl")
-   (version "7.52.1")
+   (version "7.54.0")
    (source (origin
             (method url-fetch)
-            (uri (let ((version-with-underscores
-                        (string-join (string-split version #\.) "_")))
-                   (string-append "https://gnunet.org/sites/default/files/"
-                                  name "-" version-with-underscores ".tar.bz2")))
+            (uri (string-append "https://gnunet.org/sites/default/files/"
+                                name "-" version ".tar.bz2"))
             (sha256
              (base32
-              "1gn6mvab2vhfj9637ykg1zjzb23fngfnyd24wlgxmjhf49pn334h"))))
+              "1ww346cdsxln6iq158a4wm38bmicg5wspd2c83gnqf1glx22hza0"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "doc"))                             ; 1.5 MiB of man3 pages