gnu: sbcl-postmodern: Update to 1.32.6.
[jackhill/guix/guix.git] / gnu / packages / matrix.scm
index 7bbdc09..426f26d 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,15 +61,15 @@ an LDAP server.")
 (define-public synapse
   (package
     (name "synapse")
-    (version "1.11.0")
+    (version "1.24.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "matrix-synapse" version))
               (sha256
                (base32
-                "0cqbwcz0fi4w413s1kcxvf696qi4n46n1k4ggnygqri5yq26qlfy"))))
+                "0pmn8aqc7jj2xdrwljjz2vwg58hlyxp9axac471pcmg2vqais5yb"))))
     (build-system python-build-system)
-    ;; TODO I think there are custom tests
+    ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
     (propagated-inputs
      `(("python-simplejson" ,python-simplejson) ; not attested but required
        ;; requirements (synapse/python_dependencies.py)
@@ -100,12 +102,14 @@ an LDAP server.")
        ("python-bleach" ,python-bleach)
        ("python-typing-extensions" ,python-typing-extensions)
        ;; conditional requirements (synapse/python_dependencies.py)
+       ;;("python-hiredis" ,python-hiredis)
        ("python-matrix-synapse-ldap3" ,python-matrix-synapse-ldap3)
        ("python-psycopg2" ,python-psycopg2)
        ("python-jinja2" ,python-jinja2)
        ("python-txacme" ,python-txacme)
        ("python-pysaml2" ,python-pysaml2)
        ("python-lxml" ,python-lxml)
+       ("python-packaging" ,python-packaging)
        ;; sentry-sdk, jaeger-client, and opentracing could be included, but
        ;; all are monitoring aids and not essential.
        ("python-pyjwt" ,python-pyjwt)))