gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libunwind.scm
index cda83b2..9eaf26f 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public libunwind
   (package
     (name "libunwind")
-    (version "1.1")
+    (version "1.5.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/libunwind/libunwind-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "16nhx2pahh9d62mvszc88q226q5lwjankij276fxwrm8wb50zzlx"))
-             (patches (search-patches "libunwind-CVE-2015-3239.patch"))))
+               "05qhzcg1xag3l5m3c805np6k342gc0f3g087b7g16jidv59pccwh"))))
     (build-system gnu-build-system)
     (arguments
-     ;; FIXME: As of glibc 2.17, we get 3 out of 34 test failures.
+     ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
+     ;; expected to fail).
      ;; Report them upstream.
      '(#:tests? #f))
-    (home-page "http://www.nongnu.org/libunwind")
+    (home-page "https://www.nongnu.org/libunwind")
     (synopsis "Determining the call chain of a program")
     (description
      "The primary goal of this project is to define a portable and efficient C