gnu: Add teensy-loader-cli.
[jackhill/guix/guix.git] / gnu / packages / flashing-tools.scm
index 9f9f1b9..0ab8bc5 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,6 +32,7 @@
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages libftdi)
   #:use-module (gnu packages pciutils)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages admin))
 
 (define-public flashrom
@@ -130,3 +133,81 @@ technique (ISP).")
 Atmel (8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting
 ISP.")
     (license gpl2+)))
+
+(define-public dfu-util
+  (package
+    (name "dfu-util")
+    (version "0.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://dfu-util.sourceforge.net/releases/dfu-util-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0czq73m92ngf30asdzrfkzraag95hlrr74imbanqq25kdim8qhin"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libusb" ,libusb)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "Host side of the USB Device Firmware Upgrade (DFU) protocol")
+    (description
+     "The DFU (Universal Serial Bus Device Firmware Upgrade) protocol is
+intended to download and upload firmware to devices connected over USB.  It
+ranges from small devices like micro-controller boards up to mobile phones.
+With dfu-util you are able to download firmware to your device or upload
+firmware from it.")
+    (home-page "http://dfu-util.sourceforge.net/")
+    (license gpl2+)))
+
+(define-public teensy-loader-cli
+  ;; The repo does not tag versions nor does it use releases, but a commit
+  ;; message says "Importing 2.1", while the sourcce still says "2.0". So pin
+  ;; to a fixed commit.
+  (let ((commit "f289b7a2e5627464044249f0e5742830e052e360"))
+    (package
+      (name "teensy-loader-cli")
+      (version (string-append "2.1-1." (string-take commit 7)))
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "https://github.com/PaulStoffregen/"
+                             "teensy_loader_cli/archive/" commit ".tar.gz"))
+         (sha256 (base32 "17wqc2q4fa473cy7f5m2yiyb9nq0qw7xal2kzrxzaikgm9rabsw8"))
+         (file-name (string-append "teensy-loader-cli-" version ".tar.gz" ))
+         (modules '((guix build utils)))
+         (snippet
+          `(begin
+             ;; Remove example flash files and teensy rebooter flash binaries.
+             (for-each delete-file (find-files "." "\\.(elf|hex)$"))
+             ;; Fix the version
+             (substitute* "teensy_loader_cli.c"
+               (("Teensy Loader, Command Line, Version 2.0\\\\n")
+                (string-append "Teensy Loader, Command Line, " ,version "\\n")))
+             #t))
+       (patches (search-patches "teensy-loader-cli-help.patch"))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:tests? #f ;; Makefile has no test target
+         #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin")))
+                 (install-file "teensy_loader_cli" bin)
+                 #t))))))
+      (inputs
+       `(("libusb-compat" ,libusb-compat)))
+      (synopsis "Command line firmware uploader for Teensy development boards")
+      (description
+       "The Teensy loader program communicates with your Teensy board when the
+HalfKay bootloader is running, so you can upload new programs and run them.
+
+You need to add the udev rules to make the Teensy update available for
+non-root users.")
+      (home-page "https://www.pjrc.com/teensy/loader_cli.html")
+      (license gpl3))))