gnu: vips: Update to 8.7.4.
[jackhill/guix/guix.git] / gnu / packages / image-processing.scm
index a44bc08..296265c 100644 (file)
@@ -5,6 +5,9 @@
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2018 Lprndn <guix@lprndn.info>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix packages)
   #:use-module (guix utils)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages graphviz)
+  #:use-module (gnu packages gstreamer)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages maths)
+  #:use-module (gnu packages pdf)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages photo)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xml)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (ice-9 match))
 
 ;; We use the latest snapshot of this package because the latest release is
 ;; from 2011 and has known vulnerabilities that cannot easily be fixed by
@@ -138,15 +155,15 @@ of external libraries that provide additional functionality.")
 (define-public vtk
   (package
     (name "vtk")
-    (version "7.1.0")
+    (version "8.2.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.vtk.org/files/release/"
+              (uri (string-append "https://vtk.org/files/release/"
                                   (version-major+minor version)
                                   "/VTK-" version ".tar.gz"))
               (sha256
                (base32
-                "0yj96z58haan77gzilnqp7xpf8hg5jk11a3jx55p2ksd400s0gjz"))))
+                "1fspgp8k0myr6p2a6wkc21ldcswb4bvmb484m12mxgk1a9vxrhrl"))))
     (build-system cmake-build-system)
     (arguments
      '(#:build-type "Release"           ;Build without '-g' to save space.
@@ -179,7 +196,7 @@ of external libraries that provide additional functionality.")
        ("png" ,libpng)
        ("tiff" ,libtiff)
        ("zlib" ,zlib)))
-    (home-page "http://www.vtk.org/")
+    (home-page "https://vtk.org/")
     (synopsis "Libraries for 3D computer graphics")
     (description
      "The Visualization Toolkit (VTK) is a C++ library for 3D computer graphics,
@@ -191,3 +208,303 @@ triangulation.  VTK has an extensive information visualization framework, has
 a suite of 3D interaction widgets, supports parallel processing, and
 integrates with various databases on GUI toolkits such as Qt and Tk.")
     (license license:bsd-3)))
+
+(define-public opencv
+  (package
+    (name "opencv")
+    (version "3.4.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/opencv/opencv")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "06bc61r8myym4s8im10brdjfg4wxkrvsbhhl7vr1msdan2xddzi3"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Remove external libraries. We have all available in Guix:
+                  (delete-file-recursively "3rdparty")
+
+                  ;; Milky icon set is non-free:
+                  (delete-file-recursively "modules/highgui/src/files_Qt/Milky")
+
+                  ;; Some jars found:
+                  (for-each delete-file
+                            '("modules/java/test/pure_test/lib/junit-4.11.jar"
+                              "samples/java/sbt/sbt/sbt-launch.jar"))
+                  #t))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "-DWITH_IPP=OFF"
+             "-DWITH_ITT=OFF"
+             "-DWITH_CAROTENE=OFF" ; only visible on arm/aarch64
+             "-DENABLE_PRECOMPILED_HEADERS=OFF"
+
+             ;; CPU-Features:
+             ;; See cmake/OpenCVCompilerOptimizations.cmake
+             ;; (CPU_ALL_OPTIMIZATIONS) for a list of all optimizations
+             ;; BASELINE is the minimum optimization all CPUs must support
+             ;;
+             ;; DISPATCH is the list of optional dispatches.
+             "-DCPU_BASELINE=SSE2"
+
+             ,@(match (%current-system)
+                 ("x86_64-linux"
+                  '("-DCPU_DISPATCH=NEON;VFPV3;FP16;SSE;SSE2;SSE3;SSSE3;SSE4_1;SSE4_2;POPCNT;AVX;FP16;AVX2;FMA3;AVX_512F;AVX512_SKX"
+                    "-DCPU_DISPATCH_REQUIRE=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"))
+                 ("armhf-linux"
+                  '("-DCPU_BASELINE_DISABLE=NEON")) ; causes build failures
+                 ("aarch64-linux"
+                  '("-DCPU_BASELINE=NEON"
+                    "-DCPU_DISPATCH=NEON;VFPV3;FP16"))
+                 (_ '()))
+
+             "-DBUILD_PERF_TESTS=OFF"
+             "-DBUILD_TESTS=ON"
+
+             (string-append "-DOPENCV_EXTRA_MODULES_PATH=" (getcwd)
+                            "/opencv-contrib/modules")
+
+             ;;Define test data:
+             (string-append "-DOPENCV_TEST_DATA_PATH=" (getcwd)
+                            "/opencv-extra/testdata")
+
+             ;; Is ON by default and would try to rebuild 3rd-party protobuf,
+             ;; which we had removed, which would lead to an error:
+             "-DBUILD_PROTOBUF=OFF"
+
+             ;; Rebuild protobuf files, because we have a slightly different
+             ;; version than the included one. If we would not update, we
+             ;; would get a compile error later:
+             "-DPROTOBUF_UPDATE_FILES=ON"
+
+             ;; xfeatures2d disabled, because it downloads extra binaries from
+             ;; https://github.com/opencv/opencv_3rdparty
+             ;; defined in xfeatures2d/cmake/download_{vgg|bootdesc}.cmake
+             ;; Cmp this bug entry:
+             ;; https://github.com/opencv/opencv_contrib/issues/1131
+             "-DBUILD_opencv_xfeatures2d=OFF")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-broken-tests
+           (lambda _
+             ;; These tests fails with:
+             ;; vtkXOpenGLRenderWindow (0x723990): Could not find a decent config
+             ;; I think we have no OpenGL support with the Xvfb.
+             (substitute* '("modules/viz/test/test_tutorial3.cpp"
+                            "modules/viz/test/test_main.cpp"
+                            "modules/viz/test/tests_simple.cpp"
+                            "modules/viz/test/test_viz3d.cpp")
+               (("(TEST\\(Viz, )([a-z].*\\).*)" all pre post)
+                (string-append pre "DISABLED_" post)))
+
+             ;; This one fails with "unknown file: Failure"
+             ;; But I couldn't figure out which file was missing:
+             (substitute* "../opencv-contrib/modules/face/test/test_face_align.cpp"
+               (("(TEST\\(CV_Face_FacemarkKazemi, )(can_detect_landmarks\\).*)"
+                 all pre post)
+                (string-append pre "DISABLED_" post)))
+
+             ;; Failure reason: Bad accuracy
+             ;; Incorrect count of accurate poses [2nd case]: 90.000000 / 94.000000
+             (substitute* "../opencv-contrib/modules/rgbd/test/test_odometry.cpp"
+               (("(TEST\\(RGBD_Odometry_Rgbd, )(algorithmic\\).*)" all pre post)
+                (string-append pre "DISABLED_" post)))
+             #t))
+
+         (add-after 'unpack 'unpack-submodule-sources
+           (lambda* (#:key inputs #:allow-other-keys)
+             (mkdir "../opencv-extra")
+             (mkdir "../opencv-contrib")
+             (copy-recursively (assoc-ref inputs "opencv-extra")
+                               "../opencv-extra")
+             (invoke "tar" "xvf"
+                     (assoc-ref inputs "opencv-contrib")
+                     "--strip-components=1"
+                     "-C" "../opencv-contrib")))
+
+         (add-after 'set-paths 'add-ilmbase-include-path
+           (lambda* (#:key inputs #:allow-other-keys)
+           ;; OpenEXR propagates ilmbase, but its include files do not appear
+           ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
+           ;; the CPATH to satisfy the dependency on "ImathVec.h".
+           (setenv "CPATH"
+                   (string-append (assoc-ref inputs "ilmbase")
+                                  "/include/OpenEXR"
+                                  ":" (or (getenv "CPATH") "")))
+           #t))
+       (add-before 'check 'start-xserver
+         (lambda* (#:key inputs #:allow-other-keys)
+           (let ((xorg-server (assoc-ref inputs "xorg-server"))
+                 (disp ":1"))
+             (setenv "HOME" (getcwd))
+             (setenv "DISPLAY" disp)
+             ;; There must be a running X server and make check doesn't start one.
+             ;; Therefore we must do it.
+             (zero? (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp)))))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("xorg-server" ,xorg-server) ; For running the tests
+       ("opencv-extra"
+        ,(origin
+           (method git-fetch)
+           (uri (git-reference
+                  (url "https://github.com/opencv/opencv_extra")
+                  (commit version)))
+           (file-name (git-file-name "opencv_extra" version))
+           (sha256
+            (base32 "08p5xnq8n1jw8svvz0fnirfg7q8dm3p4a5dl7527s5xj0f9qn7lp"))))
+       ("opencv-contrib"
+        ,(origin
+           (method git-fetch)
+           (uri (git-reference
+                  (url "https://github.com/opencv/opencv_contrib")
+                  (commit version)))
+           (file-name (git-file-name "opencv_contrib" version))
+           (patches (search-patches "opencv-rgbd-aarch64-test-fix.patch"))
+           (sha256
+            (base32 "1f334glf39nk42mpqq6j732h3ql2mpz89jd4mcl678s8n73nfjh2"))))))
+    (inputs `(("libjpeg" ,libjpeg)
+              ("libpng" ,libpng)
+              ("jasper" ,jasper)
+              ;; ffmpeg 4.0 causes core dumps in tests.
+              ("ffmpeg" ,ffmpeg-3.4)
+              ("libtiff" ,libtiff)
+              ("hdf5" ,hdf5)
+              ("libgphoto2" ,libgphoto2)
+              ("libwebp" ,libwebp)
+              ("zlib" ,zlib)
+              ("gtkglext" ,gtkglext)
+              ("openexr" ,openexr)
+              ("ilmbase" ,ilmbase)
+              ("gtk+" ,gtk+-2)
+              ("python-numpy" ,python-numpy)
+              ("protobuf" ,protobuf)
+              ("vtk" ,vtk)
+              ("python" ,python)))
+    ;; These three CVEs are not a problem of OpenCV, see:
+    ;; https://github.com/opencv/opencv/issues/10998
+    (properties '((lint-hidden-cve . ("CVE-2018-7712"
+                                      "CVE-2018-7713"
+                                      "CVE-2018-7714"))))
+    (synopsis "Computer vision library")
+    (description "OpenCV is a library aimed at
+real-time computer vision, including several hundred computer
+vision algorithms.  It can be used to do things like:
+
+@itemize
+@item image and video input and output
+@item image and video processing
+@item displaying
+@item feature recognition
+@item segmentation
+@item facial recognition
+@item stereo vision
+@item structure from motion
+@item augmented reality
+@item machine learning
+@end itemize\n")
+    (home-page "https://opencv.org/")
+    (license license:bsd-3)))
+
+(define-public vips
+  (package
+    (name "vips")
+    (version "8.7.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/libvips/libvips/releases/download/v"
+             version "/vips-" version ".tar.gz"))
+       (sha256
+        (base32 "01gjhcrl6zj7mcj1al717v5jsniahplqhz1xkfh2j78vyfl1hxff"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("gobject-introspection" ,gobject-introspection)))
+    (inputs
+     `(("glib" ,glib)
+       ("libjpeg" ,libjpeg)
+       ("libpng" ,libpng)
+       ("librsvg" ,librsvg)
+       ("libtiff" ,libtiff)
+       ("libexif" ,libexif)
+       ("giflib" ,giflib)
+       ("libgsf" ,libgsf)
+       ("fftw" ,fftw)
+       ("poppler" ,poppler)
+       ("pango" ,pango)
+       ("lcms" ,lcms)
+       ("matio" ,matio)
+       ("libwebp" ,libwebp)
+       ("niftilib" ,niftilib)
+       ("openexr" ,openexr)
+       ("orc" ,orc)
+       ("imagemagick" ,imagemagick)
+       ("libxml2" ,libxml2)
+       ("expat" ,expat)
+       ("hdf5" ,hdf5)))
+    (home-page "https://libvips.github.io/libvips/")
+    (synopsis "Image processing system")
+    (description
+     "vips is a demand-driven, horizontally threaded image processing library.")
+    (license license:lgpl2.1+)))
+
+(define-public nip2
+  (package
+    (name "nip2")
+    (version "8.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/libvips/nip2/releases/download/v"
+                           version "/nip2-" version ".tar.gz" ))
+       (sha256
+        (base32 "0l7n427njif53npqn02gfjjly8y3khbrkzqxp10j5vp9h97psgiw"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; test_conv.ws keep failing so disabling for now.
+         (add-after 'unpack 'disable-test-conv
+           (lambda _
+             (delete-file "test/workspaces/test_conv.ws")
+             #t))
+         (add-before 'check 'set-home
+           (lambda _
+             (setenv "HOME" "/tmp") #t)))))
+    (inputs
+     `(("vips" ,vips)
+       ("glib" ,glib)
+       ("libtiff" ,libtiff)
+       ("gtk+-2" ,gtk+-2)
+       ("libxml2" ,libxml2)
+       ("libexif" ,libexif)
+       ("libjpeg" ,libjpeg)             ; required by vips.pc
+       ("librsvg" ,librsvg)
+       ("fftw" ,fftw)
+       ("libgsf" ,libgsf)
+       ("imagemagick" ,imagemagick)
+       ("orc" ,orc)
+       ("matio" ,matio)
+       ("lcms" ,lcms)
+       ("libwebp" ,libwebp)
+       ("openexr" ,openexr)
+       ("poppler" ,poppler)
+       ("gsl" ,gsl)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("bison" ,bison)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/libvips/nip2")
+    (synopsis "Spreadsheet-like GUI for libvips")
+    (description "This package provide a graphical user interface (GUI) for
+the VIPS image processing library.  It's a little like a spreadsheet: you
+create a set of formula connecting your objects together, and on a change nip2
+recalculates.")
+    (license license:gpl2+)))