gnu: Use 'modify-phases' syntax.
[jackhill/guix/guix.git] / gnu / packages / apr.scm
index de068ee..baadb41 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages apr)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix l:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages autotools))
 
 (define-public apr
   (package
     (name "apr")
-    (version "1.5.1")
+    (version "1.5.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://apache/apr/apr-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1b4qw686bwjn19iyb0lg918q23xxd6s2gnyczhjq992d3m1vwjp9"))
+               "0ypn51xblix5ys9xy7da3ngdydip0qqh9rdq8nz54w9aq8lys0vx"))
              (patches
-              (list (search-patch "apr-skip-getservbyname-test.patch")))
+              (search-patches "apr-skip-getservbyname-test.patch"))
              (patch-flags '("-p0"))))
     (build-system gnu-build-system)
     (arguments
      '(#:parallel-build? #f
        #:parallel-tests? #f))
     (inputs `(("perl" ,perl)
-              ("libtool" ,libtool)))
+              ("libltdl" ,libltdl)))
     (home-page "http://apr.apache.org/")
     (synopsis "The Apache Portable Runtime Library")
     (description
      "The mission of the Apache Portable Runtime (APR) project is to create and
 maintain software libraries that provide a predictable and consistent interface
-to underlying platform-specific implementations. The primary goal is to provide
+to underlying platform-specific implementations.  The primary goal is to provide
 an API to which software developers may code and be assured of predictable if
 not identical behaviour regardless of the platform on which their software is
 built, relieving them of the need to code special-case conditions to work
 around or take advantage of platform-specific deficiencies or features.")
-    (license asl2.0)))
+    (license l:asl2.0)))
 
 (define-public apr-util
   (package
     (name "apr-util")
-    (version "1.5.3")
+    (version "1.5.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://apache/apr/apr-util-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "0s1rpqjy5xr03k9s4xrsm5wvhj5286vlkf6jvqayw99yy5sb3vbq"))))
+               "0bn81pfscy9yjvbmyx442svf43s6dhrdfcsnkpxz43fai5qk5kx6"))))
     (build-system gnu-build-system)
     (inputs
-      `(("apr" ,apr)))
+     `(("apr" ,apr)))
+    (propagated-inputs
+     `(("expat" ,expat)))
     (arguments
      '(#:phases
-       (alist-replace
-        'configure
-        (lambda* (#:key inputs outputs #:allow-other-keys)
-          (let ((out (assoc-ref outputs "out"))
-                (apr (assoc-ref inputs "apr")))
-            (setenv "CONFIG_SHELL" (which "bash"))
-            (zero?
-             (system* "./configure"
-                      (string-append "--prefix=" out)
-                      (string-append "--with-apr=" apr)))))
-        %standard-phases)
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out   (assoc-ref outputs "out"))
+                   (apr   (assoc-ref inputs  "apr"))
+                   (expat (assoc-ref inputs  "expat")))
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (zero?
+                (system* "./configure"
+                         (string-append "--prefix=" out)
+                         (string-append "--with-apr=" apr)
+                         (string-append "--with-expat=" expat)))))))
 
        ;; There are race conditions during 'make check'.  Typically, the
        ;; 'testall' executable is not built yet by the time 'make check' tries
@@ -98,4 +102,4 @@ around or take advantage of platform-specific deficiencies or features.")
     (synopsis "One of the Apache Portable Runtime Library companions")
     (description
      "APR-util provides a number of helpful abstractions on top of APR.")
-    (license asl2.0)))
+    (license l:asl2.0)))