gnu: sdl-mixer: Enable fluidsynth MIDI backend.
[jackhill/guix/guix.git] / gnu / packages / mastodon.scm
index 028745f..54d4c53 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages check)
   #:use-module (gnu packages python-web)
-  #:use-module (gnu packages python-xyz)
-)
+  #:use-module (gnu packages python-xyz))
 
 (define-public toot
   (package
     (name "toot")
-    (version "0.21.0")
+    (version "0.24.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "toot" version))
         (sha256
-         (base32
-          "1dqv5jckaw3r7dnfns3iygwbfnf27x513qrw2rryzl5y79xrzs1x"))))
+         (base32 "0w83b6ydaggrand9285wfrjrm1qry8fjl4as0iihma630ky6y2w3"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
              (invoke "py.test"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
-    (propagated-inputs
+    (inputs
      `(("python-beautifulsoup4" ,python-beautifulsoup4)
        ("python-requests" ,python-requests)
+       ("python-urwid" ,python-urwid)
        ("python-wcwidth" ,python-wcwidth)))
     (home-page "https://github.com/ihabunek/toot/")
     (synopsis "Mastodon CLI client")