gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / multiprecision.scm
index a6130dc..16383d1 100644 (file)
 (define-public gmp
   (package
    (name "gmp")
-   (version "5.1.0")
+   (version "5.1.2")
    (source (origin
             (method url-fetch)
             (uri
-             ;; Note: this version is not available from GNU mirrors
-             ;; because it was made with an Automake affected by
-             ;; CVE-2012-3386.
-             (string-append "ftp://ftp.gmplib.org/pub/gmp-"
-                            version "/gmp-" version ".tar.bz2"))
+             (string-append "mirror://gnu/gmp/gmp-"
+                            version ".tar.xz"))
             (sha256
              (base32
-              "15n7xxgasbxdch8ii8z9ic6fxc2ysk3q8iavf55abjp5iylspnfz"))))
+              "1hnbxz7a6jrli8ph27i8zb6k2f456zn6l5xi78yhskzbxjk47nf7"))))
    (build-system gnu-build-system)
    (native-inputs `(("m4" ,m4)))
+   (outputs '("out" "debug"))
    (arguments `(#:configure-flags
                 '(;; Build a "fat binary", with routines for several
                   ;; sub-architectures.
@@ -73,14 +71,15 @@ faster algorithms.")
 (define-public mpfr
   (package
    (name "mpfr")
-   (version "3.1.1")
+   (version "3.1.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/mpfr/mpfr-" version
                                 ".tar.xz"))
             (sha256 (base32
-                     "0ym1ylcq803n52qrggxqmkz66gbn8ncc3ybawal31v5y5p1srma9"))))
+                     "0fs501qi8l523gs3cpy4jjcnvwxggyfbklcys80wq236xx3hz79r"))))
    (build-system gnu-build-system)
+   (outputs '("out" "debug"))
    (propagated-inputs `(("gmp" ,gmp)))            ; <mpfr.h> refers to <gmp.h>
    (synopsis "C library for arbitrary precision floating-point arithmetic")
    (description
@@ -106,6 +105,7 @@ double-precision floating-point arithmetic (53-bit mantissa).")
             (sha256 (base32
                      "1zq0fidp1jii2j5k5n9hmx55a6wwid33gjzhimvxq9d5zrf82npd"))))
    (build-system gnu-build-system)
+   (outputs '("out" "debug"))
    (propagated-inputs `(("gmp" ,gmp)              ; <mpc.h> refers to both
                         ("mpfr" ,mpfr)))
    (synopsis "C library for arbitrary precision complex arithmetic")