Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / oggvorbis.scm
index 888e571..0652ec3 100644 (file)
   #:use-module (gnu packages libpng)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages pulseaudio)
   #:use-module ((guix licenses)
                 #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:export (libogg
+            libvorbis
+            speex
+            ao
+            flac
+            libkate
+            vorbis-tools))
 
-(define-public libogg
+(define libogg
   (package
    (name "libogg")
    (version "1.3.0")
@@ -54,7 +63,7 @@ periodic timestamps for seeking.")
                                "See COPYING in the distribution."))
    (home-page "http://xiph.org/ogg/")))
 
-(define-public libvorbis
+(define libvorbis
   (package
    (name "libvorbis")
    (version "1.3.3")
@@ -66,7 +75,7 @@ periodic timestamps for seeking.")
              (base32
               "1gby6hapz9njx4l9g0pndyk4q83z5fgrgc30mfwfgx7bllspsk43"))))
    (build-system gnu-build-system)
-   (inputs `(("libogg" ,libogg)))
+   (propagated-inputs `(("libogg" ,libogg)))
    (arguments `(#:configure-flags '("LDFLAGS=-lm")))
    (synopsis "libvorbis, a library implementing the vorbis audio format")
    (description
@@ -79,7 +88,7 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
                                "See COPYING in the distribution."))
    (home-page "http://xiph.org/vorbis/")))
 
-(define-public speex
+(define speex
   (package
     (name "speex")
     (version "1.2rc1")
@@ -96,15 +105,15 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
     (home-page "https://gnu.org/software/speex")
     (synopsis "Library for patent-free audio compression format")
     (description
-     "GNU Speex is a patent-free voice codec.  It is designed to
-compress voice at bitrates in the 2--45 kbps range.  Possible
-applications include VoIP, internet audio streaming, archiving of speech
-data (e.g., voice mail), and audio books.")
+     "Speex is a patent-free audio compression codec specially designed for
+speech.  It is well-adapted to internet applications, such as VoIP. It
+features compression of different bands in the same bitstream, intensity
+stereo encoding, and voice activity detection.")
     ;; 'src/getopt.c' is under LGPLv2+
     (license (license:bsd-style "file://COPYING"
                                 "See COPYING in the distribution."))))
 
-(define-public ao
+(define ao
   (package
     (name "ao")
     (version "1.1.0")
@@ -118,9 +127,13 @@ data (e.g., voice mail), and audio books.")
         "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
     (build-system gnu-build-system)
     ;; FIXME: Add further backends, see the summary printed after configure.
-    (inputs `(("pkg-config" ,pkg-config)))
-    (synopsis
-     "libao, a cross platform audio library")
+    ;; XXX: Should back-ends be pushed to different outputs?  For instance,
+    ;; "out" would include only the ALSA back-end, while "pulse" would
+    ;; contains 'lib/ao/plugins-4/libpulse.*'.
+    (inputs `(("pkg-config" ,pkg-config)
+              ("alsa-lib" ,alsa-lib)
+              ("pulseaudio" ,pulseaudio)))
+    (synopsis "Cross platform audio library")
     (description
      "Libao is a cross-platform audio library that allows programs to
 output audio using a simple API on a wide variety of platforms.
@@ -145,7 +158,7 @@ OpenBSD's sndio.")
     (license license:gpl2+)
     (home-page "http://www.xiph.org/ao/")))
 
-(define-public flac
+(define flac
   (package
    (name "flac")
    (version "1.2.1")
@@ -155,16 +168,14 @@ OpenBSD's sndio.")
                                 version ".tar.gz"))
             (sha256
              (base32
-              "1pry5lgzfg57pga1zbazzdd55fkgk3v5qy4axvrbny5lrr5s8dcn"))))
+              "1pry5lgzfg57pga1zbazzdd55fkgk3v5qy4axvrbny5lrr5s8dcn"))
+            (patches
+             (list (search-patch "flac-fix-memcmp-not-declared.patch")))))
    (build-system gnu-build-system)
    (arguments
-    `(#:parallel-tests? #f
-      #:patches (list (assoc-ref %build-inputs
-                                 "patch/memcmp"))))
+    `(#:parallel-tests? #f))
    ;; FIXME: configure also looks for xmms, input could be added once it exists
-   (inputs `(("libogg" ,libogg)
-             ("patch/memcmp"
-                 ,(search-patch "flac-fix-memcmp-not-declared.patch"))))
+   (inputs `(("libogg" ,libogg)))
    (synopsis "flac free lossless audio codec")
    (description
 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
@@ -173,7 +184,7 @@ meaning that audio is compressed in FLAC without any loss in quality.")
                                "See COPYING in the distribution.")) ; and LGPL and GPL
    (home-page "http://xiph.org/flac/")))
 
-(define-public libkate
+(define libkate
   (package
    (name "libkate")
    (version "0.4.1")
@@ -190,7 +201,7 @@ meaning that audio is compressed in FLAC without any loss in quality.")
              ("libogg" ,libogg)
              ("libpng" ,libpng)
              ("pkg-config" ,pkg-config)
-             ("python" ,python)
+             ("python" ,python-wrapper)
              ("zlib" ,zlib)))
    (synopsis "kate, a karaoke and text codec for embedding in ogg")
    (description
@@ -208,7 +219,7 @@ Kate stream.")
    (license license:bsd-3)
    (home-page "http://code.google.com/p/libkate/")))
 
-(define-public vorbis-tools
+(define vorbis-tools
   (package
    (name "vorbis-tools")
    (version "1.4.0")