WIP: bees service
[jackhill/guix/guix.git] / gnu / packages / apl.scm
index 5750abb..badec04 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module ((gnu packages gettext)
-                #:renamer (symbol-prefix-proc 'guix:))
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages maths)
-  #:use-module (gnu packages readline))
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages readline)
+  #:use-module (gnu packages sqlite))
 
 (define-public apl
   (package
     (name "apl")
-    (version "1.1")
+    (version "1.8")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
       (sha256
        (base32
-        "1myinxa0m3y4fanpxflfakfk3m1s8641wdlbwbs0vg5yp10xm0m3"))))
+        "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/apl/")
+    (home-page "https://www.gnu.org/software/apl/")
     (inputs
-     `(("gettext" ,guix:gettext)
+     `(("gettext" ,gettext-minimal)
        ("lapack" ,lapack)
+       ("pcre" ,pcre2)
+       ("sqlite" ,sqlite)
        ("readline" ,readline)))
+    (arguments
+     `(#:configure-flags (list (string-append
+                                "--with-sqlite3="
+                                (assoc-ref %build-inputs "sqlite")))))
     (synopsis "APL interpreter")
     (description
      "GNU APL is a free interpreter for the programming language APL.  It is