gnu: hdf-java: Fix build.
[jackhill/guix/guix.git] / gnu / packages / php.scm
index 5ffe7c8..8d96e54 100644 (file)
@@ -2,6 +2,8 @@
 ;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,6 +30,7 @@
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
+  #:use-module (gnu packages dbm)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages gettext)
@@ -40,6 +43,7 @@
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
@@ -54,7 +58,7 @@
 (define-public php
   (package
     (name "php")
-    (version "7.3.0")
+    (version "7.3.3")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -62,7 +66,7 @@
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
+                "1cxrpaz5cvx1qq9klwgvcyvcly865sxpn4bdk82wpl43l5wkxc3b"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
                "--with-mysqli"          ; Required for, e.g. wordpress
                "--with-pdo-mysql"
                "--with-zlib"
+               "--enable-bcmath"        ; Required for, e.g. Zabbix frontend
                "--enable-calendar"
                "--enable-dba=shared"
                "--enable-exif"
                          ;; This bug should have been fixed in gd 2.2.2.
                          ;; Is it a regression?
                          "ext/gd/tests/bug65148.phpt"
+                         ;; These tests should not be run (disabled because
+                         ;; GD_BUNDLED = 0)
+                         "ext/gd/tests/bug77198_auto.phpt"
+                         "ext/gd/tests/bug77198_threshold.phpt"
+                         "ext/gd/tests/bug77200.phpt"
+                         "ext/gd/tests/bug77269.phpt"
                          ;; TODO: Enable these when libgd is built with xpm support.
                          "ext/gd/tests/xpm2gd.phpt"
                          "ext/gd/tests/xpm2jpg.phpt"
                          "ext/gd/tests/xpm2png.phpt"
+                         ;; Whitespace difference, probably caused by a very
+                         ;; long store path
+                         "ext/gd/tests/bug77479.phpt"
+                         ;; Slightly different result (NULL instead of false),
+                         ;; but the bug report suggests the issue was in
+                         ;; the bundled gd, not upstream.
+                         "ext/gd/tests/bug77272.phpt"
 
                          ;; XXX: These iconv tests have the expected outcome,
                          ;; but with different error messages.
                          ;; XXX: These test failures appear legitimate, needs investigation.
                          ;; open_basedir() restriction failure.
                          "ext/curl/tests/bug61948.phpt"
+                         ;; Fails on recent curl https://bugs.php.net/patch-display.php?bug_id=77493
+                         "ext/curl/tests/curl_basic_009.phpt"
                          ;; Expects a false boolean, gets empty array from glob().
                          "ext/standard/tests/file/bug41655_1.phpt"
                          "ext/standard/tests/file/glob_variation5.phpt"
                          "ext/mbstring/tests/mb_ereg_variation3.phpt"
                          "ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
                          "ext/mbstring/tests/bug72994.phpt"
+                         "ext/mbstring/tests/bug77367.phpt"
+                         "ext/mbstring/tests/bug77370.phpt"
+                         "ext/mbstring/tests/bug77371.phpt"
+                         "ext/mbstring/tests/bug77381.phpt"
                          "ext/ldap/tests/ldap_set_option_error.phpt"
 
                          ;; Sometimes cannot start the LDAP server.
@@ -351,10 +375,4 @@ systems, web content management systems and web frameworks." )
               license:expat))))                             ; ext/date/lib
 
 (define-public php-with-bcmath
-  (package
-    (inherit php)
-    (name "php-with-bcmath")
-    (arguments
-     (substitute-keyword-arguments (package-arguments php)
-       ((#:configure-flags flags)
-        `(cons "--enable-bcmath" ,flags))))))
+  (deprecated-package "php-with-bcmath" php))