build-system/gnu: Add 'bootstrap' phase.
[jackhill/guix/guix.git] / gnu / packages / microcom.scm
index cfa2518..67fd5fe 100644 (file)
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "git://git.pengutronix.de/git/tools/microcom.git")
+                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                     (commit "v2016.01.0")))
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
                 "080ci5589bpyy5kcl51csmvpw9zysify189hw6awx69pi3cjnxly"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'bootstrap
-           (lambda _
-             (zero? (system* "autoreconf" "-i")))))))
     (inputs `(("readline" ,readline)))
     (native-inputs `(("automake" ,automake)
                      ("autoconf" ,autoconf)))