gnu: msmtp: Update to 1.8.10.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
index f37c0ea..5bc3d19 100644 (file)
@@ -1,5 +1,8 @@
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;;
+;;; This file is part of GNU Guix.
 ;;;
 ;;; GNU Guix is free software; you can redistribute it and/or modify it
 ;;; under the terms of the GNU General Public License as published by
   #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
-  #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml))
 
 (define-public newsboat
   (package
     (name "newsboat")
-    (version "2.12")
+    (version "2.13")
     (source
      (origin
        (method url-fetch)
@@ -40,7 +48,7 @@
                            "/newsboat-" version ".tar.xz"))
        (sha256
         (base32
-         "1x23zlgljaqf46v7sp8wnkyf6wighvirvn48ankpa34yr8mvrgcv"))))
+         "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
@@ -76,12 +84,88 @@ interface that might look familiar to @command{mutt} or @command{slrn} users.
 
 Newsboat supports OPML import/exports, HTML rendering, podcasts (with
 @command{podboat}), off-line reading, searching and storing articles to your
-file system, and many more features.
-
-It started life as a fork of the currently unmaintained Newsbeuter.")
+file system, and many more features.")
     (license (list license:gpl2+        ; filter/*
                    license:expat))))    ; everything else
 
-(define-public newsbeuter
-  ;; Newsbeuter is unmaintained with multiple CVEs, and was forked as Newsboat.
-  (deprecated-package "newsbeuter" newsboat))
+(define-public rtv
+  (package
+    (name "rtv")
+    (version "1.27.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "rtv" version))
+        (sha256
+         (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-environment-variables
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "HOME" (getcwd))
+             (setenv "TERM" "linux")
+             (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
+                                               "/share/terminfo"))
+             #t)))
+       #:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
+    (propagated-inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-decorator" ,python-decorator)
+       ("python-kitchen" ,python-kitchen)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("ncurses" ,ncurses)
+       ("python-coveralls" ,python-coveralls)
+       ("python-coverage" ,python-coverage)
+       ("python-mock" ,python-mock)
+       ("python-pylint" ,python-pylint)
+       ("python-pytest" ,python-pytest)
+       ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://github.com/michael-lazar/rtv")
+    (synopsis "Terminal viewer for Reddit (Reddit Terminal Viewer)")
+    (description
+     "RTV provides a text-based interface to view and interact with Reddit.")
+    (license (list license:expat
+                   license:gpl3+)))) ; rtv/packages/praw
+
+(define-public tuir
+  (package
+    (name "tuir")
+    (version "1.28.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "tuir" version))
+        (sha256
+         (base32
+          "1gpyjrl7jdfjq30m32nzh59ajv91gq19l93jjri2wsv5yrf90hdr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest"))))))
+    (inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-decorator" ,python-decorator)
+       ("python-kitchen" ,python-kitchen)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-coveralls" ,python-coveralls)
+       ("python-mock" ,python-mock)
+       ("python-pylint" ,python-pylint)
+       ("python-pytest" ,python-pytest)
+       ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://gitlab.com/ajak/tuir")
+    (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
+    (description
+     "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
+    (license (list license:expat
+                   license:gpl3+))))    ; tuir/packages/praw