Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / imagemagick.scm
index 24e6214..16f9a6e 100644 (file)
@@ -5,7 +5,8 @@
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
     ;; The 7 release series has an incompatible API, while the 6 series is still
     ;; maintained. Don't update to 7 until we've made sure that the ImageMagick
     ;; users are ready for the 7-series API.
-    (version "6.9.10-3")
+    (version "6.9.10-46")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://imagemagick/ImageMagick-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0njq3vp0f3d5992jsah5nhbc5id2bnl7myhdw669k0vmc55mmlcj"))))
+               "1qx3x48q1dy39g1bb8mnyaq9jwy1smf0x6zfly4r0mj3m01i2dyb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--with-frozenpaths" "--without-gcc-arch")
@@ -157,7 +158,7 @@ text, lines, polygons, ellipses and Bézier curves.")
             ;; so skip for now.
             (delete-file "t/mpeg/read.t")
             #t)))))
-    (home-page "http://search.cpan.org/dist/PerlMagick")
+    (home-page "https://metacpan.org/release/PerlMagick")
     (synopsis "Perl interface to ImageMagick")
     (description "This Perl extension allows the reading, manipulation and
 writing of a large number of image file formats using the ImageMagick library.
@@ -169,19 +170,19 @@ script.")
 (define-public graphicsmagick
   (package
     (name "graphicsmagick")
-    (version "1.3.29")
-    (source (origin
-              (method url-fetch)
-              (uri
-                (list
-                  (string-append "mirror://sourceforge/" name "/" name
-                                 "/" version "/GraphicsMagick-" version ".tar.xz")
-                  (string-append "ftp://ftp.graphicsmagick.org/pub/"
-                                 "GraphicsMagick/" (version-major+minor version)
-                                 "/GraphicsMagick-" version ".tar.xz")))
-              (sha256
-               (base32
-                "1m0cc6kpky06lpcipj7rfwc2jbw2igr0jk97zqmw3j1ld5mg93g1"))))
+    (version "1.3.31")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (list
+         (string-append "mirror://sourceforge/graphicsmagick/graphicsmagick"
+                        "/" version "/GraphicsMagick-" version ".tar.xz")
+         (string-append "ftp://ftp.graphicsmagick.org/pub/"
+                        "GraphicsMagick/" (version-major+minor version)
+                        "/GraphicsMagick-" version ".tar.xz")))
+       (sha256
+        (base32 "0y22740f25qxsqqqg26xqlfp920dm57b7hrgaqmx7azksrcvnsq9"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags