gnu: Add AVR-Libc.
[jackhill/guix/guix.git] / gnu / packages / guile.scm
index e928c31..6a76baf 100644 (file)
@@ -210,9 +210,9 @@ or 2.0."
 "Guile-Reader is a simple framework for building readers for GNU Guile.
 
 The idea is to make it easy to build procedures that extend Guile’s read
-procedure. Readers supporting various syntax variants can easily be written,
+procedure.  Readers supporting various syntax variants can easily be written,
 possibly by re-using existing “token readers” of a standard Scheme
-readers. For example, it is used to implement Skribilo’s R5RS-derived
+readers.  For example, it is used to implement Skribilo’s R5RS-derived
 document syntax.
 
 Guile-Reader’s approach is similar to Common Lisp’s “read table”, but
@@ -232,15 +232,14 @@ many readers as needed).")
 (define-public guile-ncurses
   (package
     (name "guile-ncurses")
-    (version "1.4")
+    (version "1.6")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/guile-ncurses/guile-ncurses-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "070wl664lsm14hb6y9ch97x9q6cns4k6nxgdzbdzi5byixn74899"))
-             (patches (list (search-patch "guile-ncurses-tests.patch")))))
+               "0wmk681zzi1wxw543r2s2r84ndnzxp69kr7pc01aw4l55hg7jn73"))))
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)
               ("guile" ,guile-2.0)))
@@ -315,7 +314,7 @@ format is also supported.")
     (home-page "http://www.nongnu.org/guile-lib/")
     (synopsis "Collection of useful Guile Scheme modules")
     (description
-     "guile-lib is intended as an accumulation place for pure-scheme Guile
+     "Guile-Lib is intended as an accumulation place for pure-scheme Guile
 modules, allowing for people to cooperate integrating their generic Guile
 modules into a coherent library.  Think \"a down-scaled, limited-scope CPAN
 for Guile\".")
@@ -344,12 +343,12 @@ for Guile\".")
                  (("moddir =.*/share/guile/site" all)
                   (string-append all "/2.0"))))))
     (build-system gnu-build-system)
-    (inputs `(("guile" ,guile-2.0)))
+    (native-inputs `(("guile" ,guile-2.0)))
     (home-page "http://savannah.nongnu.org/projects/guile-json/")
     (synopsis "JSON module for Guile")
     (description
      "Guile-json supports parsing and building JSON documents according to the
-http:://json.org specification. These are the main features:
+http:://json.org specification.  These are the main features:
 - Strictly complies to http://json.org specification.
 - Build JSON documents programmatically via macros.
 - Unicode support for strings.