gnu: Add FIL plugins.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
index 0c92cc3..8f3e1a1 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 
 (define-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages)
-  #:use-module (gnu packages gdbm)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages mit-krb5)
-  #:use-module (gnu packages openssl)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (gnu packages tls)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
       ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
       ;; fail with EEXIST when building things in parallel.
       #:parallel-build? #f))
-   (synopsis "Cyrus SASL, an implementation of the Simple Authentication Security Layer framework")
+   (synopsis "Simple Authentication Security Layer implementation")
    (description
     "SASL (Simple Authentication Security Layer) is an Internet
-standards-track method for remote computers to authenticate. The Cyrus SASL
+standards-track method for remote computers to authenticate.  The Cyrus SASL
 library makes supporting various SASL mechanisms easy for both client and
 server writers.")
-   (license (license:bsd-style "file://COPYING"
-                       "See COPYING in the distribution."))
+   (license (license:non-copyleft "file://COPYING"
+                                  "See COPYING in the distribution."))
    (home-page "http://cyrusimap.web.cmu.edu/index.php")))