gnu: Add python-priority.
[jackhill/guix/guix.git] / gnu / packages / nim.scm
index 5694eae..b7ab8a3 100644 (file)
@@ -2,6 +2,7 @@
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,7 +28,7 @@
 (define-public nim
   (package
     (name "nim")
-    (version "0.17.2")
+    (version "1.0.6")
     (source
      (origin
       (method url-fetch)
@@ -35,7 +36,7 @@
                           name "-" version ".tar.xz"))
       (sha256
        (base32
-        "1gc2xk3ygmz9y4pm75pligssgw995a7gvnfpy445fjpw4d81pzxa"))))
+        "1cv6bxc7w21455c0pv0r2h64ljyzw266jsk1fsgiiyk2rx8mfkhk"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; No tests.
                  #t)))
            (add-after 'patch-source-shebangs 'patch-more-shebangs
              (lambda _
-               (substitute* (append '("tests/stdlib/tosprocterminate.nim"
-                                      "lib/pure/osproc.nim")
-                                    (find-files "c_code" "stdlib_osproc.c"))
-                 (("/bin/sh") (which "sh")))
+               (let ((sh (which "sh")))
+                 (substitute* '("tests/stdlib/tosprocterminate.nim"
+                                        "lib/pure/osproc.nim")
+                   (("/bin/sh") sh))
+                 (substitute* (find-files "c_code" "stdlib_osproc.c")
+                   (("\"/bin/sh\", 7") (format #f "~s, ~s" sh (string-length sh)))))
                #t))
            (replace 'build
              (lambda _