gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / regex.scm
index f526d1c..cb7a08e 100644 (file)
@@ -1,8 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,7 +30,7 @@
 (define-public re2
    (package
      (name "re2")
-     (version "2019-01-01")
+     (version "2020-07-06")
      (home-page "https://github.com/google/re2")
      (source (origin
                (method git-fetch)
@@ -38,7 +38,7 @@
                (file-name (git-file-name name version))
                (sha256
                 (base32
-                 "0wys8bbhj8ppgmgp3842qjmnvkynnzxrm8d7c3a3qyq3p6grqa29"))))
+                 "12a9r9y7ry3hq0qf4znl9j7pn9mb5k6xp1f8nrk1sagfj1a504mq"))))
      (build-system gnu-build-system)
      (arguments
       `(#:modules ((guix build gnu-build-system)
@@ -91,9 +91,9 @@ Python.  It is a C++ library.")
              ;; The tests require the availability of the
              ;; 'en_US.ISO-8859-1' locale.
              (setenv "LOCPATH" (getcwd))
-             (zero? (system* "localedef" "--no-archive"
-                             "--prefix" (getcwd) "-i" "en_US"
-                             "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
+             (invoke "localedef" "--no-archive"
+                     "--prefix" (getcwd) "-i" "en_US"
+                     "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
     (synopsis "Approximate regex matching library and agrep utility")
     (description "Superset of the POSIX regex API, enabling approximate
 matching.  Also ships a version of the agrep utility which behaves similar to