gnu: sudo: Apply workaround to build system for MIPS.
[jackhill/guix/guix.git] / gnu / packages / texinfo.scm
index dba5cd2..0f21ec3 100644 (file)
 (define-public texinfo
   (package
     (name "texinfo")
-    (version "5.0")
+    (version "5.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/texinfo/texinfo-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1p34f68h9ggfj6ckgj0p62qlj7pmz3ha3vc91kh4hr44pnwm1pla"))))
+               "1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
     (build-system gnu-build-system)
-    (inputs `(("perl" ,perl)                      ; yuck!
-              ("ncurses" ,ncurses)
-              ("xz" ,xz)))
+    (inputs `(("ncurses" ,ncurses)
+              ("xz" ,xz)
+              ("perl" ,perl)))
     (home-page "http://www.gnu.org/software/texinfo/")
-    (synopsis "GNU Texinfo, the GNU documentation system")
+    (synopsis "The GNU documentation format")
     (description
-     "Texinfo is the official documentation format of the GNU project.
-It was invented by Richard Stallman and Bob Chassell many years
-ago, loosely based on Brian Reid's Scribe and other formatting
-languages of the time.  It is used by many non-GNU projects as
-well.
-
-Texinfo uses a single source file to produce output in a number
-of formats, both online and printed (dvi, html, info, pdf, xml,
-etc.).  This means that instead of writing different documents
-for online information and another for a printed manual, you
-need write only one document.  And when the work is revised, you
-need revise only that one document.  The Texinfo system is
-well-integrated with GNU Emacs.")
+     "Texinfo is the official documentation format of the GNU project.  It
+uses a single source file using explicit commands to produce a final document
+in any of several supported output formats, such as HTML or PDF.  This
+package includes both the tools necessary to produce Info documents from
+their source and the command-line Info reader.  The emphasis of the language
+is on expressing the content semantically, avoiding physical markup commands.")
     (license gpl3+)))
+
+(define-public texinfo-4
+  (package (inherit texinfo)
+    (version "4.13a")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://gnu/texinfo/texinfo-"
+                    version
+                    ".tar.lzma"))
+              (sha256
+               (base32
+                "1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
+    (inputs `(("ncurses" ,ncurses) ("xz" ,xz)))))