gnu: libtasn1: Remove obsolete patch.
[jackhill/guix/guix.git] / gnu / packages / regex.scm
index f04cba7..2b32aa3 100644 (file)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix utils))
 
 (define-public re2
    (package
      (name "re2")
-     (version "2017-01-01")
+     (version "2017-05-01")
      (source (origin
                (method url-fetch)
                (uri
                (file-name (string-append name "-" version ".tar.gz"))
                (sha256
                 (base32
-                 "0yij1ajh66h3pj3kfz7y0ldrsww8rlpjzaavyr5lchl98as1jq74"))))
+                 "19glvic4ipd122yhcavf7ifg7ms5k61398vq7gyb90wggf2w0z9k"))))
      (build-system gnu-build-system)
      (arguments
-      `(#:test-target "test"
+      `(#:modules ((guix build gnu-build-system)
+                   (guix build utils)
+                   (srfi srfi-1))
+        #:test-target "test"
         ;; There is no configure step, but the Makefile respects a prefix.
-        #:make-flags (list (string-append "prefix=" %output))
+        ;; As ./configure does not know anything about the target CXX
+        ;; we need to specify TARGET-g++ explicitly.
+        #:make-flags (list (string-append "prefix=" %output)
+                           (string-append
+                             "CXX=" ,(string-append
+                                       (if (%current-target-system)
+                                           (string-append
+                                             (%current-target-system) "-")
+                                           "")
+                                       "g++")))
         #:phases
         (modify-phases %standard-phases
           (delete 'configure)