gnu: Remove cmake/fixed.
[jackhill/guix/guix.git] / gnu / packages / unrtf.scm
index 162dec7..de5ecf9 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix gexp)
+  #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages base))
 (define-public unrtf
   (package
     (name "unrtf")
-    (version "0.21.9")
+    (version "0.21.10")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/unrtf/unrtf-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1pcdzf2h1prn393dkvg93v80vh38q0v817xnbwrlwxbdz4k7i8r2"))
-             (modules '((guix build utils)))
-             (snippet
-              #~(begin
-                  ;; The tarball includes site-specific generated files.
-                  ;; Remove them.
-                  (for-each delete-file '("config.log" "config.h"))
-                  (for-each delete-file
-                            (find-files "." "^Makefile$"))
-
-                  ;; The config/ directory contains dangling symlinks to
-                  ;; /usr/share/automake.
-                  (for-each delete-file (find-files "config"))
-
-                  ;; Regenerate the whole thing.
-                  (setenv "PATH"
-                          (string-append #$autoconf "/bin:"
-                                         #$automake "/bin:"
-                                         #$m4 "/bin:"
-                                         #$grep "/bin:" #$sed "/bin:"
-                                         #$coreutils "/bin:"
-                                         (getenv "PATH")))
-                  (zero? (system* "autoreconf" "-vfi"))))))
+               "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/unrtf")
+    (home-page "https://www.gnu.org/software/unrtf/")
     (synopsis "Convert Rich Text Format documents to other formats")
     (description
      "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
 It supports changes in font characteristics, underlines and strikethroughs,
 superscripts and subscripts, and more.")
-    (license gpl2+)))
+    (license gpl3+)))