Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / telephony.scm
index 61bd1d3..d8a33dd 100644 (file)
@@ -2,6 +2,9 @@
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
+;;; Copyright © 2016 Francesco Frassinelli <fraph24@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages telephony)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages xiph)
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -59,21 +67,23 @@ reimplementation.")
 (define-public ucommon
   (package
    (name "ucommon")
-   (version "6.3.1")
+   (version "7.0.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/commoncpp/" name "-"
                    version ".tar.gz"))
             (sha256 (base32
-                     "1marbwbqnllhm9nh22lvyfjy802pgy1wx7j7kkpkasbm9r0sb6mm"))))
+                     "1mv080rvrhyxyhgqiqr8r9jdqhg3xhfawjvfj5zgj47h59nggjba"))))
    (build-system gnu-build-system)
+   (inputs `(("gnutls" ,gnutls)))
    (synopsis "Common C++ framework for threaded applications")
    (description "GNU uCommon C++ is meant as a very light-weight C++ library
 to facilitate using C++ design patterns even for very deeply embedded
 applications, such as for systems using uclibc along with posix threading
 support.")
-   (license gpl2+) ; plus runtime exception
-   (home-page "http://www.gnu.org/software/commoncpp")))
+   (license gpl3+)
+   (home-page "http://www.gnu.org/software/commoncpp")
+   (properties '((ftp-directory . "/gnu/commoncpp")))))
 
 (define-public ccrtp
   (package
@@ -124,7 +134,7 @@ to initiate and control SIP sessions.")
    (version "4.1.0")
    (source (origin
             (method url-fetch)
-            (uri (string-append 
+            (uri (string-append
                   "http://download.savannah.gnu.org/releases/exosip/libeXosip2-"
                   version ".tar.gz"))
             (sha256 (base32
@@ -133,11 +143,11 @@ to initiate and control SIP sessions.")
    (inputs `(("osip" ,osip)))
    (synopsis "Sip abstraction library")
    (description "EXosip is a library that hides the complexity of using the
-SIP protocol for mutlimedia session establishement.  This protocol is mainly to
+SIP protocol for multimedia session establishment.  This protocol is mainly to
 be used by VoIP telephony applications (endpoints or conference server) but
-might be also usefull for any application that wish to establish sessions like
+might be also useful for any application that wish to establish sessions like
 multiplayer games.")
-   (license gpl2+) 
+   (license gpl2+)
    ;; (plus OpenSSL linking exception)
    ;; http://git.savannah.gnu.org/cgit/exosip.git/plain/LICENSE.OpenSSL
     (home-page "http://savannah.nongnu.org/projects/exosip")))
@@ -145,31 +155,31 @@ multiplayer games.")
 (define-public sipwitch
   (package
    (name "sipwitch")
-   (version "1.9.7")
+   (version "1.9.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/sipwitch/sipwitch-"
                    version ".tar.gz"))
             (sha256 (base32
-                     "07a069cx35pndl96c9v3vsyjcmrrr97xnv37k74m21q31isc458c"))))
+                     "10lli9c703d7qbarzc0lgmz963ppncvnrklwrnri0s1zcmmahyia"))))
    (build-system gnu-build-system)
-   ;; The configure.ac uses pkg-config but in a kludgy way which breaks when 
+   ;; The configure.ac uses pkg-config but in a kludgy way which breaks when
    ;; cross-compiling.  Among other issues there the program name "pkg-config"
    ;; is hard coded instead of respecting the PKG_CONFIG environment variable.
-   ;; Fortunately we can avoid the use of pkg-config and set the dependency 
-   ;; flags ourselves. 
-   (arguments `(#:configure-flags 
+   ;; Fortunately we can avoid the use of pkg-config and set the dependency
+   ;; flags ourselves.
+   (arguments `(#:configure-flags
                 `("--without-pkg-config"
-                  ,(string-append "UCOMMON_CFLAGS=-I" 
+                  ,(string-append "UCOMMON_CFLAGS=-I"
                                   (assoc-ref %build-inputs "ucommon") "/include")
                   "UCOMMON_LIBS=-lusecure -lucommon -lrt -ldl -lpthread"
-                  ,(string-append "LIBOSIP2_CFLAGS=-I" 
+                  ,(string-append "LIBOSIP2_CFLAGS=-I"
                                   (assoc-ref %build-inputs "osip") "/include")
                   "LIBOSIP2_LIBS=-losipparser2 -losip2"
-                  ,(string-append "--sysconfdir=" (assoc-ref %outputs "out") 
+                  ,(string-append "--sysconfdir=" (assoc-ref %outputs "out")
                                   "/etc")
                   "EXOSIP2_LIBS=-leXosip2"
-                  ,(string-append "EXOSIP2_CFLAGS=-I" 
+                  ,(string-append "EXOSIP2_CFLAGS=-I"
                                   (assoc-ref %build-inputs "exosip")
                                   "/include"))))
    (inputs `(("ucommon" ,ucommon)
@@ -188,14 +198,14 @@ internet.")
 (define-public libsrtp
   (package
     (name "libsrtp")
-    (version "1.5.2")
+    (version "1.5.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/cisco/libsrtp/archive/v"
                                   version ".tar.gz"))
              (sha256
               (base32
-               "1njf62f6sazz2q7qc4j495v1pga385whkmxxyr8hfz1ragiyzqc6"))))
+               "1w2g623qkd7gdyydglx2hr4s2y237lg0nszjmy7z8d2iq8hvb9sn"))))
     (native-inputs
      `(("procps" ,procps)))
     (build-system gnu-build-system)
@@ -207,3 +217,72 @@ Real-time Transport Protocol (SRTP), the Universal Security Transform (UST),
 and a supporting cryptographic kernel.")
     (home-page "https://github.com/cisco/libsrtp")
     (license bsd-3)))
+
+(define-public libiax2
+  (let ((commit "0e5980f1d78ce462e2d1ed6bc39ff35c8341f201"))
+    ;; This is the commit used by the Ring Project.
+    (package
+      (name "libiax2")
+      (version (string-append "0.0.0-1." (string-take commit 7)))
+      (source
+       (origin
+         (method url-fetch)
+         (uri
+          (string-append
+           "https://gitlab.savoirfairelinux.com/sflphone/libiax2/"
+           "repository/archive.tar.gz?ref="
+           commit))
+         (file-name (string-append name "-" version ".tar.gz"))
+         (sha256
+          (base32
+           "0cj5293bixp3k5x3hjwyd0iq7z8w5p7yavxvvkqk5817hjq386y2"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("libtool" ,libtool)))
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (add-before 'configure 'autoconf
+                      (lambda _
+                        (zero? (system* "autoreconf" "-vfi")))))))
+      (home-page "https://gitlab.savoirfairelinux.com/sflphone/libiax2")
+      (synopsis "Inter-Asterisk-Protocol library")
+      (description "LibIAX2 implements the Inter-Asterisk-Protocol for relaying
+Voice-over-IP (VoIP) communications.")
+      ;; The file 'src/md5.c' is released into the public domain by RSA Data
+      ;; Security.  The files 'src/answer.h', 'src/miniphone.c',
+      ;; 'src/options.c', 'src/options.h', 'src/ring10.h', 'src/winiphone.c' are
+      ;; covered under the 'GPL'.
+      ;; The package as a whole is distributed under the LGPL 2.0.
+      (license (list lgpl2.0 public-domain gpl2+)))))
+
+(define-public seren
+  (package
+    (name "seren")
+    (version "0.0.21")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://holdenc.altervista.org/"
+                                  "seren/downloads/seren-" version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "06mams6bng7ib7p2zpfq88kdr4ffril9svzc9lprkb0wjgmkglk9"))))
+    (build-system gnu-build-system)
+    (arguments '(#:tests? #f))  ; no "check" target
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("gmp" ,gmp)
+       ("libogg" ,libogg)
+       ("ncurses" ,ncurses)
+       ("opus" ,opus)))
+    (synopsis "Simple VoIP program to create conferences from the terminal")
+    (description
+     "Seren is a simple VoIP program based on the Opus codec that allows you
+to create a voice conference from the terminal, with up to 10 participants,
+without having to register accounts, exchange emails, or add people to contact
+lists.  All you need to join an existing conference is the host name or IP
+address of one of the participants.")
+    (home-page "http://holdenc.altervista.org/seren/")
+    (license gpl3+)))