gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / lxde.scm
index cad5282..f81d7af 100644 (file)
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 ison <ison@airmail.cc>
 ;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -66,7 +66,7 @@
 (define-public libfm
   (package
     (name "libfm")
-    (version "1.3.1")
+    (version "1.3.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcmanfm/"
@@ -74,7 +74,7 @@
                                   "%29/LibFM/" name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1r6gl49xrykldwz8y4h2s7gjarxigg3bbkrj0gphxjj1vr5j9ccn"))))
+                "1rfira3lx8v6scz1aq69925j4vslpp36bmgrrzcfby2c60q2c155"))))
     (build-system gnu-build-system)
     (inputs `(("glib" ,glib)
               ("gtk+" ,gtk+-2)))
@@ -87,7 +87,7 @@
     (synopsis "File management support (core library)")
     (description "LibFM provides file management functions built on top of
 Glib/GIO giving a higher-level API.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public libfm-extra
@@ -99,7 +99,7 @@ Glib/GIO giving a higher-level API.")
                      ("libtool"    ,libtool)
                      ("pkg-config" ,pkg-config)))
     (synopsis "File management support (extra library)")
-    (description "This package contains standalone library which extends the
+    (description "This package contains a stand-alone library which extends the
 libFM file management library.")))
 
 (define-public lxappearance
@@ -120,7 +120,7 @@ libFM file management library.")))
     (synopsis "LXDE GTK+ theme switcher")
     (description "LXAppearance is a desktop-independent GTK+ theme switcher
 able to change themes, icons, and fonts used by GTK+ applications.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxrandr
@@ -158,13 +158,13 @@ relies on the X11 resize-and-rotate (RandR) extension but doesn't aim to be a
 full frontend of it.  LXRandR only gives you some easy and quick options which
 are intuitive.  It's suitable for laptop users who frequently uses projectors
 or external monitor.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxtask
   (package
     (name "lxtask")
-    (version "0.1.9")
+    (version "0.1.10")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/lxde/LXTask"
@@ -173,7 +173,7 @@ or external monitor.")
                                   "lxtask-" version ".tar.xz"))
               (sha256
                (base32
-                "0cv4hx5dg01hbyi5p10pl78n0a40xajpq4wx9c7886pkmpq8isj1"))))
+                "0b2fxg8jjjpk219gh7qa18g45365598nd2bq7rrq0bdvqjdxy5i2"))))
     (build-system gnu-build-system)
     (inputs `(("gtk+" ,gtk+-2)))
     (native-inputs `(("intltool"   ,intltool)
@@ -182,7 +182,7 @@ or external monitor.")
     (description "LXTask is a lightweight task manager derived from Xfce task
 manager with all dependencies on Xfce removed.  LXTask is based on the GTK+
 toolkit.  It allows users to monitor and control of running processes.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxterminal
@@ -207,7 +207,7 @@ toolkit.  It allows users to monitor and control of running processes.")
 multiple tabs and has only minimal dependencies thus being completely
 desktop-independent.  In order to reduce memory usage and increase the
 performance, all instances of the terminal are sharing a single process.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public menu-cache
@@ -229,13 +229,13 @@ performance, all instances of the terminal are sharing a single process.")
     (synopsis "LXDE implementation of the freedesktop menu's cache")
     (description "Menu-cache is a library creating and utilizing caches to
 speed up the access to freedesktop.org defined application menus.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:lgpl2.1+)))
 
 (define-public pcmanfm
   (package
     (name "pcmanfm")
-    (version "1.3.1")
+    (version "1.3.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcmanfm/"
@@ -243,7 +243,7 @@ speed up the access to freedesktop.org defined application menus.")
                                   "%29/PCManFM/pcmanfm-" version ".tar.xz"))
               (sha256
                (base32
-                "0mb8hg76x1z0szdyl0w7jpz0bdblc6a29is1vvnh79z37qxh8138"))))
+                "1xqc2k2jh165mm81xg0ghxx0ml1s3rhh4ndvbzkcri4kfhj7pjql"))))
     (build-system gnu-build-system)
     (inputs `(("gtk+"   ,gtk+-2)
               ("gvfs"   ,gvfs)          ; for trash and mount support
@@ -257,7 +257,7 @@ speed up the access to freedesktop.org defined application menus.")
     (synopsis "LXDE file manager")
     (description "PCMan is a lightweight GTK+ based file manager, compliant
 with freedesktop.org standard.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public spacefm
@@ -270,7 +270,7 @@ with freedesktop.org standard.")
        (method git-fetch)
        (uri
         (git-reference
-         (url "https://github.com/IgnorantGuru/spacefm.git")
+         (url "https://github.com/IgnorantGuru/spacefm")
          (commit version)))
        (file-name (git-file-name name version))
        (sha256
@@ -440,7 +440,7 @@ customizable menu system, and Bash integration.")
     (description
      "Lxmenu-data provides files required to build freedesktop.org
 menu spec-compliant desktop menus for LXDE.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:lgpl2.1+)))
 
 (define-public lxde-icon-theme
@@ -461,7 +461,7 @@ menu spec-compliant desktop menus for LXDE.")
     (synopsis "LXDE default icon theme based on nuoveXT2")
     (description
      "Lxde-icon-theme provides an default icon theme for LXDE.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:lgpl3)))
 
 (define-public lxde-common
@@ -500,7 +500,7 @@ menu spec-compliant desktop menus for LXDE.")
     (synopsis "Common files of the LXDE Desktop")
     (description
      "Lxde-common provides common files of the LXDE Desktop.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxinput
@@ -525,7 +525,7 @@ menu spec-compliant desktop menus for LXDE.")
     (description
      "Lxinput provides a small program to configure keyboard and mouse
 in LXDE.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxsession
@@ -578,7 +578,7 @@ in LXDE.")
     (synopsis "Lightweight X11 session manager")
     (description
      "Lxsession provides an lightweight X11 session manager.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxpanel
@@ -629,7 +629,7 @@ in LXDE.")
     (synopsis "X11 Desktop panel for LXDE")
     (description
      "Lxpanel provides an X11 desktop panel for LXDE.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+)))
 
 (define-public lxde
@@ -668,7 +668,7 @@ user friendly and slim, while keeping the resource usage low.  LXDE uses
 less RAM and less CPU while being a feature rich desktop environment.  Unlike
 other tightly integrated desktops LXDE strives to be modular, so each
 component can be used independently with few dependencies.")
-    (home-page "https://lxde.org")
+    (home-page "https://lxde.github.io")
     (license license:gpl2+))) ; And others.
 
 ;;; lxde.scm ends here