gnu: Add PadWalker.
[jackhill/guix/guix.git] / gnu / packages / texlive.scm
index f562732..f757350 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17,8 +19,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages texlive)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages which)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages tcsh)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages zip)
   #:autoload   (gnu packages texinfo) (texinfo))
 
 (define texlive-extra-src
   (origin
     (method url-fetch)
-    (uri "ftp://tug.org/historic/systems/texlive/2013/texlive-20130530-extra.tar.xz")
+    (uri "ftp://tug.org/historic/systems/texlive/2014/texlive-20140525-extra.tar.xz")
     (sha256 (base32
-              "15r1qyn7x1iamiiycylx8vzsg27h1r962v6dz9q70f9pdp2rjr6s"))))
+              "1zlnjysvxskcy05iva6jfklirwv12wqyn3ia119a7xnqlvhpqz33"))))
 
 (define texlive-texmf-src
   (origin
     (method url-fetch)
-    (uri "ftp://tug.org/historic/systems/texlive/2013/texlive-20130530-texmf.tar.xz")
+    (uri "ftp://tug.org/historic/systems/texlive/2014/texlive-20140525-texmf.tar.xz")
     (sha256 (base32
-              "09kza0ha0x9cm4k2qm9w31h3g94y9hy17jahnnsirqyy8rpdqgwg"))))
+              "0qsr55ms1278dhmgixs5qqwd4fxhh369ihkki6wgh8xaqm8p48p0"))))
 
 (define-public texlive
   (package
    (name "texlive")
-   (version "2013")
+   (version "2014")
    (source (origin
             (method url-fetch)
-            (uri "ftp://tug.org/historic/systems/texlive/2013/texlive-20130530-source.tar.xz")
+            (uri "ftp://tug.org/historic/systems/texlive/2014/texlive-20140525-source.tar.xz")
             (sha256 (base32
-                     "1m3ripkmra53jwkaqcxxhabc3yvqrfm7pfxldnqirp849hp861d9"))))
+                     "1glmaw2jv42grbsn05kay825j66scimjqqc32776bb1356q4xfq8"))))
    (build-system gnu-build-system)
    (inputs `(("texlive-extra-src" ,texlive-extra-src)
              ("texlive-texmf-src" ,texlive-texmf-src)
              ("cairo" ,cairo)
              ("fontconfig" ,fontconfig)
+             ("fontforge" ,fontforge)
              ("freetype" ,freetype)
              ("gd" ,gd)
-             ("icu4c" ,icu4c)
              ("ghostscript" ,ghostscript)
+             ("graphite2" ,graphite2)
+             ("harfbuzz" ,harfbuzz)
+             ("icu4c" ,icu4c)
+             ("libpaper" ,libpaper)
              ("libpng" ,libpng)
              ("libxaw" ,libxaw)
              ("libxt" ,libxt)
+             ("perl" ,perl)
              ("pixman" ,pixman)
              ("poppler" ,poppler)
-             ;; FIXME: Add interpreters fontforge and ruby,
-             ;; once they are available.
+             ("potrace" ,potrace)
+             ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+             ("ruby" ,ruby)
+             ("tcsh" ,tcsh)
              ("teckit" ,teckit)
-             ("t1lib" ,t1lib)
              ("zlib" ,zlib)
              ("zziplib" ,zziplib)))
    (native-inputs
-    `(("perl" ,perl)
-      ("pkg-config" ,pkg-config)
-      ("python" ,python-2) ; incompatible with Python 3 (print syntax)
-      ("tcsh" ,tcsh)))
+    `(("pkg-config" ,pkg-config)))
    (outputs '("out" "data"))
    (arguments
     `(#:out-of-source? #t
          "--with-system-cairo"
          "--with-system-freetype2"
          "--with-system-gd"
-         ;; "--with-system-graphite2"  ; requires cmake build system
-         ;; "--with-system-harfbuzz"   ; requires --with-system-graphite2
+         "--with-system-graphite2"
+         "--with-system-harfbuzz"
          "--with-system-icu"
          "--with-system-libgs"
+         "--with-system-libpaper"
          "--with-system-libpng"
          "--with-system-pixman"
          "--with-system-poppler"
-         "--with-system-t1lib"
+         "--with-system-potrace"
          "--with-system-teckit"
          "--with-system-xpdf"
          "--with-system-zlib"
          "--with-system-zziplib")
+
+      ;; Disable tests on mips64 to cope with a failure of luajiterr.test.
+      ;; XXX FIXME fix luajit properly on mips64.
+      #:tests? ,(not (string-prefix? "mips64" (or (%current-target-system)
+                                                  (%current-system))))
       #:phases
-       (alist-cons-before
-        'configure 'patch-perl-shebang
-        (lambda _
-          (substitute* "utils/psutils/Makefile.in"
-            (("/usr/bin/env perl") (which "perl"))))
        (alist-cons-after
         'install 'postinst
          (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
              (system* "updmap-sys" "--nohash" "--syncwithtrees")
              (system* "mktexlsr")
              (system* "fmtutil-sys" "--all")))
-       %standard-phases)))))
+       %standard-phases))))
    (synopsis "Tex Live, a package of the TeX typesetting system")
    (description
     "TeX Live provides a comprehensive TeX document production system.
@@ -204,7 +211,7 @@ world.")
               ("python" ,python-2) ; incompatible with Python 3 (print syntax)
               ("which" ,which)))
     (home-page "https://launchpad.net/rubber")
-    (synopsis "Rubber, a wrapper for LaTeX and friends")
+    (synopsis "Wrapper for LaTeX and friends")
     (description
      "Rubber is a program whose purpose is to handle all tasks related to the
 compilation of LaTeX documents.  This includes compiling the document itself,